aboutsummaryrefslogtreecommitdiff
path: root/x11/xfce4-terminal/Makefile
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-09-30 20:46:08 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-09-30 20:46:08 +0000
commit7084a9046330b3b6e85600840cc25029daa836b1 (patch)
treed2e4a3bed47029ee84cc21a63456fa1ac7d2fa28 /x11/xfce4-terminal/Makefile
parentfe188cfb428b857befe2064a2b8b510a2083b01b (diff)
downloadports-7084a9046330b3b6e85600840cc25029daa836b1.tar.gz
ports-7084a9046330b3b6e85600840cc25029daa836b1.zip
x11/xfce4-terminal: fix build on GCC architectures
Use C11 compiler: In file included from /usr/local/include/xfce4/libxfce4util/libxfce4util.h:33, from /usr/local/include/xfce4/libxfce4ui-2/libxfce4ui/libxfce4ui.h:23, from terminal-window.c:35: /usr/local/include/xfce4/libxfce4util/xfce-kiosk.h:37: error: redefinition of typedef 'XfceKiosk' /usr/local/include/xfce4/libxfce4util/xfce-kiosk.h:35: error: previous declaration of 'XfceKiosk' was here Approved by: mentors (implicit approval)
Notes
Notes: svn path=/head/; revision=513415
Diffstat (limited to 'x11/xfce4-terminal/Makefile')
-rw-r--r--x11/xfce4-terminal/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/x11/xfce4-terminal/Makefile b/x11/xfce4-terminal/Makefile
index 44f4e283f618..b61e7e2073d0 100644
--- a/x11/xfce4-terminal/Makefile
+++ b/x11/xfce4-terminal/Makefile
@@ -14,7 +14,8 @@ COMMENT= Terminal emulator for the X windowing system
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gettext-tools gmake gnome pkgconfig tar:bzip2 xfce xorg
+USES= compiler:c11 gettext-tools gmake gnome pkgconfig tar:bzip2 \
+ xfce xorg
USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 intltool libxml2 vte3
USE_XFCE= libmenu xfconf
USE_XORG= ice sm x11