aboutsummaryrefslogtreecommitdiff
path: root/x11/xfce4-verve-plugin
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-05-01 16:13:45 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-05-01 16:13:45 +0000
commitb2aa13a92865516b92b02fd7e4e525286962c5da (patch)
treea52b3e5e36c4436205a5718d25629f949f39af77 /x11/xfce4-verve-plugin
parent6789dd6575a7dc3d7b58569b79477186441e24bf (diff)
downloadports-b2aa13a92865516b92b02fd7e4e525286962c5da.tar.gz
ports-b2aa13a92865516b92b02fd7e4e525286962c5da.zip
- conversion to USES framework
Approved by: portmgr (bapt@)
Notes
Notes: svn path=/head/; revision=317031
Diffstat (limited to 'x11/xfce4-verve-plugin')
-rw-r--r--x11/xfce4-verve-plugin/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/x11/xfce4-verve-plugin/Makefile b/x11/xfce4-verve-plugin/Makefile
index de313a3ecba8..f61194d9b24a 100644
--- a/x11/xfce4-verve-plugin/Makefile
+++ b/x11/xfce4-verve-plugin/Makefile
@@ -12,7 +12,7 @@ PKGNAMEPREFIX= xfce4-
DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= xfce@FreeBSD.org
-COMMENT= A command line plugin for Xfce4
+COMMENT= Command line plugin for Xfce4
LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
@@ -20,18 +20,18 @@ USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack glib20 intltool intlhack
+USE_GNOME= glib20 intltool intlhack
USE_XFCE= configenv panel libexo libgui libutil
-USES= pkgconfig
+USES= pkgconfig pathfix
CONFIGURE_ARGS= --disable-debug
OPTIONS_DEFINE= NLS DBUS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
.else
@@ -48,4 +48,4 @@ CONFIGURE_ARGS+=--disable-dbus
PLIST_SUB+= DBUS="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>