aboutsummaryrefslogtreecommitdiff
path: root/x11/xgrab
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-09-09 19:31:28 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-09-09 19:31:28 +0000
commitf86ce48e8699e27878f3cbe06315fe01be761c6f (patch)
tree041e395f21c13c192ea0811a356afd1a36b04fea /x11/xgrab
parentefd0d5fc6e279984ac610a97d55f4ccd5ce5016b (diff)
downloadports-f86ce48e8699e27878f3cbe06315fe01be761c6f.tar.gz
ports-f86ce48e8699e27878f3cbe06315fe01be761c6f.zip
Add USE_XORG=xaw. Not clear how this was building successfully before.
While here, include stdlib.h to quiet warnings about exit.
Notes
Notes: svn path=/head/; revision=367770
Diffstat (limited to 'x11/xgrab')
-rw-r--r--x11/xgrab/Makefile2
-rw-r--r--x11/xgrab/files/patch-xgrabsc.h10
2 files changed, 11 insertions, 1 deletions
diff --git a/x11/xgrab/Makefile b/x11/xgrab/Makefile
index e6d968098fdc..c75f8c4fcfd5 100644
--- a/x11/xgrab/Makefile
+++ b/x11/xgrab/Makefile
@@ -15,7 +15,7 @@ COMMENT= X11 image grabber
BUILD_DEPENDS= xrdb:${PORTSDIR}/x11/xrdb
USES= display:build imake:notall tar:Z
-USE_XORG= x11
+USE_XORG= x11 xaw
MAKE_FLAGS= BINDIR=${PREFIX}/bin MANDIR=${PREFIX}/man/man1 \
XAPPLOADDIR=${PREFIX}/lib/X11/app-defaults -f
diff --git a/x11/xgrab/files/patch-xgrabsc.h b/x11/xgrab/files/patch-xgrabsc.h
new file mode 100644
index 000000000000..4232da27ecc4
--- /dev/null
+++ b/x11/xgrab/files/patch-xgrabsc.h
@@ -0,0 +1,10 @@
+--- xgrabsc.h.orig 2014-09-09 19:24:54 UTC
++++ xgrabsc.h
+@@ -43,6 +43,7 @@
+ #include "cmdopts.h"
+
+ #include <stdio.h>
++#include <stdlib.h>
+
+ #include <X11/Xos.h>
+ #include <X11/Xlib.h>