aboutsummaryrefslogtreecommitdiff
path: root/x11/xloadimage/Makefile
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2013-09-25 19:25:12 +0000
committerAlex Kozlov <ak@FreeBSD.org>2013-09-25 19:25:12 +0000
commitad5a8dfacbea03375a65fede4a2b3dd949e0e346 (patch)
tree5e7ba17312dc4c6dfff041fce42d024cc1bd51fe /x11/xloadimage/Makefile
parent9b81a00e02ad5d1703f9fbdc0ea734064be1f286 (diff)
downloadports-ad5a8dfacbea03375a65fede4a2b3dd949e0e346.tar.gz
ports-ad5a8dfacbea03375a65fede4a2b3dd949e0e346.zip
- Support STAGEDIR
- Convert to new LIB_DEPENDS syntax Reviewed by: eadler
Notes
Notes: svn path=/head/; revision=328308
Diffstat (limited to 'x11/xloadimage/Makefile')
-rw-r--r--x11/xloadimage/Makefile30
1 files changed, 13 insertions, 17 deletions
diff --git a/x11/xloadimage/Makefile b/x11/xloadimage/Makefile
index 24d38f2d52c2..4f24c6e8249b 100644
--- a/x11/xloadimage/Makefile
+++ b/x11/xloadimage/Makefile
@@ -14,9 +14,9 @@ COMMENT= X11 Image Loading Utility
LICENSE= MIT
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- tiff:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff
CONFLICTS_INSTALL= xli-*
@@ -32,11 +32,6 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAN1= xloadimage.1 uufilter.1
-MLINKS= xloadimage.1 xsetbg.1 \
- xloadimage.1 xview.1
-
-NO_STAGE= yes
post-patch:
@${CHMOD} a+rx ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|TIFFHeader|TIFFHeaderClassic|g' \
@@ -48,15 +43,16 @@ post-patch:
${WRKSRC}/xloadimage.man
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/xloadimage ${PREFIX}/bin
- @cd ${PREFIX}/bin && \
+ ${INSTALL_PROGRAM} ${WRKSRC}/xloadimage ${STAGEDIR}${PREFIX}/bin
+ @(cd ${STAGEDIR}${PREFIX}/bin && \
${LN} -sf xloadimage xsetbg && \
- ${LN} -sf xloadimage xview
- ${INSTALL_PROGRAM} ${WRKSRC}/uufilter ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/xloadimage.man ${MAN1PREFIX}/man/man1/xloadimage.1
- ${INSTALL_MAN} ${WRKSRC}/uufilter.man ${MAN1PREFIX}/man/man1/uufilter.1
- ${INSTALL_DATA} ${WRKSRC}/xloadimagerc ${PREFIX}/etc/xloadimagerc.sample
- @[ -f ${PREFIX}/etc/xloadimagerc ] || ${CP} -f ${PREFIX}/etc/xloadimagerc.sample \
- ${PREFIX}/etc/xloadimagerc
+ ${LN} -sf xloadimage xview )
+ ${INSTALL_PROGRAM} ${WRKSRC}/uufilter ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/uufilter.man ${STAGEDIR}${MAN1PREFIX}/man/man1/uufilter.1
+ ${INSTALL_MAN} ${WRKSRC}/xloadimage.man ${STAGEDIR}${MAN1PREFIX}/man/man1/xloadimage.1
+ @(cd ${STAGEDIR}${MAN1PREFIX}/man/man1 && \
+ ${LN} -sf xloadimage.1 xsetbg.1 && \
+ ${LN} -sf xloadimage.1 xview.1 )
+ ${INSTALL_DATA} ${WRKSRC}/xloadimagerc ${STAGEDIR}${PREFIX}/etc/xloadimagerc.sample
.include <bsd.port.mk>