aboutsummaryrefslogtreecommitdiff
path: root/x11/xlockmore
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2001-09-27 11:44:51 +0000
committerThomas Gellekum <tg@FreeBSD.org>2001-09-27 11:44:51 +0000
commita2921c23eaa255bc69c69d91b5b5c2c458849a73 (patch)
treedadb9eb199b485b6351e75492ed96d61866743bf /x11/xlockmore
parent65bb30c922cde2732f3680fc11fa4c1269550f18 (diff)
downloadports-a2921c23eaa255bc69c69d91b5b5c2c458849a73.tar.gz
ports-a2921c23eaa255bc69c69d91b5b5c2c458849a73.zip
Add ${KRB5_HOME}/include to $CFLAGS and ${KRB5_HOME}/lib to
$XLOCKLIBS for people using kerberos5. Suggested by: Niels Kroon <niels@fundum.net>
Notes
Notes: svn path=/head/; revision=48219
Diffstat (limited to 'x11/xlockmore')
-rw-r--r--x11/xlockmore/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/x11/xlockmore/Makefile b/x11/xlockmore/Makefile
index acb691bc9709..84d7aa752cf1 100644
--- a/x11/xlockmore/Makefile
+++ b/x11/xlockmore/Makefile
@@ -23,6 +23,8 @@ CONFIGURE_ARGS+= --enable-kerberos4
.endif
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
CONFIGURE_ARGS+= --enable-kerberos5
+CFLAGS+= -I${KRB5_HOME}/include
+KRB5LIB= -L${KRB5_HOME}/lib
.endif
USE_X_PREFIX= yes
USE_XPM= yes
@@ -31,11 +33,12 @@ MAN1= xlock.1
WITH_MESAGL?= yes
.if ${WITH_MESAGL} == yes
CONFIGURE_ARGS+= --with-mesagl
-CONFIGURE_ENV+= XLOCKLIBS="${PTHREAD_LIBS}"
+MESALIB= ${PTHREAD_LIBS}
USE_MESA= yes
.else
CONFIGURE_ARGS+= --without-mesagl --without-opengl
.endif
+CONFIGURE_ENV+= XLOCKLIBS="${KRB5LIB} ${MESALIB}"
.include <bsd.port.pre.mk>