aboutsummaryrefslogtreecommitdiff
path: root/x11/xproto
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2004-05-07 18:13:40 +0000
committerEric Anholt <anholt@FreeBSD.org>2004-05-07 18:13:40 +0000
commit16d64e36464622c60c4c4be9b5b5411afad9ad2c (patch)
tree2250261290028a788928b7a5426f508b6d1b7d53 /x11/xproto
parent20688a3dfec8508b62b212fc428fbd2d79e343f5 (diff)
downloadports-16d64e36464622c60c4c4be9b5b5411afad9ad2c.tar.gz
ports-16d64e36464622c60c4c4be9b5b5411afad9ad2c.zip
Update to 6.6.2, which includes Xalloca.h
Notes
Notes: svn path=/head/; revision=108627
Diffstat (limited to 'x11/xproto')
-rw-r--r--x11/xproto/Makefile6
-rw-r--r--x11/xproto/distinfo4
-rw-r--r--x11/xproto/files/Xalloca.h139
-rw-r--r--x11/xproto/files/patch-Makefile.in10
4 files changed, 3 insertions, 156 deletions
diff --git a/x11/xproto/Makefile b/x11/xproto/Makefile
index e4a3ee1abf02..e0b6750460c0 100644
--- a/x11/xproto/Makefile
+++ b/x11/xproto/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xproto
-PORTVERSION= 6.6.1
-PORTREVISION= 2
+PORTVERSION= 6.6.2
CATEGORIES= x11
MASTER_SITES= http://pdx.freedesktop.org/~xlibs/release/
@@ -25,7 +24,4 @@ USE_GMAKE= yes
NO_BUILD= yes
USE_GNOME= gnomehack
-post-extract:
- @${CP} ${FILESDIR}/Xalloca.h ${WRKSRC}
-
.include <bsd.port.mk>
diff --git a/x11/xproto/distinfo b/x11/xproto/distinfo
index b49a5c46ba8f..123efab402c8 100644
--- a/x11/xproto/distinfo
+++ b/x11/xproto/distinfo
@@ -1,2 +1,2 @@
-MD5 (xproto-6.6.1.tar.bz2) = 8a7546a607dcd61b2ee595c763fd7f85
-SIZE (xproto-6.6.1.tar.bz2) = 84788
+MD5 (xproto-6.6.2.tar.bz2) = fc419f3028cc2959b979a7e7464105f9
+SIZE (xproto-6.6.2.tar.bz2) = 86759
diff --git a/x11/xproto/files/Xalloca.h b/x11/xproto/files/Xalloca.h
deleted file mode 100644
index 0db456a8620b..000000000000
--- a/x11/xproto/files/Xalloca.h
+++ /dev/null
@@ -1,139 +0,0 @@
-/* $Xorg: Xalloca.h,v 1.4 2001/02/09 02:03:22 xorgcvs Exp $ */
-
-/*
-
-Copyright 1995, 1998 The Open Group
-
-Permission to use, copy, modify, distribute, and sell this software and its
-documentation for any purpose is hereby granted without fee, provided that
-the above copyright notice appear in all copies and that both that
-copyright notice and this permission notice appear in supporting
-documentation.
-
-The above copyright notice and this permission notice shall be
-included in all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
-IN NO EVENT SHALL THE OPEN GROUP BE LIABLE FOR ANY CLAIM, DAMAGES OR
-OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
-ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
-OTHER DEALINGS IN THE SOFTWARE.
-
-Except as contained in this notice, the name of The Open Group shall
-not be used in advertising or otherwise to promote the sale, use or
-other dealings in this Software without prior written authorization
-from The Open Group.
-
-*/
-/* $XFree86: xc/include/Xalloca.h,v 3.10 2001/12/14 19:53:25 dawes Exp $ */
-
-/*
- * The purpose of this header is to define the macros ALLOCATE_LOCAL and
- * DEALLOCATE_LOCAL appropriately for the platform being compiled on.
- * These macros are used to make fast, function-local memory allocations.
- * Their characteristics are as follows:
- *
- * void *ALLOCATE_LOCAL(int size)
- * Returns a pointer to size bytes of memory, or NULL if the allocation
- * failed. The memory must be freed with DEALLOCATE_LOCAL before the
- * function that made the allocation returns. You should not ask for
- * large blocks of memory with this function, since on many platforms
- * the memory comes from the stack, which may have limited size.
- *
- * void DEALLOCATE_LOCAL(void *)
- * Frees the memory allocated by ALLOCATE_LOCAL. Omission of this
- * step may be harmless on some platforms, but will result in
- * memory leaks or worse on others.
- *
- * Before including this file, you should define two macros,
- * ALLOCATE_LOCAL_FALLBACK and DEALLOCATE_LOCAL_FALLBACK, that have the
- * same characteristics as ALLOCATE_LOCAL and DEALLOCATE_LOCAL. The
- * header uses the fallbacks if it doesn't know a "better" way to define
- * ALLOCATE_LOCAL and DEALLOCATE_LOCAL. Typical usage would be:
- *
- * #define ALLOCATE_LOCAL_FALLBACK(_size) malloc(_size)
- * #define DEALLOCATE_LOCAL_FALLBACK(_ptr) free(_ptr)
- * #include "Xalloca.h"
- */
-
-#ifndef XALLOCA_H
-#define XALLOCA_H 1
-
-#ifdef INCLUDE_ALLOCA_H
-# include <alloca.h>
-#endif
-
-#ifndef NO_ALLOCA
-/*
- * os-dependent definition of local allocation and deallocation
- * If you want something other than (DE)ALLOCATE_LOCAL_FALLBACK
- * for ALLOCATE/DEALLOCATE_LOCAL then you add that in here.
- */
-# if defined(__HIGHC__)
-# ifndef NCR
- extern char *alloca();
-# if HCVERSION < 21003
-# define ALLOCATE_LOCAL(size) alloca((int)(size))
- pragma on(alloca);
-# else /* HCVERSION >= 21003 */
-# define ALLOCATE_LOCAL(size) _Alloca((int)(size))
-# endif /* HCVERSION < 21003 */
-# else /* NCR */
-# define ALLOCATE_LOCAL(size) alloca(size)
-# endif
-# endif /* defined(__HIGHC__) */
-
-
-# ifdef __GNUC__
-# ifndef alloca
-# define alloca __builtin_alloca
-# endif /* !alloca */
-# define ALLOCATE_LOCAL(size) alloca((int)(size))
-# else /* ! __GNUC__ */
-
-/*
- * warning: old mips alloca (pre 2.10) is unusable, new one is built in
- * Test is easy, the new one is named __builtin_alloca and comes
- * from alloca.h which #defines alloca.
- */
-# ifndef NCR
-# if defined(vax) || defined(sun) || defined(apollo) || defined(stellar) || defined(alloca)
-/*
- * Some System V boxes extract alloca.o from /lib/libPW.a; if you
- * decide that you don't want to use alloca, you might want to fix it here.
- */
-/* alloca might be a macro taking one arg (hi, Sun!), so give it one. */
-# ifndef __sgi /* IRIX 5/6 has definition */
-# ifndef __QNX__
-# define __Xnullarg /* as nothing */
-# ifndef X_NOT_STDC_ENV
- extern void *alloca(__Xnullarg);
-# else
- extern char *alloca(__Xnullarg);
-# endif
-# endif /* __QNX__ */
-# endif /* __sgi */
-# define ALLOCATE_LOCAL(size) alloca((int)(size))
-# endif /* who does alloca */
-# endif /* NCR */
-# endif /* __GNUC__ */
-
-#endif /* NO_ALLOCA */
-
-#if !defined(ALLOCATE_LOCAL)
-# if defined(ALLOCATE_LOCAL_FALLBACK) && defined(DEALLOCATE_LOCAL_FALLBACK)
-# define ALLOCATE_LOCAL(_size) ALLOCATE_LOCAL_FALLBACK(_size)
-# define DEALLOCATE_LOCAL(_ptr) DEALLOCATE_LOCAL_FALLBACK(_ptr)
-# else /* no fallbacks supplied; error */
-# define ALLOCATE_LOCAL(_size) ALLOCATE_LOCAL_FALLBACK undefined!
-# define DEALLOCATE_LOCAL(_ptr) DEALLOCATE_LOCAL_FALLBACK undefined!
-# endif /* defined(ALLOCATE_LOCAL_FALLBACK && DEALLOCATE_LOCAL_FALLBACK) */
-#else
-# if !defined(DEALLOCATE_LOCAL)
-# define DEALLOCATE_LOCAL(_ptr) do {} while(0)
-# endif
-#endif /* defined(ALLOCATE_LOCAL) */
-
-#endif /* XALLOCA_H */
diff --git a/x11/xproto/files/patch-Makefile.in b/x11/xproto/files/patch-Makefile.in
deleted file mode 100644
index b4158cd8b28f..000000000000
--- a/x11/xproto/files/patch-Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- Makefile.in.orig Sun Mar 14 02:08:42 2004
-+++ Makefile.in Sun Mar 14 02:09:50 2004
-@@ -116,6 +116,7 @@
- xprotoincludedir = $(includedir)/X11
- xprotoinclude_HEADERS = \
- X.h \
-+ Xalloca.h \
- Xarch.h \
- Xatom.h \
- Xdefs.h \