aboutsummaryrefslogtreecommitdiff
path: root/x11/xstroke/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-14 08:19:03 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-05-14 08:19:03 +0000
commit696497e2c8e02609edf2437f53a3f49e722b9b63 (patch)
tree0ee8d5caf99e3900f1a74cd4565637ab09e19608 /x11/xstroke/Makefile
parent328dfe5722c8ce8bbe0d4d819590e1a7d29314d4 (diff)
downloadports-696497e2c8e02609edf2437f53a3f49e722b9b63.tar.gz
ports-696497e2c8e02609edf2437f53a3f49e722b9b63.zip
add xstroke 0.5.12
Fullscreen gesture recognition
Notes
Notes: svn path=/head/; revision=59067
Diffstat (limited to 'x11/xstroke/Makefile')
-rw-r--r--x11/xstroke/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11/xstroke/Makefile b/x11/xstroke/Makefile
new file mode 100644
index 000000000000..b119524d5c2e
--- /dev/null
+++ b/x11/xstroke/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: xstroke
+# Date created: May 14, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= xstroke
+PORTVERSION= 0.5.12
+CATEGORIES= x11
+MASTER_SITES= ftp://ftp.handhelds.org/pub/projects/xstroke/release-${PORTVERSION:R}/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+USE_BISON= yes
+USE_IMAKE= yes
+CFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -lgnugetopt
+
+MAN1= xstroke.1
+
+post-patch:
+ @${PERL} -pi -e "s,-lpthread,${PTHREAD_LIBS},g ; \
+ s,%%CFLAGS%%,${CFLAGS},g ; \
+ s,%%LDFLAGS%%,${LDFLAGS},g" ${WRKSRC}/Imakefile
+ @${PERL} -pi -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/etc/Imakefile
+
+.include <bsd.port.mk>