aboutsummaryrefslogtreecommitdiff
path: root/x11/yelp/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-11 08:02:54 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-11 08:02:54 +0000
commitf027d4ff58354ebca9012233fc60c0d23174be34 (patch)
treedda5799c0315cd8828a4ad0f24edf0d095b0db70 /x11/yelp/Makefile
parent8f4c7ee1eee32416b5722aae8d251f9e7650fd1b (diff)
downloadports-f027d4ff58354ebca9012233fc60c0d23174be34.tar.gz
ports-f027d4ff58354ebca9012233fc60c0d23174be34.zip
Support stage
Notes
Notes: svn path=/head/; revision=350896
Diffstat (limited to 'x11/yelp/Makefile')
-rw-r--r--x11/yelp/Makefile33
1 files changed, 10 insertions, 23 deletions
diff --git a/x11/yelp/Makefile b/x11/yelp/Makefile
index 550d3a412d82..ff8541d1e227 100644
--- a/x11/yelp/Makefile
+++ b/x11/yelp/Makefile
@@ -11,36 +11,26 @@ DISTNAME= ${PORTNAME}-webkit-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A help browser for the GNOME 2 desktop
+COMMENT= Help browser for the GNOME 2 desktop
-LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
- startup-notification-1:${PORTSDIR}/x11/startup-notification \
- webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2 \
- rarian:${PORTSDIR}/textproc/rarian
+LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+ libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification \
+ libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2 \
+ librarian.so:${PORTSDIR}/textproc/rarian
CONFLICTS= yelp-3.[0-9]*
-USES= desktop-file-utils gettext gmake pkgconfig
-USE_BZIP2= yes
+USES= desktop-file-utils gettext gmake pathfix pkgconfig tar:bzip2
USE_XORG= ice
-USE_GNOME= gnomeprefix gnomehack intlhack gconf2 gnomedocutils
+USE_GNOME= gnomeprefix intlhack gconf2 gnomedocutils
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib \
+ -fstack-protector
GCONF_SCHEMAS= yelp.schemas
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-# Around the time GCC stack protection (aka Propolice) for userland
-# was enabled on src/share/mk/bsd.sys.mk
-# SVN rev 180012 on 2008-06-25 21:33:28Z by ru
-.if ${OSVERSION} >= 800040
-LDFLAGS+= -fstack-protector
-.endif
-
post-extract:
${RM} -f ${WRKSRC}/data/yelp.schemas
@@ -49,7 +39,4 @@ post-patch:
-e 's/ --define-variable=includetype=unstable//' \
${WRKSRC}/configure
-post-install:
- @-update-mime-database ${PREFIX}/share/mime
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>