aboutsummaryrefslogtreecommitdiff
path: root/x11/yelp
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /x11/yelp
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
The FreeBSD GNOME team proudly presents GNOME 3.14 and Cinnamon 2.2.
Gnome 3.14.1 and Cinnamon 2.2.16 are supported on FreeBSD 9.3-RELEASE and up. This commit removes the old GNOME 2 desktop, bindings and some ports that can't be compiled. A few ports where updated to more recent versions to allow them to compile with this update. Apart from updating ports to newer versions GDM is more integrated with gnome-shell now, and handles several things for the GNOME desktop such as screen locking. If you want to use GNOME 3 via startx, you will have to add your own lock screen/screensaver. For example xscreensaver can be used for sessions started without GDM. Shell Extensions can be installed via https://extensions.gnome.org/ , we have ported a few that can't be installed via this way. The old gnome-utils and gnome-games ports where split up into single ports and where converted to meta-ports. gnome-terminal requires a UTF-8 locale to run, gdm handles this already, but if you use startx you need to do this yourself. Upgrade instructions: Delete the old and conflicting packages: # pkg delete clutter gnome-utils gnome-panel gnome-keyring vala-vapigen \ guile gcalctool gnome-media libgnomekbd # pkg delete gnome-screensaver gnome-applets bug-buddy evolution-exchange \ evolution-webcal gnome-system-tools seahorse-plugins gnome-control-center For package users the following lines will be enough: # pkg upgrade # pkg install gnome3 For ports users should do the following: # portmaster -a # portmaster x11/gnome3 We are currently aware of two issues. The first issue is a bug in the file monitoring code in the glib20 port. This bug causes glib programs to crash when files in a monitored directory are added or removed. Upstream is aware of the problem, but since the problem is quite complex there is no solution yet. This problem isn't restricted to BSD. The second issue is that on certain video cards totem will display a purple/pink overlay on the video. It not clear yet where the issues comes from. Major thanks goes to Gustau Perez for being a driving force behind getting GNOME 3 up to speed again. Also thanks to Antoine Brodin for running the exp-runs. This update was also made possible by: Joe Maloney Kris Moore Beeblebrox Ryan Lortie Antoine Jacoutot and everyone I missed
Notes
Notes: svn path=/head/; revision=372768
Diffstat (limited to 'x11/yelp')
-rw-r--r--x11/yelp/Makefile54
-rw-r--r--x11/yelp/distinfo4
-rw-r--r--x11/yelp/files/patch-yelp.desktop.in.in16
-rw-r--r--x11/yelp/pkg-descr2
-rw-r--r--x11/yelp/pkg-plist352
5 files changed, 290 insertions, 138 deletions
diff --git a/x11/yelp/Makefile b/x11/yelp/Makefile
index 4fe6d5c05f2e..2f2d44f303d4 100644
--- a/x11/yelp/Makefile
+++ b/x11/yelp/Makefile
@@ -1,43 +1,43 @@
# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/x11/yelp/Makefile,v 1.171 2012/10/01 16:19:07 kwm Exp $
+# $MCom: ports/trunk/x11/yelp/Makefile 19967 2014-10-16 06:45:29Z gusi $
PORTNAME= yelp
-PORTVERSION= 2.30.2
-PORTREVISION= 10
+PORTVERSION= 3.14.1
CATEGORIES= x11 gnome
-MASTER_SITES= LOCAL/kwm
-DISTNAME= ${PORTNAME}-webkit-${PORTVERSION}
-DIST_SUBDIR= gnome2
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
-COMMENT= Help browser for the GNOME 2 desktop
+COMMENT= Help browser for the GNOME 3 desktop
-LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
- libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification \
- libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2 \
- librarian.so:${PORTSDIR}/textproc/rarian
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-CONFLICTS= yelp-3.[0-9]*
+BUILD_DEPENDS= yelp-xsl>=0:${PORTSDIR}/textproc/yelp-xsl \
+ itstool:${PORTSDIR}/textproc/itstool
+LIB_DEPENDS= libwebkitgtk-3.0.so:${PORTSDIR}/www/webkit-gtk3
+RUN_DEPENDS= yelp-xsl>=0:${PORTSDIR}/textproc/yelp-xsl
-USES= desktop-file-utils gettext gmake pathfix pkgconfig tar:bzip2
-USE_XORG= ice
-USE_GNOME= gnomeprefix intlhack gconf2 gnomedocutils
+USES= desktop-file-utils gettext gmake libtool pathfix \
+ pkgconfig tar:xz
+USE_XORG= x11 ice
+USE_GNOME= gnomeprefix gtk30 intlhack libxml2 libxslt
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
+USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib \
- -fstack-protector
+LDFLAGS+= -L${LOCALBASE}/lib -fstack-protector
+GLIB_SCHEMAS= org.gnome.yelp.gschema.xml
+INSTALL_TARGET= install-strip
-GCONF_SCHEMAS= yelp.schemas
+.include <bsd.port.pre.mk>
-post-extract:
- ${RM} -f ${WRKSRC}/data/yelp.schemas
+.if ${OSVERSION} >= 900012 || (${OSVERSION} >= 800505 && ${OSVERSION} < 900000)
+CONFIGURE_ENV+= YELP_LZMA_CFLAGS="-I/usr/include" \
+ YELP_LZMA_LIBS="-L/usr/lib -llzma"
+.else
+LIB_DEPENDS+= liblzma.so:${PORTSDIR}/archivers/xz
+.endif
-post-patch:
- @${REINPLACE_CMD} -e 's,[-/]unstable,,' \
- -e 's/ --define-variable=includetype=unstable//' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} '/g_thread_init/d' ${WRKSRC}/src/yelp-main.c
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/yelp/distinfo b/x11/yelp/distinfo
index 5c12283abc4b..422aa861e61f 100644
--- a/x11/yelp/distinfo
+++ b/x11/yelp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/yelp-webkit-2.30.2.tar.bz2) = 8c49dffecdc07dfe1e1b03f6ec3c32c523650802b6aebaf0b232aaa1af5e9f88
-SIZE (gnome2/yelp-webkit-2.30.2.tar.bz2) = 1125815
+SHA256 (gnome3/yelp-3.14.1.tar.xz) = 1df24b0afa000fd7b003b43448be5227d72757e95e678a7be1832ebea685f072
+SIZE (gnome3/yelp-3.14.1.tar.xz) = 1401680
diff --git a/x11/yelp/files/patch-yelp.desktop.in.in b/x11/yelp/files/patch-yelp.desktop.in.in
deleted file mode 100644
index cd331558d19d..000000000000
--- a/x11/yelp/files/patch-yelp.desktop.in.in
+++ /dev/null
@@ -1,16 +0,0 @@
---- yelp.desktop.in.in.orig 2010-08-03 21:41:38.000000000 +0200
-+++ yelp.desktop.in.in 2012-05-10 16:20:42.000000000 +0200
-@@ -2,7 +2,7 @@
- _Name=Help
- _Comment=Get help with GNOME
- OnlyShowIn=GNOME;
--Exec=yelp
-+Exec=yelp %u
- Icon=help-browser
- StartupNotify=true
- Terminal=false
-@@ -12,3 +12,4 @@
- X-GNOME-Bugzilla-Product=Yelp
- X-GNOME-Bugzilla-Component=general
- X-GNOME-Bugzilla-Version=@VERSION@
-+MimeType=x-scheme-handler/ghelp;x-scheme-handler/help;x-scheme-handler/info;x-scheme-handler/man;
diff --git a/x11/yelp/pkg-descr b/x11/yelp/pkg-descr
index d38af5629561..985ffefd8a61 100644
--- a/x11/yelp/pkg-descr
+++ b/x11/yelp/pkg-descr
@@ -1,4 +1,4 @@
-Yelp is a help browser for GNOME 2.0 that displays GNOME
+Yelp is a help browser for GNOME 3.0 that displays GNOME
help documents, info pages, manpages, and more.
WWW: http://www.gnome.org/
diff --git a/x11/yelp/pkg-plist b/x11/yelp/pkg-plist
index 42f1c492e22c..50f076b09c24 100644
--- a/x11/yelp/pkg-plist
+++ b/x11/yelp/pkg-plist
@@ -1,7 +1,47 @@
bin/gnome-help
bin/yelp
+include/libyelp/yelp-bookmarks.h
+include/libyelp/yelp-docbook-document.h
+include/libyelp/yelp-document.h
+include/libyelp/yelp-help-list.h
+include/libyelp/yelp-info-document.h
+include/libyelp/yelp-mallard-document.h
+include/libyelp/yelp-man-document.h
+include/libyelp/yelp-search-entry.h
+include/libyelp/yelp-settings.h
+include/libyelp/yelp-simple-document.h
+include/libyelp/yelp-sqlite-storage.h
+include/libyelp/yelp-storage.h
+include/libyelp/yelp-transform.h
+include/libyelp/yelp-types.h
+include/libyelp/yelp-uri.h
+include/libyelp/yelp-view.h
+lib/libyelp.a
+lib/libyelp.so
+lib/libyelp.so.0
+lib/libyelp.so.0.0.0
share/applications/yelp.desktop
-share/icons/hicolor/192x192/apps/yelp-icon-big.png
+share/doc/libyelp/YelpDocument.html
+share/doc/libyelp/YelpSettings.html
+share/doc/libyelp/YelpSimpleDocument.html
+share/doc/libyelp/YelpUri.html
+share/doc/libyelp/YelpView.html
+share/doc/libyelp/api-index-full.html
+share/doc/libyelp/ch01.html
+share/doc/libyelp/ch01s02.html
+share/doc/libyelp/home.png
+share/doc/libyelp/index.html
+share/doc/libyelp/index.sgml
+share/doc/libyelp/left-insensitive.png
+share/doc/libyelp/left.png
+share/doc/libyelp/libyelp-yelp-error.html
+share/doc/libyelp/libyelp.devhelp2
+share/doc/libyelp/object-tree.html
+share/doc/libyelp/right-insensitive.png
+share/doc/libyelp/right.png
+share/doc/libyelp/style.css
+share/doc/libyelp/up-insensitive.png
+share/doc/libyelp/up.png
share/locale/af/LC_MESSAGES/yelp.mo
share/locale/am/LC_MESSAGES/yelp.mo
share/locale/ar/LC_MESSAGES/yelp.mo
@@ -24,7 +64,6 @@ share/locale/da/LC_MESSAGES/yelp.mo
share/locale/de/LC_MESSAGES/yelp.mo
share/locale/dz/LC_MESSAGES/yelp.mo
share/locale/el/LC_MESSAGES/yelp.mo
-share/locale/en@shaw/LC_MESSAGES/yelp.mo
share/locale/en_CA/LC_MESSAGES/yelp.mo
share/locale/en_GB/LC_MESSAGES/yelp.mo
share/locale/eo/LC_MESSAGES/yelp.mo
@@ -36,8 +75,10 @@ share/locale/fi/LC_MESSAGES/yelp.mo
share/locale/fr/LC_MESSAGES/yelp.mo
share/locale/fur/LC_MESSAGES/yelp.mo
share/locale/ga/LC_MESSAGES/yelp.mo
+share/locale/gd/LC_MESSAGES/yelp.mo
share/locale/gl/LC_MESSAGES/yelp.mo
share/locale/gu/LC_MESSAGES/yelp.mo
+share/locale/km/LC_MESSAGES/yelp.mo
share/locale/he/LC_MESSAGES/yelp.mo
share/locale/hi/LC_MESSAGES/yelp.mo
share/locale/hr/LC_MESSAGES/yelp.mo
@@ -103,98 +144,225 @@ share/locale/zh_CN/LC_MESSAGES/yelp.mo
share/locale/zh_HK/LC_MESSAGES/yelp.mo
share/locale/zh_TW/LC_MESSAGES/yelp.mo
share/locale/zu/LC_MESSAGES/yelp.mo
-%%DATADIR%%/default.css
-%%DATADIR%%/icons/yelp-icon-caution.png
-%%DATADIR%%/icons/yelp-icon-important.png
-%%DATADIR%%/icons/yelp-icon-note.png
-%%DATADIR%%/icons/yelp-icon-tip.png
-%%DATADIR%%/icons/yelp-icon-warning.png
-%%DATADIR%%/icons/yelp-watermark-blockquote-00AB.png
-%%DATADIR%%/icons/yelp-watermark-blockquote-00BB.png
-%%DATADIR%%/icons/yelp-watermark-blockquote-201C.png
-%%DATADIR%%/icons/yelp-watermark-blockquote-201D.png
-%%DATADIR%%/icons/yelp-watermark-blockquote-201E.png
-%%DATADIR%%/important_docs.xml
-%%DATADIR%%/info.xml
-%%DATADIR%%/man.xml
-%%DATADIR%%/scrollkeeper.xml
-%%DATADIR%%/toc.xml
-%%DATADIR%%/ui/yelp-bookmarks-add.ui
-%%DATADIR%%/ui/yelp-bookmarks.ui
-%%DATADIR%%/ui/yelp-open-location.ui
-%%DATADIR%%/ui/yelp-preferences.ui
-%%DATADIR%%/ui/yelp-search-ui.xml
-%%DATADIR%%/ui/yelp-ui.xml
-%%DATADIR%%/xslt/db-title.xsl
+%%DATADIR%%/dtd/catalog
+%%DATADIR%%/dtd/docbookx.dtd
+%%DATADIR%%/dtd/isoamsa.ent
+%%DATADIR%%/dtd/isoamsb.ent
+%%DATADIR%%/dtd/isoamsc.ent
+%%DATADIR%%/dtd/isoamsn.ent
+%%DATADIR%%/dtd/isoamso.ent
+%%DATADIR%%/dtd/isoamsr.ent
+%%DATADIR%%/dtd/isobox.ent
+%%DATADIR%%/dtd/isocyr1.ent
+%%DATADIR%%/dtd/isocyr2.ent
+%%DATADIR%%/dtd/isodia.ent
+%%DATADIR%%/dtd/isogrk1.ent
+%%DATADIR%%/dtd/isogrk2.ent
+%%DATADIR%%/dtd/isogrk3.ent
+%%DATADIR%%/dtd/isogrk4.ent
+%%DATADIR%%/dtd/isolat1.ent
+%%DATADIR%%/dtd/isolat2.ent
+%%DATADIR%%/dtd/isonum.ent
+%%DATADIR%%/dtd/isopub.ent
+%%DATADIR%%/dtd/isotech.ent
+%%DATADIR%%/icons/hicolor/16x16/status/bookmark.png
+%%DATADIR%%/icons/hicolor/16x16/status/yelp-page-task.png
+%%DATADIR%%/icons/hicolor/16x16/status/yelp-page-tip.png
+%%DATADIR%%/icons/hicolor/16x16/status/yelp-page-ui.png
+%%DATADIR%%/icons/hicolor/16x16/status/yelp-page-video.png
+%%DATADIR%%/icons/hicolor/scalable/actions/yelp-bookmark-add-symbolic.svg
+%%DATADIR%%/icons/hicolor/scalable/actions/yelp-bookmark-remove-symbolic.svg
+%%DATADIR%%/icons/hicolor/scalable/status/yelp-page-problem-symbolic.svg
+%%DATADIR%%/icons/hicolor/scalable/status/yelp-page-search-symbolic.svg
+%%DATADIR%%/icons/hicolor/scalable/status/yelp-page-symbolic.svg
+%%DATADIR%%/icons/hicolor/scalable/status/yelp-page-task-symbolic.svg
+%%DATADIR%%/icons/hicolor/scalable/status/yelp-page-tip-symbolic.svg
+%%DATADIR%%/icons/hicolor/scalable/status/yelp-page-ui-symbolic.svg
+%%DATADIR%%/icons/hicolor/scalable/status/yelp-page-video-symbolic.svg
+%%DATADIR%%/mathjax/MathJax.js
+%%DATADIR%%/mathjax/config/MMLorHTML.js
+%%DATADIR%%/mathjax/config/yelp.js
+%%DATADIR%%/mathjax/extensions/MathEvents.js
+%%DATADIR%%/mathjax/extensions/MathMenu.js
+%%DATADIR%%/mathjax/extensions/MathZoom.js
+%%DATADIR%%/mathjax/extensions/mml2jax.js
+%%DATADIR%%/mathjax/extensions/HTML-CSS/handle-floats.js
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_AMS-Regular.woff
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_Caligraphic-Bold.woff
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_Caligraphic-Regular.woff
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_Fraktur-Bold.woff
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_Fraktur-Regular.woff
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_Main-Bold.woff
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_Main-Italic.woff
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_Main-Regular.woff
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_Math-BoldItalic.woff
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_Math-Italic.woff
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_Math-Regular.woff
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_SansSerif-Bold.woff
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_SansSerif-Italic.woff
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_SansSerif-Regular.woff
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_Script-Regular.woff
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_Size1-Regular.woff
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_Size2-Regular.woff
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_Size3-Regular.woff
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_Size4-Regular.woff
+%%DATADIR%%/mathjax/fonts/HTML-CSS/TeX/woff/MathJax_Typewriter-Regular.woff
+%%DATADIR%%/mathjax/jax/element/mml/jax.js
+%%DATADIR%%/mathjax/jax/element/mml/optable/Arrows.js
+%%DATADIR%%/mathjax/jax/element/mml/optable/BasicLatin.js
+%%DATADIR%%/mathjax/jax/element/mml/optable/CombDiacritMarks.js
+%%DATADIR%%/mathjax/jax/element/mml/optable/CombDiactForSymbols.js
+%%DATADIR%%/mathjax/jax/element/mml/optable/Dingbats.js
+%%DATADIR%%/mathjax/jax/element/mml/optable/GeneralPunctuation.js
+%%DATADIR%%/mathjax/jax/element/mml/optable/GeometricShapes.js
+%%DATADIR%%/mathjax/jax/element/mml/optable/GreekAndCoptic.js
+%%DATADIR%%/mathjax/jax/element/mml/optable/Latin1Supplement.js
+%%DATADIR%%/mathjax/jax/element/mml/optable/LetterlikeSymbols.js
+%%DATADIR%%/mathjax/jax/element/mml/optable/Makefile.am
+%%DATADIR%%/mathjax/jax/element/mml/optable/MathOperators.js
+%%DATADIR%%/mathjax/jax/element/mml/optable/MiscMathSymbolsA.js
+%%DATADIR%%/mathjax/jax/element/mml/optable/MiscMathSymbolsB.js
+%%DATADIR%%/mathjax/jax/element/mml/optable/MiscSymbolsAndArrows.js
+%%DATADIR%%/mathjax/jax/element/mml/optable/MiscTechnical.js
+%%DATADIR%%/mathjax/jax/element/mml/optable/SpacingModLetters.js
+%%DATADIR%%/mathjax/jax/element/mml/optable/SuppMathOperators.js
+%%DATADIR%%/mathjax/jax/element/mml/optable/SupplementalArrowsA.js
+%%DATADIR%%/mathjax/jax/element/mml/optable/SupplementalArrowsB.js
+%%DATADIR%%/mathjax/jax/input/MathML/config.js
+%%DATADIR%%/mathjax/jax/input/MathML/jax.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/a.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/b.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/c.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/d.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/e.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/f.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/fr.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/g.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/h.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/i.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/j.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/k.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/l.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/m.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/n.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/o.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/opf.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/p.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/q.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/r.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/s.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/scr.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/t.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/u.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/v.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/w.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/x.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/y.js
+%%DATADIR%%/mathjax/jax/input/MathML/entities/z.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/config.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/jax.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/autoload/Makefile.am
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/autoload/annotation-xml.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/autoload/maction.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/autoload/menclose.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/autoload/mglyph.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/autoload/mmultiscripts.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/autoload/ms.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/autoload/mtable.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/autoload/multiline.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/fontdata-extra.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/fontdata.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/Arrows.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/BBBold.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/BoxDrawing.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/CombDiacritMarks.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/Dingbats.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/EnclosedAlphanum.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/GeneralPunctuation.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/GeometricShapes.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/GreekAndCoptic.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/Latin1Supplement.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/LatinExtendedA.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/LetterlikeSymbols.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/MathOperators.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/MiscMathSymbolsB.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/MiscSymbols.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/MiscTechnical.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/PUA.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/SpacingModLetters.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/AMS/Regular/SuppMathOperators.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Caligraphic/Bold/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Caligraphic/Regular/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Fraktur/Bold/BasicLatin.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Fraktur/Bold/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Fraktur/Bold/Other.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Fraktur/Bold/PUA.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Fraktur/Regular/BasicLatin.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Fraktur/Regular/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Fraktur/Regular/Other.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Fraktur/Regular/PUA.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Greek/Bold/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Greek/BoldItalic/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Greek/Italic/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Greek/Regular/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Bold/Arrows.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Bold/CombDiacritMarks.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Bold/CombDiactForSymbols.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Bold/GeneralPunctuation.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Bold/GeometricShapes.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Bold/Latin1Supplement.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Bold/LatinExtendedA.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Bold/LatinExtendedB.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Bold/LetterlikeSymbols.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Bold/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Bold/MathOperators.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Bold/MiscMathSymbolsA.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Bold/MiscSymbols.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Bold/MiscTechnical.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Bold/SpacingModLetters.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Bold/SuppMathOperators.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Bold/SupplementalArrowsA.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Italic/CombDiacritMarks.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Italic/GeneralPunctuation.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Italic/Latin1Supplement.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Italic/LetterlikeSymbols.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Italic/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Regular/CombDiacritMarks.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Regular/GeometricShapes.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Regular/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Regular/MiscSymbols.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Main/Regular/SpacingModLetters.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Math/BoldItalic/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Math/Italic/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/SansSerif/Bold/BasicLatin.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/SansSerif/Bold/CombDiacritMarks.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/SansSerif/Bold/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/SansSerif/Bold/Other.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/SansSerif/Italic/BasicLatin.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/SansSerif/Italic/CombDiacritMarks.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/SansSerif/Italic/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/SansSerif/Italic/Other.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/SansSerif/Regular/BasicLatin.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/SansSerif/Regular/CombDiacritMarks.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/SansSerif/Regular/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/SansSerif/Regular/Other.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Script/Regular/BasicLatin.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Script/Regular/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Script/Regular/Other.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Size1/Regular/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Size2/Regular/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Size3/Regular/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Size4/Regular/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Typewriter/Regular/BasicLatin.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Typewriter/Regular/CombDiacritMarks.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Typewriter/Regular/Main.js
+%%DATADIR%%/mathjax/jax/output/HTML-CSS/fonts/TeX/Typewriter/Regular/Other.js
+%%DATADIR%%/mathjax/jax/output/NativeMML/config.js
+%%DATADIR%%/mathjax/jax/output/NativeMML/jax.js
%%DATADIR%%/xslt/db2html.xsl
%%DATADIR%%/xslt/info2html.xsl
%%DATADIR%%/xslt/mal2html.xsl
%%DATADIR%%/xslt/man2html.xsl
-%%DATADIR%%/xslt/search2html.xsl
-%%DATADIR%%/xslt/toc2html.xsl
%%DATADIR%%/xslt/yelp-common.xsl
-%%DATADIR%%/yelp.js
-@dirrm %%DATADIR%%/xslt
-@dirrm %%DATADIR%%/ui
-@dirrm %%DATADIR%%/icons
-@dirrm %%DATADIR%%
-@dirrmtry share/locale/zu/LC_MESSAGES
-@dirrmtry share/locale/zu
-@dirrmtry share/locale/zh_HK/LC_MESSAGES
-@dirrmtry share/locale/zh_HK
-@dirrmtry share/locale/xh/LC_MESSAGES
-@dirrmtry share/locale/xh
-@dirrmtry share/locale/uz@cyrillic/LC_MESSAGES
-@dirrmtry share/locale/uz@cyrillic
-@dirrmtry share/locale/ug/LC_MESSAGES
-@dirrmtry share/locale/ug
-@dirrmtry share/locale/te/LC_MESSAGES
-@dirrmtry share/locale/te
-@dirrmtry share/locale/sr@latin/LC_MESSAGES
-@dirrmtry share/locale/sr@latin
-@dirrmtry share/locale/si/LC_MESSAGES
-@dirrmtry share/locale/si
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw
-@dirrmtry share/locale/ps/LC_MESSAGES
-@dirrmtry share/locale/ps
-@dirrmtry share/locale/oc/LC_MESSAGES
-@dirrmtry share/locale/oc
-@dirrmtry share/locale/nso/LC_MESSAGES
-@dirrmtry share/locale/nso
-@dirrmtry share/locale/nds/LC_MESSAGES
-@dirrmtry share/locale/nds
-@dirrmtry share/locale/mr/LC_MESSAGES
-@dirrmtry share/locale/mr
-@dirrmtry share/locale/mg/LC_MESSAGES
-@dirrmtry share/locale/mg
-@dirrmtry share/locale/mai/LC_MESSAGES
-@dirrmtry share/locale/mai
-@dirrmtry share/locale/la/LC_MESSAGES
-@dirrmtry share/locale/la
-@dirrmtry share/locale/ky/LC_MESSAGES
-@dirrmtry share/locale/ky
-@dirrmtry share/locale/ku/LC_MESSAGES
-@dirrmtry share/locale/ku
-@dirrmtry share/locale/ks/LC_MESSAGES
-@dirrmtry share/locale/ks
-@dirrmtry share/locale/kk/LC_MESSAGES
-@dirrmtry share/locale/kk
-@dirrmtry share/locale/fur/LC_MESSAGES
-@dirrmtry share/locale/fur
-@dirrmtry share/locale/en@shaw/LC_MESSAGES
-@dirrmtry share/locale/en@shaw
-@dirrmtry share/locale/dz/LC_MESSAGES
-@dirrmtry share/locale/dz
-@dirrmtry share/locale/crh/LC_MESSAGES
-@dirrmtry share/locale/crh
-@dirrmtry share/locale/ca@valencia/LC_MESSAGES
-@dirrmtry share/locale/ca@valencia
-@dirrmtry share/locale/bn_IN/LC_MESSAGES
-@dirrmtry share/locale/bn_IN
-@dirrmtry share/locale/be@latin/LC_MESSAGES
-@dirrmtry share/locale/be@latin
-@dirrmtry share/locale/ast/LC_MESSAGES
-@dirrmtry share/locale/ast
-@dirrmtry share/locale/as/LC_MESSAGES
-@dirrmtry share/locale/as
+share/yelp-xsl/xslt/common/domains/yelp.xml