aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2020-12-31 11:37:10 +0000
committerDima Panov <fluffy@FreeBSD.org>2020-12-31 11:37:10 +0000
commit02fac8f9cabade9ad002501e26fcfad3bec3c192 (patch)
tree00749690eed4336a0faf3aae3ed744e31209c7e1 /x11
parentd048519929771a8505465562a2291fe056ef03b0 (diff)
downloadports-02fac8f9cabade9ad002501e26fcfad3bec3c192.tar.gz
ports-02fac8f9cabade9ad002501e26fcfad3bec3c192.zip
x11/xapps: move to x11/xapp and update to 2.0.4
Upstream changed the project name to xapp PR: 252299 Submitted by: Charlie Li
Notes
Notes: svn path=/head/; revision=559718
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile2
-rw-r--r--x11/xapp/Makefile48
-rw-r--r--x11/xapp/distinfo3
-rw-r--r--x11/xapp/pkg-descr5
-rw-r--r--x11/xapp/pkg-plist (renamed from x11/xapps/pkg-plist)67
-rw-r--r--x11/xapps/Makefile41
-rw-r--r--x11/xapps/distinfo3
-rw-r--r--x11/xapps/pkg-descr4
8 files changed, 123 insertions, 50 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 9db9affc7221..2227bc3bc3b5 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -377,7 +377,7 @@
SUBDIR += x11perf
SUBDIR += x3270
SUBDIR += xantfarm
- SUBDIR += xapps
+ SUBDIR += xapp
SUBDIR += xascii
SUBDIR += xauth
SUBDIR += xautolock
diff --git a/x11/xapp/Makefile b/x11/xapp/Makefile
new file mode 100644
index 000000000000..82bbb2c49575
--- /dev/null
+++ b/x11/xapp/Makefile
@@ -0,0 +1,48 @@
+# $FreeBSD$
+
+PORTNAME= xapp
+PORTVERSION= 2.0.4
+CATEGORIES= x11 gnome
+DIST_SUBDIR= gnome
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Cross-desktop libraries and common resources
+
+LICENSE= LGPL3
+LICENSE_FILE?= ${WRKSRC}/COPYING.LESSER
+
+BUILD_DEPENDS= vapigen:lang/vala
+LIB_DEPENDS= libxklavier.so:x11/libxklavier \
+ libdbusmenu-gtk3.so:devel/libdbusmenu
+RUN_DEPENDS= bash:shells/bash
+
+USES= gettext-tools:build gnome meson pkgconfig python:3.5+ \
+ shebangfix xorg
+
+USE_GITHUB= yes
+GH_ACCOUNT= linuxmint
+
+SHEBANG_FILES= data libxapp meson-scripts schemas scripts status-applets \
+ test-scripts
+BINARY_ALIAS= python3=${PYTHON_CMD}
+
+USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 introspection intltool \
+ libgnomekbd pygobject3
+
+GLIB_SCHEMAS= org.x.apps.gschema.xml
+INSTALLS_ICONS= yes
+
+USE_XORG= x11
+
+USE_LDCONFIG= yes
+
+PORTSCOUT= limit:^[0-9.]+$$ # ignore master.mint* tags
+
+PLIST_SUB+= LIBVERSION=${PORTVERSION}
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_BUILD_DEPENDS= gtkdocize:textproc/gtk-doc
+DOCS_MESON_TRUE= docs
+
+.include <bsd.port.mk>
diff --git a/x11/xapp/distinfo b/x11/xapp/distinfo
new file mode 100644
index 000000000000..6db8c11fb5d7
--- /dev/null
+++ b/x11/xapp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608871755
+SHA256 (gnome/linuxmint-xapp-2.0.4_GH0.tar.gz) = 99d77bffc39cace6a283c3fe8f63ece3e1cf5d136eae7830d53674f50967e5ee
+SIZE (gnome/linuxmint-xapp-2.0.4_GH0.tar.gz) = 229723
diff --git a/x11/xapp/pkg-descr b/x11/xapp/pkg-descr
new file mode 100644
index 000000000000..f1b605a6248c
--- /dev/null
+++ b/x11/xapp/pkg-descr
@@ -0,0 +1,5 @@
+This project gathers the components which are common to multiple
+desktop environments and required to implement cross-DE solutions.
+Consists of xapp-common and libxapp.
+
+WWW: https://github.com/linuxmint/xapp
diff --git a/x11/xapps/pkg-plist b/x11/xapp/pkg-plist
index 818ce60d6333..72861e2c291d 100644
--- a/x11/xapps/pkg-plist
+++ b/x11/xapp/pkg-plist
@@ -1,3 +1,9 @@
+bin/pastebin
+bin/upload-system-info
+bin/xfce4-set-wallpaper
+etc/X11/xinit/xinitrc.d/80xapp-gtk3-module.sh
+etc/xdg/autostart/xapp-sn-watcher.desktop
+include/xapp/libxapp/xapp-favorites.h
include/xapp/libxapp/xapp-gtk-window.h
include/xapp/libxapp/xapp-icon-chooser-button.h
include/xapp/libxapp/xapp-icon-chooser-dialog.h
@@ -8,13 +14,48 @@ include/xapp/libxapp/xapp-stack-sidebar.h
include/xapp/libxapp/xapp-status-icon-monitor.h
include/xapp/libxapp/xapp-status-icon.h
include/xapp/libxapp/xapp-statusicon-interface.h
+include/xapp/libxapp/xapp-util.h
lib/girepository-1.0/XApp-1.0.typelib
+lib/gtk-3.0/modules/libxapp-gtk3-module.so
lib/libxapp.so
lib/libxapp.so.1
-lib/libxapp.so.1.6.10
+lib/libxapp.so.%%LIBVERSION%%
+%%PYTHON_SITELIBDIR%%/gi/overrides/XApp.py
libdata/pkgconfig/xapp.pc
+libexec/xapps/applet_constants.py
+libexec/xapps/mate-xapp-status-applet.py
+libexec/xapps/sn-watcher/xapp-sn-watcher
+share/dbus-1/services/org.mate.panel.applet.MateXAppStatusAppletFactory.service
+share/dbus-1/services/org.x.StatusNotifierWatcher.service
share/gir-1.0/XApp-1.0.gir
share/glade/catalogs/xapp-glade-catalog.xml
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppFavorites.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppGtkWindow.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppIconChooserButton.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppIconChooserDialog.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppKbdLayoutController.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppMonitorBlanker.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppObjectManagerClient.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppPreferencesWindow.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppStackSidebar.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppStatusIcon.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppStatusIconMonitor.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/annotation-glossary.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/api-index-full.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/ch01.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/deprecated-api-index.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/home.png
+%%PORTDOCS%%share/gtk-doc/html/libxapp/index.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/left-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/libxapp/left.png
+%%PORTDOCS%%share/gtk-doc/html/libxapp/libxapp.devhelp2
+%%PORTDOCS%%share/gtk-doc/html/libxapp/libxapp-xapp-util.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/object-tree.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/right-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/libxapp/right.png
+%%PORTDOCS%%share/gtk-doc/html/libxapp/style.css
+%%PORTDOCS%%share/gtk-doc/html/libxapp/up-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/libxapp/up.png
share/icons/hicolor/scalable/actions/add-files-to-archive-symbolic.svg
share/icons/hicolor/scalable/actions/category-search-symbolic.svg
share/icons/hicolor/scalable/actions/extract-archive-symbolic.svg
@@ -25,22 +66,37 @@ share/icons/hicolor/scalable/actions/view-left-pane-symbolic.svg
share/icons/hicolor/scalable/actions/view-right-pane-symbolic-rtl.svg
share/icons/hicolor/scalable/actions/view-right-pane-symbolic.svg
share/icons/hicolor/scalable/actions/view-top-pane-symbolic.svg
+share/icons/hicolor/scalable/actions/xapp-annotations-squiggly-symbolic.svg
+share/icons/hicolor/scalable/actions/xapp-annotations-text-symbolic.svg
+share/icons/hicolor/scalable/actions/xapp-diaporama-symbolic.svg
+share/icons/hicolor/scalable/actions/xapp-favorite-symbolic.svg
+share/icons/hicolor/scalable/actions/xapp-format-text-highlight-symbolic.svg
share/icons/hicolor/scalable/actions/xapp-go-history-next-symbolic-rtl.svg
share/icons/hicolor/scalable/actions/xapp-go-history-next-symbolic.svg
share/icons/hicolor/scalable/actions/xapp-go-history-previous-symbolic-rtl.svg
share/icons/hicolor/scalable/actions/xapp-go-history-previous-symbolic.svg
+share/icons/hicolor/scalable/actions/xapp-pin-symbolic.svg
share/icons/hicolor/scalable/actions/xapp-search-entire-word-symbolic.svg
share/icons/hicolor/scalable/actions/xapp-search-wrap-symbolic.svg
share/icons/hicolor/scalable/actions/xapp-text-case-symbolic.svg
+share/icons/hicolor/scalable/actions/xapp-unfavorite-symbolic.svg
+share/icons/hicolor/scalable/actions/xapp-unpin-symbolic.svg
share/icons/hicolor/scalable/actions/xapp-use-regex-symbolic.svg
+share/icons/hicolor/scalable/apps/xapp-favorites-app-symbolic.svg
+share/icons/hicolor/scalable/apps/xapp-favorites-app.svg
share/icons/hicolor/scalable/categories/xapp-prefs-behavior-symbolic.svg
share/icons/hicolor/scalable/categories/xapp-prefs-display-symbolic.svg
share/icons/hicolor/scalable/categories/xapp-prefs-plugins-symbolic.svg
share/icons/hicolor/scalable/categories/xapp-prefs-preview-symbolic.svg
share/icons/hicolor/scalable/categories/xapp-prefs-toolbar-symbolic.svg
+share/icons/hicolor/scalable/emblems/emblem-xapp-favorite.svg
+share/icons/hicolor/scalable/places/xapp-user-favorites-symbolic.svg
+share/icons/hicolor/scalable/places/xapp-user-favorites.svg
+share/locale/af/LC_MESSAGES/xapp.mo
share/locale/am/LC_MESSAGES/xapp.mo
share/locale/ar/LC_MESSAGES/xapp.mo
share/locale/az/LC_MESSAGES/xapp.mo
+share/locale/ber/LC_MESSAGES/xapp.mo
share/locale/bg/LC_MESSAGES/xapp.mo
share/locale/bn/LC_MESSAGES/xapp.mo
share/locale/ca/LC_MESSAGES/xapp.mo
@@ -57,6 +113,8 @@ share/locale/et/LC_MESSAGES/xapp.mo
share/locale/eu/LC_MESSAGES/xapp.mo
share/locale/fi/LC_MESSAGES/xapp.mo
share/locale/fr/LC_MESSAGES/xapp.mo
+share/locale/fr_CA/LC_MESSAGES/xapp.mo
+share/locale/he/LC_MESSAGES/xapp.mo
share/locale/hi/LC_MESSAGES/xapp.mo
share/locale/hr/LC_MESSAGES/xapp.mo
share/locale/hu/LC_MESSAGES/xapp.mo
@@ -66,13 +124,16 @@ share/locale/ie/LC_MESSAGES/xapp.mo
share/locale/is/LC_MESSAGES/xapp.mo
share/locale/it/LC_MESSAGES/xapp.mo
share/locale/ja/LC_MESSAGES/xapp.mo
+share/locale/ka/LC_MESSAGES/xapp.mo
share/locale/kab/LC_MESSAGES/xapp.mo
share/locale/kk/LC_MESSAGES/xapp.mo
share/locale/ko/LC_MESSAGES/xapp.mo
share/locale/ku/LC_MESSAGES/xapp.mo
share/locale/lt/LC_MESSAGES/xapp.mo
+share/locale/mai/LC_MESSAGES/xapp.mo
share/locale/ms/LC_MESSAGES/xapp.mo
share/locale/nl/LC_MESSAGES/xapp.mo
+share/locale/oc/LC_MESSAGES/xapp.mo
share/locale/pl/LC_MESSAGES/xapp.mo
share/locale/pt/LC_MESSAGES/xapp.mo
share/locale/pt_BR/LC_MESSAGES/xapp.mo
@@ -81,11 +142,15 @@ share/locale/ru/LC_MESSAGES/xapp.mo
share/locale/sk/LC_MESSAGES/xapp.mo
share/locale/sl/LC_MESSAGES/xapp.mo
share/locale/sr/LC_MESSAGES/xapp.mo
+share/locale/sr@latin/LC_MESSAGES/xapp.mo
share/locale/sv/LC_MESSAGES/xapp.mo
share/locale/tr/LC_MESSAGES/xapp.mo
share/locale/uk/LC_MESSAGES/xapp.mo
share/locale/uz/LC_MESSAGES/xapp.mo
+share/locale/zgh/LC_MESSAGES/xapp.mo
share/locale/zh_CN/LC_MESSAGES/xapp.mo
+share/locale/zh_HK/LC_MESSAGES/xapp.mo
share/locale/zh_TW/LC_MESSAGES/xapp.mo
+share/mate-panel/applets/org.x.MateXAppStatusApplet.mate-panel-applet
share/vala/vapi/xapp.deps
share/vala/vapi/xapp.vapi
diff --git a/x11/xapps/Makefile b/x11/xapps/Makefile
deleted file mode 100644
index b7a53fe1e219..000000000000
--- a/x11/xapps/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= xapps
-PORTVERSION= 1.6.10
-PORTREVISION= 1
-CATEGORIES= x11
-
-MAINTAINER= x11@FreeBSD.org
-COMMENT= Cross-desktop libraries and common resources
-
-LICENSE= LGPL3
-
-PORTSCOUT= limit:^[0-9.]+$$ # ignore master.mint* tags
-
-BUILD_DEPENDS= vapigen:lang/vala
-LIB_DEPENDS= libgnomekbdui.so:x11/libgnomekbd
-
-USES= gettext gnome meson pkgconfig python:build shebangfix xorg
-USE_GITHUB= yes
-GH_ACCOUNT= linuxmint
-USE_GNOME= cairo gdkpixbuf2 gtk30 introspection:build
-USE_LDCONFIG= yes
-USE_XORG= x11
-GLIB_SCHEMAS= org.x.apps.gschema.xml
-INSTALLS_ICONS= yes
-SHEBANG_FILES= libxapp/g-codegen.py libxapp/install_generated_header.py \
- makedoc schemas/meson_install_schemas.py
-
-post-extract:
-# Do not install auxiliary scripts and adjust icons installation path
- @${RM} -r ${WRKSRC}/files/usr/bin
- @${MKDIR} ${WRKSRC}/files${PREFIX}
- @${MV} ${WRKSRC}/files/usr/share ${WRKSRC}/files${PREFIX}
-
-post-patch:
-# Do not build non-essential optional components for the moment
- @${REINPLACE_CMD} -E '/pygobject|status-applets/d' \
- ${WRKSRC}/meson.build
-
-.include <bsd.port.mk>
diff --git a/x11/xapps/distinfo b/x11/xapps/distinfo
deleted file mode 100644
index 8a33484d10ed..000000000000
--- a/x11/xapps/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1578590051
-SHA256 (linuxmint-xapps-1.6.10_GH0.tar.gz) = 4dd228a2165f1077f18d6fb3152bb77d365ffbb8ad883ed4dd9137886dd21377
-SIZE (linuxmint-xapps-1.6.10_GH0.tar.gz) = 158446
diff --git a/x11/xapps/pkg-descr b/x11/xapps/pkg-descr
deleted file mode 100644
index aa382880a12e..000000000000
--- a/x11/xapps/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-This project gathers the components which are common to multiple desktop
-environments and required to implement cross-DE solutions.
-
-WWW: https://github.com/linuxmint/xapps