aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-08-26 08:56:21 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-08-26 08:56:21 +0000
commit0de4761493afc5fb2aa23628e7f527fc0ab35735 (patch)
tree6d250ab4eb0552f0b19047c81424bb145df90505 /x11
parentc65cf6f0b72708afd07b5af96d4bf101ed5f9150 (diff)
downloadports-0de4761493afc5fb2aa23628e7f527fc0ab35735.tar.gz
ports-0de4761493afc5fb2aa23628e7f527fc0ab35735.zip
- Fix runtime on amd64
PR: ports/149954 Submitted by: Yuri <yuri@tsoft.com>
Notes
Notes: svn path=/head/; revision=259996
Diffstat (limited to 'x11')
-rw-r--r--x11/xmx/Makefile2
-rw-r--r--x11/xmx/files/patch-fix-amd6450
2 files changed, 51 insertions, 1 deletions
diff --git a/x11/xmx/Makefile b/x11/xmx/Makefile
index 72d8853c2b36..bcdc65a59f9e 100644
--- a/x11/xmx/Makefile
+++ b/x11/xmx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xmx
PORTVERSION= 1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= ftp://ftp.cs.brown.edu/pub/xmx/
EXTRACT_SUFX= .tar.Z
diff --git a/x11/xmx/files/patch-fix-amd64 b/x11/xmx/files/patch-fix-amd64
new file mode 100644
index 000000000000..9afd931827b4
--- /dev/null
+++ b/x11/xmx/files/patch-fix-amd64
@@ -0,0 +1,50 @@
+diff -ru bufio.c.orig bufio.c
+--- bufio.c.orig 1994-04-13 09:22:21.000000000 -0700
++++ bufio.c 2010-08-24 21:45:48.000000000 -0700
+@@ -35,9 +35,6 @@
+ static void adjust();
+ static void trim_high_water();
+
+-extern char * malloc();
+-extern char * calloc();
+-
+ /************************************************************************
+ * *
+ * local constants *
+diff -ru error.c.orig error.c
+--- error.c.orig 1994-04-13 09:22:22.000000000 -0700
++++ error.c 2010-08-24 21:46:53.000000000 -0700
+@@ -16,6 +16,7 @@
+ * *
+ ************************************************************************/
+ #include <stdio.h>
++#include "xmx.h"
+
+ static int print = 1;
+
+diff -ru xmx.h.orig xmx.h
+--- xmx.h.orig 1994-04-13 09:22:24.000000000 -0700
++++ xmx.h 2010-08-24 21:46:14.000000000 -0700
+@@ -38,6 +38,11 @@
+
+ #define REQHISTORY 64 /* size of per client history */
+
++#include <stdlib.h>
++#include <stdio.h>
++#include <string.h>
++#include <strings.h>
++
+ typedef unsigned long rid_t;
+ typedef unsigned long atom_t;
+ typedef unsigned long pixel_t;
+@@ -104,10 +109,6 @@
+ * *
+ ************************************************************************/
+
+-/* system */
+-char * malloc();
+-char * calloc();
+-
+ /* bufio.c */
+
+ void buf_init();