aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-01-31 07:46:46 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-01-31 07:46:46 +0000
commit10ea80fb5c59ee97e1f27f695dd511e92533588b (patch)
tree4f3571f71c3ff5433cbf657da0f01eab2d15f374 /x11
parent8d1937bc7dfa27cb45cabbb034766f2af68ae654 (diff)
downloadports-10ea80fb5c59ee97e1f27f695dd511e92533588b.tar.gz
ports-10ea80fb5c59ee97e1f27f695dd511e92533588b.zip
x11/libinput: Update to 1.12.6
Update libinput to 1.12.6. This is the last remaining piece to bring us basically up to date with upstream input stack. PR: 222905 Reported by: Greg V (original version) Obtained from: FreeBSDDesktop development repo https://github.com/FreeBSDDesktop/freebsd-ports/tree/feature/input-ports Tested by: tcberner (kde@), andrnils@gmail.com Sponsored by: B3 Init (zeising)
Notes
Notes: svn path=/head/; revision=491694
Diffstat (limited to 'x11')
-rw-r--r--x11/libinput/Makefile18
-rw-r--r--x11/libinput/distinfo6
-rw-r--r--x11/libinput/files/patch-src_evdev.c6
-rw-r--r--x11/libinput/pkg-plist37
4 files changed, 47 insertions, 20 deletions
diff --git a/x11/libinput/Makefile b/x11/libinput/Makefile
index 3438ed299d66..cad756b2a0aa 100644
--- a/x11/libinput/Makefile
+++ b/x11/libinput/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= libinput
-PORTVERSION= 1.11.3
-PORTREVISION= 1
+PORTVERSION= 1.12.6
CATEGORIES= x11
MASTER_SITES= http://freedesktop.org/software/${PORTNAME}/
@@ -12,7 +11,6 @@ COMMENT= Generic input library
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}evdev>0:devel/py-evdev@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyudev>0:devel/py-pyudev@${PY_FLAVOR}
LIB_DEPENDS= libevdev.so:devel/libevdev \
@@ -21,25 +19,25 @@ LIB_DEPENDS= libevdev.so:devel/libevdev \
libmtdev.so:devel/libmtdev
USES= localbase meson pkgconfig python:3.4+,run shebangfix tar:xz
+USE_LDCONFIG= yes
MESON_ARGS+= -Ddocumentation=false -Dtests=false
-INSTALL_TARGET= install-strip
python_OLD_CMD= "/usr/bin/env python3"
-SHEBANG_FILES= tools/libinput-measure-fuzz \
- tools/libinput-measure-touch-size \
- tools/libinput-measure-touchpad-pressure \
- tools/libinput-measure-touchpad-tap \
- tools/libinput-measure-trackpoint-range \
+SHEBANG_FILES= tools/libinput-measure-fuzz.py \
+ tools/libinput-measure-touch-size.py \
+ tools/libinput-measure-touchpad-pressure.py \
+ tools/libinput-measure-touchpad-tap.py \
tools/libinput-replay
OPTIONS_DEFINE= DEBUG_GUI LIBWACOM
OPTIONS_DEFAULT=LIBWACOM
OPTIONS_SUB= yes
-
+
DEBUG_GUI_DESC= Build the GUI event viewer
LIBWACOM_DESC= Libwacom support
+DEBUG_GUI_USES= gnome
DEBUG_GUI_USE= GNOME=gtk30,glib20,cairo
DEBUG_GUI_MESON_TRUE= debug-gui
LIBWACOM_LIB_DEPENDS= libwacom.so:x11/libwacom
diff --git a/x11/libinput/distinfo b/x11/libinput/distinfo
index c3c5aa1fd9fb..5a5d44988ab7 100644
--- a/x11/libinput/distinfo
+++ b/x11/libinput/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1532702018
-SHA256 (libinput-1.11.3.tar.xz) = f31191d96e425b4f16319842279d65946d9d983dcd3d9e466ae1206aa10ecb06
-SIZE (libinput-1.11.3.tar.xz) = 487408
+TIMESTAMP = 1548226824
+SHA256 (libinput-1.12.6.tar.xz) = 12b4023a3fc683d3d8127db573bdf925a2ef366615042f69c87e57c32a50f45d
+SIZE (libinput-1.12.6.tar.xz) = 518784
diff --git a/x11/libinput/files/patch-src_evdev.c b/x11/libinput/files/patch-src_evdev.c
index 93d4b3644f63..c2ceddaed68c 100644
--- a/x11/libinput/files/patch-src_evdev.c
+++ b/x11/libinput/files/patch-src_evdev.c
@@ -6,9 +6,9 @@ libinput reopens devices just to check path equality.
The udev_devices from reopening do have the right properties,
so we just use them instead of the original (enumerated) ones.
---- src/evdev.c.orig 2018-06-09 12:13:43 UTC
+--- src/evdev.c.orig 2018-12-18 05:06:18 UTC
+++ src/evdev.c
-@@ -895,7 +895,7 @@ evdev_sync_device(struct evdev_device *device)
+@@ -905,7 +905,7 @@ evdev_sync_device(struct evdev_device *device)
evdev_device_dispatch_one(device, &ev);
} while (rc == LIBEVDEV_READ_STATUS_SYNC);
@@ -17,7 +17,7 @@ so we just use them instead of the original (enumerated) ones.
}
static void
-@@ -933,6 +933,17 @@ evdev_device_dispatch(void *data)
+@@ -943,6 +943,17 @@ evdev_device_dispatch(void *data)
if (rc != -EAGAIN && rc != -EINTR) {
libinput_remove_source(libinput, device->source);
diff --git a/x11/libinput/pkg-plist b/x11/libinput/pkg-plist
index 94682427cd64..44e033c8f155 100644
--- a/x11/libinput/pkg-plist
+++ b/x11/libinput/pkg-plist
@@ -12,18 +12,47 @@ libexec/libinput/libinput-measure-fuzz
libexec/libinput/libinput-measure-touch-size
libexec/libinput/libinput-measure-touchpad-pressure
libexec/libinput/libinput-measure-touchpad-tap
-libexec/libinput/libinput-measure-trackpoint-range
+libexec/libinput/libinput-quirks
libexec/libinput/libinput-record
libexec/libinput/libinput-replay
-man/man1/libinput.1.gz
man/man1/libinput-debug-events.1.gz
%%DEBUG_GUI%%man/man1/libinput-debug-gui.1.gz
man/man1/libinput-list-devices.1.gz
-man/man1/libinput-measure.1.gz
man/man1/libinput-measure-fuzz.1.gz
man/man1/libinput-measure-touch-size.1.gz
man/man1/libinput-measure-touchpad-pressure.1.gz
man/man1/libinput-measure-touchpad-tap.1.gz
-man/man1/libinput-measure-trackpoint-range.1.gz
+man/man1/libinput-measure.1.gz
+man/man1/libinput-quirks-list.1.gz
+man/man1/libinput-quirks-validate.1.gz
+man/man1/libinput-quirks.1.gz
man/man1/libinput-record.1.gz
man/man1/libinput-replay.1.gz
+man/man1/libinput.1.gz
+%%DATADIR%%/10-generic-keyboard.quirks
+%%DATADIR%%/10-generic-lid.quirks
+%%DATADIR%%/10-generic-trackball.quirks
+%%DATADIR%%/30-vendor-aiptek.quirks
+%%DATADIR%%/30-vendor-alps.quirks
+%%DATADIR%%/30-vendor-contour.quirks
+%%DATADIR%%/30-vendor-cyapa.quirks
+%%DATADIR%%/30-vendor-elantech.quirks
+%%DATADIR%%/30-vendor-huion.quirks
+%%DATADIR%%/30-vendor-ibm.quirks
+%%DATADIR%%/30-vendor-kensington.quirks
+%%DATADIR%%/30-vendor-logitech.quirks
+%%DATADIR%%/30-vendor-microsoft.quirks
+%%DATADIR%%/30-vendor-razer.quirks
+%%DATADIR%%/30-vendor-synaptics.quirks
+%%DATADIR%%/30-vendor-vmware.quirks
+%%DATADIR%%/30-vendor-wacom.quirks
+%%DATADIR%%/50-system-acer.quirks
+%%DATADIR%%/50-system-apple.quirks
+%%DATADIR%%/50-system-asus.quirks
+%%DATADIR%%/50-system-chicony.quirks
+%%DATADIR%%/50-system-cyborg.quirks
+%%DATADIR%%/50-system-dell.quirks
+%%DATADIR%%/50-system-google.quirks
+%%DATADIR%%/50-system-hp.quirks
+%%DATADIR%%/50-system-lenovo.quirks
+%%DATADIR%%/50-system-system76.quirks