aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-08-16 00:38:02 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-08-16 00:38:02 +0000
commit1a11a3cc2cb64cc67c7a28a3dcc032a1a80aa110 (patch)
tree436563e5998f13f8ec715d62347ba848acb044ce /x11
parent42f8fd70317ee67fc3b7d290e72a427b315bf91b (diff)
downloadports-1a11a3cc2cb64cc67c7a28a3dcc032a1a80aa110.tar.gz
ports-1a11a3cc2cb64cc67c7a28a3dcc032a1a80aa110.zip
x11/lavalauncher: add new port
LavaLauncher serves a single purpose: Letting the user execute shell commands by clicking on icons on a dynamically sized bar, placed at one of the screen edges. Unlike most popular launchers, LavaLauncher does not care about .desktop files or icon themes and it does not track open applications; It is not a dock. To create a button, you simply provide the path to an image and a shell command. This makes LavaLauncher considerably more flexible: You could have buttons not just for launching applications, but also for ejecting your optical drive, rotating your screen, sending your cat an email, playing a funny sound, muting all audio, toggling your lamps, etc. You can turn practically anything you could do in your shell into a button. https://git.sr.ht/~leon_plickat/lavalauncher
Notes
Notes: svn path=/head/; revision=545084
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/lavalauncher/Makefile33
-rw-r--r--x11/lavalauncher/distinfo5
-rw-r--r--x11/lavalauncher/pkg-descr15
4 files changed, 54 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index f9c93a22bb20..5f11c940c4dc 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -129,6 +129,7 @@
SUBDIR += kf5-kwindowsystem
SUBDIR += kf5-plasma-framework
SUBDIR += konsole
+ SUBDIR += lavalauncher
SUBDIR += lemonbar
SUBDIR += libICE
SUBDIR += libSM
diff --git a/x11/lavalauncher/Makefile b/x11/lavalauncher/Makefile
new file mode 100644
index 000000000000..fa1de85cd6a8
--- /dev/null
+++ b/x11/lavalauncher/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= lavalauncher
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.7.1
+CATEGORIES= x11
+MASTER_SITES= https://git.sr.ht/~leon_plickat/${PORTNAME}/archive/${DISTVERSIONFULL}${EXTRACT_SUFX}?dummy=/
+
+PATCH_SITES= https://git.sr.ht/~leon_plickat/${PORTNAME}/commit/
+PATCHFILES+= 7142822a8082.patch:-p1
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Simple launcher for Wayland
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
+ wayland-protocols>0:graphics/wayland-protocols
+LIB_DEPENDS= libwayland-client.so:graphics/wayland
+
+USES= compiler:c11 gnome localbase meson pkgconfig
+USE_GNOME= cairo
+PLIST_FILES= bin/${PORTNAME}
+
+OPTIONS_DEFINE= MANPAGES
+OPTIONS_DEFAULT=MANPAGES
+
+MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
+MANPAGES_MESON_ENABLED= man-page
+MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz
+
+.include <bsd.port.mk>
diff --git a/x11/lavalauncher/distinfo b/x11/lavalauncher/distinfo
new file mode 100644
index 000000000000..da12ca7b8b69
--- /dev/null
+++ b/x11/lavalauncher/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1589545119
+SHA256 (lavalauncher-v1.7.1.tar.gz) = ff67f599de523daf50bd4d8351fd299c1967dd622126086145f7f035a329bbdb
+SIZE (lavalauncher-v1.7.1.tar.gz) = 82550
+SHA256 (7142822a8082.patch) = 9184ff5b1d3b2bf9f16097e7a21ab635d4bf8d2c0a0592cfad7d437797e1ed9f
+SIZE (7142822a8082.patch) = 1348
diff --git a/x11/lavalauncher/pkg-descr b/x11/lavalauncher/pkg-descr
new file mode 100644
index 000000000000..5da345f7c224
--- /dev/null
+++ b/x11/lavalauncher/pkg-descr
@@ -0,0 +1,15 @@
+LavaLauncher serves a single purpose: Letting the user execute shell
+commands by clicking on icons on a dynamically sized bar, placed at
+one of the screen edges.
+
+Unlike most popular launchers, LavaLauncher does not care about
+.desktop files or icon themes and it does not track open applications;
+It is not a dock. To create a button, you simply provide the path to
+an image and a shell command. This makes LavaLauncher considerably
+more flexible: You could have buttons not just for launching
+applications, but also for ejecting your optical drive, rotating your
+screen, sending your cat an email, playing a funny sound, muting all
+audio, toggling your lamps, etc. You can turn practically anything you
+could do in your shell into a button.
+
+WWW: https://git.sr.ht/~leon_plickat/lavalauncher