aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2011-04-02 02:28:33 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2011-04-02 02:28:33 +0000
commit2aba6faf1e4bcb3f585d0a8fae6a6bba68ceaeb2 (patch)
tree52b18a92483f544ea5eb5138281b33d9455f65e1 /x11
parent742d06bd88050c02c5ed76e3f6080c7a6a1aee46 (diff)
downloadports-2aba6faf1e4bcb3f585d0a8fae6a6bba68ceaeb2.tar.gz
ports-2aba6faf1e4bcb3f585d0a8fae6a6bba68ceaeb2.zip
- Update to 3.0.3.
- Add IBUS option.
Notes
Notes: svn path=/head/; revision=272111
Diffstat (limited to 'x11')
-rw-r--r--x11/mlterm/Makefile15
-rw-r--r--x11/mlterm/distinfo4
-rw-r--r--x11/mlterm/files/patch-inputmethod_ibus_im_ibus.c13
-rw-r--r--x11/mlterm/pkg-plist4
4 files changed, 32 insertions, 4 deletions
diff --git a/x11/mlterm/Makefile b/x11/mlterm/Makefile
index 5b5131fe849a..729306f96039 100644
--- a/x11/mlterm/Makefile
+++ b/x11/mlterm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mlterm
-PORTVERSION= 3.0.2
+PORTVERSION= 3.0.3
CATEGORIES= x11
MASTER_SITES= SF/${PORTNAME}/01release/${PORTNAME}-${PORTVERSION}
@@ -31,7 +31,8 @@ OPTIONS= FRIBIDI "Use Fribidi for BiDi rendering" off \
UIM "uim support (experimental)" off \
M17NLIB "m17n library support (experimental)" off \
IIIMF "IIIMF support (experimental)" off \
- SCIM "SCIM support (experimental)" off
+ SCIM "SCIM support (experimental)" off \
+ IBUS "IBUS support (experimental)" off
.include <bsd.port.pre.mk>
@@ -81,6 +82,16 @@ CONFIGURE_ARGS+= --disable-scim
PLIST_SUB+= SCIM="@comment "
.endif
+.if defined(WITH_IBUS)
+CONFIGURE_ARGS+= --enable-ibus
+MAKE_ENV= LIBS_LOCAL=-L${LOCALBASE}/lib
+LIB_DEPENDS+= ibus.2:${PORTSDIR}/textproc/ibus
+PLIST_SUB+= IBUS=""
+.else
+CONFIGURE_ARGS+= --disable-ibus
+PLIST_SUB+= IBUS="@comment "
+.endif
+
.if ${OSVERSION} >= 900004
MAKE_ENV= LIBS_LOCAL=-lutempter
.else
diff --git a/x11/mlterm/distinfo b/x11/mlterm/distinfo
index bbc31a1d76b0..f0fedf806734 100644
--- a/x11/mlterm/distinfo
+++ b/x11/mlterm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mlterm-3.0.2.tar.gz) = d4e2bbbc1e613521765845fd9596794be8e042a1353d426452108d5561b01b74
-SIZE (mlterm-3.0.2.tar.gz) = 2678853
+SHA256 (mlterm-3.0.3.tar.gz) = be3f440ef884e739cc0dfa5f805a1d560508746fd4c9895817e3d9169bbbbe6d
+SIZE (mlterm-3.0.3.tar.gz) = 2706811
diff --git a/x11/mlterm/files/patch-inputmethod_ibus_im_ibus.c b/x11/mlterm/files/patch-inputmethod_ibus_im_ibus.c
new file mode 100644
index 000000000000..17b3530a596a
--- /dev/null
+++ b/x11/mlterm/files/patch-inputmethod_ibus_im_ibus.c
@@ -0,0 +1,13 @@
+--- inputmethod/ibus/im_ibus.c.orig 2011-04-02 11:18:35.000000000 +0900
++++ inputmethod/ibus/im_ibus.c 2011-04-02 11:19:03.000000000 +0900
+@@ -627,8 +627,8 @@
+ return NULL ;
+ }
+
+- result->id = strdup( "iBus") ;
+- result->name = strdup( "iBus") ;
++ result->id = strdup( "ibus") ;
++ result->name = strdup( "ibus") ;
+ result->num_of_args = 0;
+ result->args = NULL ;
+ result->readable_args = NULL ;
diff --git a/x11/mlterm/pkg-plist b/x11/mlterm/pkg-plist
index ac9510bed8d9..625097a6095c 100644
--- a/x11/mlterm/pkg-plist
+++ b/x11/mlterm/pkg-plist
@@ -38,6 +38,9 @@ lib/mkf/libmkf_zh.so
lib/mlterm/libathena.a
lib/mlterm/libathena.la
lib/mlterm/libathena.so
+%%IBUS%%lib/mlterm/libim-ibus.a
+%%IBUS%%lib/mlterm/libim-ibus.la
+%%IBUS%%lib/mlterm/libim-ibus.so
%%IIIMF%%lib/mlterm/libim-iiimf.a
%%IIIMF%%lib/mlterm/libim-iiimf.la
%%IIIMF%%lib/mlterm/libim-iiimf.so
@@ -69,6 +72,7 @@ lib/mlterm/libsample2.a
lib/mlterm/libsample2.la
lib/mlterm/libsample2.so
libexec/mlconfig
+libexec/mlimgloader
libexec/mlterm-menu
libexec/w3mmlconfig/mlconfig-data.pl
libexec/w3mmlconfig/mlconfig.cgi