aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-08-02 20:23:55 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-08-02 20:23:55 +0000
commit2f0486b64721a1072cdd1b8d2840d6539b2247d2 (patch)
tree36ed89e03b0f2ac4525ba4f4e39af16da597b209 /x11
parent05aa1eb8b1e5d76cddd216c787c98b5cfe7db1e9 (diff)
downloadports-2f0486b64721a1072cdd1b8d2840d6539b2247d2.tar.gz
ports-2f0486b64721a1072cdd1b8d2840d6539b2247d2.zip
Part 1 of adding USE_GNOME=intltool to ports that require it.
The reason for this is that in the GNOME 3.16 update, USE_GNOME gtk20 and gtk30 don't pull intltool in anymore. PR: 201980 Exp-run by: antoine@
Notes
Notes: svn path=/head/; revision=393444
Diffstat (limited to 'x11')
-rw-r--r--x11/brightside/Makefile2
-rw-r--r--x11/gsynaptics/Makefile2
-rw-r--r--x11/guake/Makefile2
-rw-r--r--x11/libfm/Makefile2
-rw-r--r--x11/lxpanel/Makefile2
-rw-r--r--x11/lxrandr/Makefile2
-rw-r--r--x11/terminator/Makefile2
-rw-r--r--x11/yad/Makefile4
8 files changed, 9 insertions, 9 deletions
diff --git a/x11/brightside/Makefile b/x11/brightside/Makefile
index 4363c2ea5277..5f8098f01e36 100644
--- a/x11/brightside/Makefile
+++ b/x11/brightside/Makefile
@@ -13,7 +13,7 @@ COMMENT= Tool to add reactivity to the edges and corners of the GNOME desktop
USES= gmake pathfix pkgconfig tar:bzip2
USE_XORG= x11
GNU_CONFIGURE= yes
-USE_GNOME= gnomeprefix libwnck libgnomeui
+USE_GNOME= gnomeprefix libwnck libgnomeui intltool
CONFIGURE_ARGS= --enable-tray-icon
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lX11
diff --git a/x11/gsynaptics/Makefile b/x11/gsynaptics/Makefile
index 0035e3178f77..f3845b2f730d 100644
--- a/x11/gsynaptics/Makefile
+++ b/x11/gsynaptics/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
RUN_DEPENDS= xf86-input-synaptics>0:${PORTSDIR}/x11-drivers/xf86-input-synaptics
USES= gettext gmake pathfix pkgconfig
-USE_GNOME= gconf2 libglade2 gnomedocutils
+USE_GNOME= gconf2 libglade2 gnomedocutils intltool
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/x11/guake/Makefile b/x11/guake/Makefile
index 7ba2eb5a61ca..abe5039c4519 100644
--- a/x11/guake/Makefile
+++ b/x11/guake/Makefile
@@ -43,7 +43,7 @@ PLIST_SUB+= DESKTOPDIR="${DESKTOPDIR:S,${PREFIX}/,,}"
USES= autoreconf:build desktop-file-utils gettext gmake libtool \
pkgconfig python:2
USE_GITHUB= yes
-USE_GNOME= gtk20 pygnome2
+USE_GNOME= gtk20 pygnome2 intltool
.include <bsd.port.options.mk>
diff --git a/x11/libfm/Makefile b/x11/libfm/Makefile
index 81a0380c113a..a49dc1f93d08 100644
--- a/x11/libfm/Makefile
+++ b/x11/libfm/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libmenu-cache.so:${PORTSDIR}/x11/menu-cache \
SLAVEDIRS= ${CATEGORIES}/${PORTNAME}-extra
USES= gettext-tools gmake libtool pathfix pkgconfig tar:xz
-USE_GNOME= glib20
+USE_GNOME= glib20 intltool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${LOCALBASE}/etc --disable-static
diff --git a/x11/lxpanel/Makefile b/x11/lxpanel/Makefile
index b40c22acd1d7..782853416730 100644
--- a/x11/lxpanel/Makefile
+++ b/x11/lxpanel/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/desktop-directories/lxde-audio-video.directory:$
USE_AUTOTOOLS= automake:env
USE_CSTD= gnu89
-USE_GNOME= gtk20 libwnck
+USE_GNOME= gtk20 libwnck intltool
USE_XORG= x11 xmu
USES= gmake pathfix pkgconfig
GNU_CONFIGURE= yes
diff --git a/x11/lxrandr/Makefile b/x11/lxrandr/Makefile
index 70656e57c9f9..51e00d06db48 100644
--- a/x11/lxrandr/Makefile
+++ b/x11/lxrandr/Makefile
@@ -12,7 +12,7 @@ COMMENT= LXDE screen manager
LICENSE= GPLv2
USES= desktop-file-utils gmake pkgconfig
-USE_GNOME= gtk20
+USE_GNOME= gtk20 intltool
USE_XORG= xrandr
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
diff --git a/x11/terminator/Makefile b/x11/terminator/Makefile
index a742d89c4b66..7dc65636333d 100644
--- a/x11/terminator/Makefile
+++ b/x11/terminator/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}notify>=0:${PORTSDIR}/devel/py-notify \
${PYTHON_PKGNAMEPREFIX}vte>=0:${PORTSDIR}/x11-toolkits/py-vte
USES= python
-USE= GNOME=pygtk2
+USE= GNOME=pygtk2,intltool
USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= Terminator
diff --git a/x11/yad/Makefile b/x11/yad/Makefile
index 1611ab687207..6525d077c866 100644
--- a/x11/yad/Makefile
+++ b/x11/yad/Makefile
@@ -30,9 +30,9 @@ OPTIONS_DEFAULT= GTK2
NLS_CONFIGURE_OFF= --disable-nls
NLS_USES= gettext
GTK2_CONFIGURE_ON= --with-gtk=gtk2
-GTK2_USE= GNOME=gtk20
+GTK2_USE= GNOME=gtk20,intltool
GTK3_CONFIGURE_ON= --with-gtk=gtk3
-GTK3_USE= GNOME=gtk30
+GTK3_USE= GNOME=gtk30,intltool
ICONBROWSER_CONFIGURE_ENABLE= icon-browser
.include <bsd.port.options.mk>