aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2023-01-16 18:57:19 +0000
committerCy Schubert <cy@FreeBSD.org>2023-01-17 21:12:11 +0000
commit30387c1f04de9965f4fa56b4f95a6676477ebe72 (patch)
tree9f43e3544d55912107c4440db7a3e11acc77ca8f /x11
parent0ffb609ec452b6ad34ea3be0ec2167d9d5630031 (diff)
downloadports-30387c1f04de9965f4fa56b4f95a6676477ebe72.tar.gz
ports-30387c1f04de9965f4fa56b4f95a6676477ebe72.zip
x11/cde*: Remove call to tzsetall()
As of src d5c85ac6526d, the tzcode update removed the tzsetwall() function. Our tzcode upstream removed tzsetwall() in their commit d36f8f5b6983. The reason they did this was that tzsetwall() was "undocumented and ineffective." MFH: 2023Q1
Diffstat (limited to 'x11')
-rw-r--r--x11/cde-24/Makefile1
-rw-r--r--x11/cde-24/files/patch-programs_dtcm_libDtCmP_timeops.c11
-rw-r--r--x11/cde-25/Makefile2
-rw-r--r--x11/cde-25/files/patch-programs_dtcm_libDtCmP_timeops.c11
-rw-r--r--x11/cde-devel/Makefile2
-rw-r--r--x11/cde-devel/files/patch-programs_dtcm_libDtCmP_timeops.c11
6 files changed, 36 insertions, 2 deletions
diff --git a/x11/cde-24/Makefile b/x11/cde-24/Makefile
index 13b965fcba40..b721c769f828 100644
--- a/x11/cde-24/Makefile
+++ b/x11/cde-24/Makefile
@@ -1,5 +1,6 @@
PORTNAME= cde
DISTVERSION= 2.4.0
+PORTREVISION= 2
CATEGORIES= x11
MASTER_SITES= SF/cdesktopenv/src/
.if !defined(MASTERDIR)
diff --git a/x11/cde-24/files/patch-programs_dtcm_libDtCmP_timeops.c b/x11/cde-24/files/patch-programs_dtcm_libDtCmP_timeops.c
new file mode 100644
index 000000000000..ee691a8d5b18
--- /dev/null
+++ b/x11/cde-24/files/patch-programs_dtcm_libDtCmP_timeops.c
@@ -0,0 +1,11 @@
+--- programs/dtcm/libDtCmP/timeops.c.orig 2023-01-16 10:43:01.353775000 -0800
++++ programs/dtcm/libDtCmP/timeops.c 2023-01-16 10:50:35.918370000 -0800
+@@ -960,7 +960,7 @@
+ */
+ if (tzname==NULL) system("unset TZ\n");
+ #else
+- if (tzname==NULL) tzsetwall();
++ if (tzname==NULL) tzset();
+ #endif /* SVR4 */
+
+ else {
diff --git a/x11/cde-25/Makefile b/x11/cde-25/Makefile
index 73067122110c..a0100ca8ea14 100644
--- a/x11/cde-25/Makefile
+++ b/x11/cde-25/Makefile
@@ -1,6 +1,6 @@
PORTNAME= cde
DISTVERSION= 2.5.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11
MASTER_SITES= SF/cdesktopenv/src/
.if !defined(MASTERDIR)
diff --git a/x11/cde-25/files/patch-programs_dtcm_libDtCmP_timeops.c b/x11/cde-25/files/patch-programs_dtcm_libDtCmP_timeops.c
new file mode 100644
index 000000000000..efb412aa000f
--- /dev/null
+++ b/x11/cde-25/files/patch-programs_dtcm_libDtCmP_timeops.c
@@ -0,0 +1,11 @@
+--- programs/dtcm/libDtCmP/timeops.c.orig 2023-01-16 09:58:33.955866000 -0800
++++ programs/dtcm/libDtCmP/timeops.c 2023-01-16 10:47:36.739851000 -0800
+@@ -963,7 +963,7 @@
+ */
+ if (tzname==NULL) system("unset TZ\n");
+ #else
+- if (tzname==NULL) tzsetwall();
++ if (tzname==NULL) tzset();
+ #endif /* SVR4 */
+
+ else {
diff --git a/x11/cde-devel/Makefile b/x11/cde-devel/Makefile
index 2774b00592d3..1757e62e1a49 100644
--- a/x11/cde-devel/Makefile
+++ b/x11/cde-devel/Makefile
@@ -1,6 +1,6 @@
PORTNAME= cde
PORTVERSION= ${COMMIT_DATE}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11
.if !defined(MASTERDIR)
PKGNAMESUFFIX= -devel
diff --git a/x11/cde-devel/files/patch-programs_dtcm_libDtCmP_timeops.c b/x11/cde-devel/files/patch-programs_dtcm_libDtCmP_timeops.c
new file mode 100644
index 000000000000..3723b2e4d24d
--- /dev/null
+++ b/x11/cde-devel/files/patch-programs_dtcm_libDtCmP_timeops.c
@@ -0,0 +1,11 @@
+--- programs/dtcm/libDtCmP/timeops.c.orig 2023-01-16 09:59:52.166236000 -0800
++++ programs/dtcm/libDtCmP/timeops.c 2023-01-16 10:43:55.531953000 -0800
+@@ -963,7 +963,7 @@
+ */
+ if (tzname==NULL) system("unset TZ\n");
+ #else
+- if (tzname==NULL) tzsetwall();
++ if (tzname==NULL) tzset();
+ #endif /* SVR4 */
+
+ else {