aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2011-05-01 18:46:39 +0000
committerDoug Barton <dougb@FreeBSD.org>2011-05-01 18:46:39 +0000
commit38d15fa6e8a075e08bef76655b8d429dd91d7f3d (patch)
tree25dd135155b3a9324b90f9798c94877f4aa480aa /x11
parent75b07ada89c54c9a345ec9794767f61404b59be8 (diff)
downloadports-38d15fa6e8a075e08bef76655b8d429dd91d7f3d.tar.gz
ports-38d15fa6e8a075e08bef76655b8d429dd91d7f3d.zip
Conditionally take advantage of the new get_pidfile_from_conf in rc.subr
PR: ports/156594 Submitted by: me Approved by: maintainer
Notes
Notes: svn path=/head/; revision=273409
Diffstat (limited to 'x11')
-rw-r--r--x11/slim/Makefile2
-rw-r--r--x11/slim/files/slim.sh.in15
2 files changed, 15 insertions, 2 deletions
diff --git a/x11/slim/Makefile b/x11/slim/Makefile
index 74611d633fa4..639148312d0b 100644
--- a/x11/slim/Makefile
+++ b/x11/slim/Makefile
@@ -7,7 +7,7 @@
PORTNAME= slim
PORTVERSION= 1.3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_BERLIOS} \
http://depot.fsck.ch/mirror/distfiles/
diff --git a/x11/slim/files/slim.sh.in b/x11/slim/files/slim.sh.in
index 642cfacd0045..7141f6a38923 100644
--- a/x11/slim/files/slim.sh.in
+++ b/x11/slim/files/slim.sh.in
@@ -30,12 +30,23 @@ load_rc_config $name
command=%%PREFIX%%/bin/slim
command_args="-d"
-pidfile=/var/run/slim.pid
+
+find_pidfile()
+{
+ if type get_pidfile_from_conf >/dev/null 2>&1 &&
+ get_pidfile_from_conf lockfile %%PREFIX%%/etc/${name}.conf; then
+ pidfile="$_pidfile_from_conf"
+ else
+ pidfile="/var/run/${name}.pid"
+ fi
+}
slim_rmfile ()
{
local file
+ [ -z "$pidfile" ] && find_pidfile
+
for file in $pidfile /var/run/slim.auth; do
[ -e "$file" ] && unlink $file
done
@@ -47,6 +58,8 @@ slim_prestop ()
{
local xpid
+ find_pidfile
+
xpid=`ps -axww | grep '/bin/[X] .* -auth /var/run/slim.auth'`
xpid="${xpid## }"
[ -n "$xpid" ] && kill ${xpid%% *}