aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJoel Bodenmann <jbo@FreeBSD.org>2023-11-12 19:29:41 +0000
committerJoel Bodenmann <jbo@FreeBSD.org>2023-11-13 20:55:13 +0000
commit468f1ec7596d48409e999422b2007d42f0b15e17 (patch)
tree0d76a6fa5f957d28db35d9a9f9f1846ae6d81826 /x11
parent1939f1562411e5155390cfe7147af0a5c890f1bc (diff)
downloadports-468f1ec7596d48409e999422b2007d42f0b15e17.tar.gz
ports-468f1ec7596d48409e999422b2007d42f0b15e17.zip
x11/polybar: Update to 3.7.0
Changelog: https://github.com/polybar/polybar/releases/tag/3.7.0 Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D42529
Diffstat (limited to 'x11')
-rw-r--r--x11/polybar/Makefile3
-rw-r--r--x11/polybar/distinfo6
-rw-r--r--x11/polybar/files/patch-CMakeLists.txt11
-rw-r--r--x11/polybar/files/patch-include_cairo_context.hpp10
-rw-r--r--x11/polybar/files/patch-include_common.hpp8
-rw-r--r--x11/polybar/files/patch-lib_i3ipcpp_src_ipc.cpp10
-rw-r--r--x11/polybar/files/patch-src_modules_cpu.cpp16
-rw-r--r--x11/polybar/files/patch-src_modules_memory.cpp14
-rw-r--r--x11/polybar/files/patch-src_utils_string.cpp10
9 files changed, 51 insertions, 37 deletions
diff --git a/x11/polybar/Makefile b/x11/polybar/Makefile
index 499f4b60d957..4f4397e78ffe 100644
--- a/x11/polybar/Makefile
+++ b/x11/polybar/Makefile
@@ -1,6 +1,5 @@
PORTNAME= polybar
-DISTVERSION= 3.6.3
-PORTREVISION= 3
+DISTVERSION= 3.7.0
CATEGORIES= x11
MASTER_SITES= https://github.com/polybar/polybar/releases/download/${DISTVERSION}/
diff --git a/x11/polybar/distinfo b/x11/polybar/distinfo
index f1d6b1a6b110..899c89a1255d 100644
--- a/x11/polybar/distinfo
+++ b/x11/polybar/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1651678522
-SHA256 (polybar-3.6.3.tar.gz) = f25758573567208fc7b6f4d4115a6117a87389cbcc094cf605d079775be95fa5
-SIZE (polybar-3.6.3.tar.gz) = 439838
+TIMESTAMP = 1699810833
+SHA256 (polybar-3.7.0.tar.gz) = b8e07aca94a013341b7d47ee548afe84f519113f202300565d4852885a11e91d
+SIZE (polybar-3.7.0.tar.gz) = 494588
diff --git a/x11/polybar/files/patch-CMakeLists.txt b/x11/polybar/files/patch-CMakeLists.txt
deleted file mode 100644
index 00a661bf7aad..000000000000
--- a/x11/polybar/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt.orig 2022-03-27 18:35:56 UTC
-+++ CMakeLists.txt
-@@ -63,7 +63,7 @@ endif()
-
- if(BUILD_CONFIG)
- install(FILES ${CMAKE_SOURCE_DIR}/doc/config.ini
-- DESTINATION /etc/${PROJECT_NAME}
-+ DESTINATION ${CMAKE_INSTALL_PREFIX}/etc/${PROJECT_NAME}
- COMPONENT config)
- endif()
-
diff --git a/x11/polybar/files/patch-include_cairo_context.hpp b/x11/polybar/files/patch-include_cairo_context.hpp
new file mode 100644
index 000000000000..fdb744f74a2c
--- /dev/null
+++ b/x11/polybar/files/patch-include_cairo_context.hpp
@@ -0,0 +1,10 @@
+--- include/cairo/context.hpp.orig 2023-11-12 19:12:43 UTC
++++ include/cairo/context.hpp
+@@ -3,6 +3,7 @@
+ #include <cairo/cairo-xcb.h>
+
+ #include <algorithm>
++#include <array>
+ #include <cmath>
+ #include <deque>
+ #include <iomanip>
diff --git a/x11/polybar/files/patch-include_common.hpp b/x11/polybar/files/patch-include_common.hpp
index fe04eb492818..82f3db90dd21 100644
--- a/x11/polybar/files/patch-include_common.hpp
+++ b/x11/polybar/files/patch-include_common.hpp
@@ -1,12 +1,12 @@
---- include/common.hpp.orig 2020-12-02 17:15:49 UTC
+--- include/common.hpp.orig 2023-11-05 22:37:13 UTC
+++ include/common.hpp
-@@ -5,6 +5,9 @@
+@@ -6,6 +6,9 @@
+ #include <type_traits>
#include <vector>
- #include <functional>
+#include <sys/types.h>
+#include <unistd.h>
+
#include "settings.hpp"
- #define POLYBAR_NS \
+ #define POLYBAR_NS namespace polybar {
diff --git a/x11/polybar/files/patch-lib_i3ipcpp_src_ipc.cpp b/x11/polybar/files/patch-lib_i3ipcpp_src_ipc.cpp
new file mode 100644
index 000000000000..8d75f7072573
--- /dev/null
+++ b/x11/polybar/files/patch-lib_i3ipcpp_src_ipc.cpp
@@ -0,0 +1,10 @@
+--- lib/i3ipcpp/src/ipc.cpp.orig 2023-11-12 19:08:48 UTC
++++ lib/i3ipcpp/src/ipc.cpp
+@@ -1,6 +1,7 @@
+ #include "i3ipc++/ipc.hpp"
+
+ #include <json/json.h>
++#include <sys/wait.h>
+
+ #include <auss.hpp>
+ #include <cstdio>
diff --git a/x11/polybar/files/patch-src_modules_cpu.cpp b/x11/polybar/files/patch-src_modules_cpu.cpp
index 7d31e2c08bff..7fdd0a291ce3 100644
--- a/x11/polybar/files/patch-src_modules_cpu.cpp
+++ b/x11/polybar/files/patch-src_modules_cpu.cpp
@@ -1,9 +1,7 @@
-diff --git src/modules/cpu.cpp src/modules/cpu.cpp
-index 527f27fb..179d9221 100644
---- src/modules/cpu.cpp
+--- src/modules/cpu.cpp.orig 2023-11-05 22:37:13 UTC
+++ src/modules/cpu.cpp
@@ -2,6 +2,11 @@
-
+
#include <fstream>
#include <istream>
+#ifdef __FreeBSD__
@@ -11,12 +9,12 @@ index 527f27fb..179d9221 100644
+ #include <sys/resource.h>
+ #include <sys/sysctl.h>
+#endif
-
+
#include "drawtypes/label.hpp"
#include "drawtypes/progressbar.hpp"
-@@ -128,6 +133,41 @@ namespace modules {
+@@ -129,6 +134,41 @@ namespace modules {
m_cputimes.clear();
-
+
try {
+#ifdef __FreeBSD__
+ // Get number of CPUs
@@ -55,8 +53,8 @@ index 527f27fb..179d9221 100644
+#else
std::ifstream in(PATH_CPU_INFO);
string str;
-
-@@ -148,6 +188,7 @@ namespace modules {
+
+@@ -149,6 +189,7 @@ namespace modules {
m_cputimes.back()->total = m_cputimes.back()->user + m_cputimes.back()->nice + m_cputimes.back()->system +
m_cputimes.back()->idle + m_cputimes.back()->steal;
}
diff --git a/x11/polybar/files/patch-src_modules_memory.cpp b/x11/polybar/files/patch-src_modules_memory.cpp
index b0d836e120db..908adb9a168d 100644
--- a/x11/polybar/files/patch-src_modules_memory.cpp
+++ b/x11/polybar/files/patch-src_modules_memory.cpp
@@ -1,6 +1,4 @@
-diff --git src/modules/memory.cpp src/modules/memory.cpp
-index eb36e5dc..042d85cb 100644
---- src/modules/memory.cpp
+--- src/modules/memory.cpp.orig 2023-11-05 22:37:13 UTC
+++ src/modules/memory.cpp
@@ -1,6 +1,10 @@
#include <fstream>
@@ -10,12 +8,12 @@ index eb36e5dc..042d85cb 100644
+ #include <sys/types.h>
+ #include <sys/sysctl.h>
+#endif
-
+
#include "drawtypes/label.hpp"
#include "drawtypes/progressbar.hpp"
-@@ -63,6 +67,25 @@ namespace modules {
+@@ -64,6 +68,25 @@ namespace modules {
unsigned long long kb_swap_free{0ULL};
-
+
try {
+#ifdef __FreeBSD__
+ std::size_t sz;
@@ -38,8 +36,8 @@ index eb36e5dc..042d85cb 100644
+#else
std::ifstream meminfo(PATH_MEMORY_INFO);
std::map<std::string, unsigned long long int> parsed;
-
-@@ -91,6 +114,7 @@ namespace modules {
+
+@@ -92,6 +115,7 @@ namespace modules {
// old kernel; give a best-effort approximation of available memory
kb_avail = parsed["MemFree"] + parsed["Buffers"] + parsed["Cached"] + parsed["SReclaimable"] - parsed["Shmem"];
}
diff --git a/x11/polybar/files/patch-src_utils_string.cpp b/x11/polybar/files/patch-src_utils_string.cpp
new file mode 100644
index 000000000000..2d5897731e5b
--- /dev/null
+++ b/x11/polybar/files/patch-src_utils_string.cpp
@@ -0,0 +1,10 @@
+--- src/utils/string.cpp.orig 2023-11-12 19:11:07 UTC
++++ src/utils/string.cpp
+@@ -1,6 +1,7 @@
+ #include "utils/string.hpp"
+
+ #include <algorithm>
++#include <array>
+ #include <cassert>
+ #include <iomanip>
+ #include <sstream>