aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2016-01-15 20:12:55 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2016-01-15 20:12:55 +0000
commit4c684c538696faa3932c617a2596167884989018 (patch)
treec1539d91c136ee0b2734270f6c46d6fde8ff1b5b /x11
parent6656cb7bf512e6f986b19ab553aa8d4503f8bd6c (diff)
downloadports-4c684c538696faa3932c617a2596167884989018.tar.gz
ports-4c684c538696faa3932c617a2596167884989018.zip
On BSD, switching off ICANON does not disable LNEXT (^V) processing.
We explicitly need to unset IEXTEN.
Notes
Notes: svn path=/head/; revision=406190
Diffstat (limited to 'x11')
-rw-r--r--x11/luit/Makefile1
-rw-r--r--x11/luit/files/patch-sys.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/x11/luit/Makefile b/x11/luit/Makefile
index bfa31c298f20..c0aa99264659 100644
--- a/x11/luit/Makefile
+++ b/x11/luit/Makefile
@@ -2,6 +2,7 @@
PORTNAME= luit
PORTVERSION= 1.1.1
+PORTREVISION= 1
CATEGORIES= x11
MAINTAINER= x11@FreeBSD.org
diff --git a/x11/luit/files/patch-sys.c b/x11/luit/files/patch-sys.c
new file mode 100644
index 000000000000..ed1d2541fb80
--- /dev/null
+++ b/x11/luit/files/patch-sys.c
@@ -0,0 +1,11 @@
+--- sys.c.orig 2012-03-23 04:23:07 UTC
++++ sys.c
+@@ -256,7 +256,7 @@ setRawTermios(void)
+ rc = tcgetattr(0, &tio);
+ if (rc < 0)
+ return rc;
+- tio.c_lflag &= (unsigned) ~(ECHO | ICANON | ISIG);
++ tio.c_lflag &= (unsigned) ~(ECHO | ICANON | IEXTEN | ISIG);
+ tio.c_iflag &= (unsigned) ~(ICRNL | IXOFF | IXON | ISTRIP);
+ #ifdef ONLCR
+ tio.c_oflag &= (unsigned) ~ONLCR;