aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-19 14:50:52 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-19 14:50:52 +0000
commit67971bd0fb8a440f973d12606b0f496ba216d7df (patch)
tree72fd93ae39b43490b34dc8479465e07b453d126e /x11
parentf13c234d6c664c916b5c0d0e6f089d8ef0c93d55 (diff)
downloadports-67971bd0fb8a440f973d12606b0f496ba216d7df.tar.gz
ports-67971bd0fb8a440f973d12606b0f496ba216d7df.zip
Improve shebangfix framework
- Support multiple values in *_OLD_CMD, i.e. we can now fix both "/usr/bin/python" and "/usr/bin/env python" at the same time - Default *_OLD_CMD values are now always appended, so you don't need to specify them in individual ports - Add lua support (depends on USES=lua) - Add more default values, such as "/usr/bin/env foo" for python, perl, bash, ruby and lua - Shebangfix now matches whole words, e.g. we will no longer (erroneously) replace "/usr/bin/perl5.005" with "${perl_CMD}5.005" (but "/usr/bin/perl -tt" is still (correctly) replaced with "${perl_CMD} -tt") Note that *_OLD_CMD items containing spaces must now be quoted (e.g. perl_OLD_CMD=/bin/perl /usr/bin/perl "/usr/bin/env perl") Update shebangfix usage according to new rules in many ports: - Remove *_OLD_CMD for patterns now replaced by default - Quote custom *_OLD_CMD which contain spaces Fix shebangfix usage in many ports (irrelevant to infrastructure change): - Remove redundant SHEBANG_LANG (no need to duplicate default langs) - Remove redundant *_CMD (such as python_CMD=${LOCALBASE}/bin/python${PYTHON_VER} when USES=python is present) - Never use *_OLD_CMD in REINPLACE_CMD matchers, these should always look for exact string Approved by: portmgr (bapt) Differential Revision: D3756
Notes
Notes: svn path=/head/; revision=399684
Diffstat (limited to 'x11')
-rw-r--r--x11/eaglemode/Makefile2
-rw-r--r--x11/scripts/Makefile2
-rw-r--r--x11/wbarconf/Makefile3
3 files changed, 3 insertions, 4 deletions
diff --git a/x11/eaglemode/Makefile b/x11/eaglemode/Makefile
index 3bbf096fd19b..51b18108f003 100644
--- a/x11/eaglemode/Makefile
+++ b/x11/eaglemode/Makefile
@@ -59,7 +59,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|gcc|${CC}|; s|"-O2"|"${CFLAGS}"|' \
${WRKSRC}/makers/unicc/plugins/unicc_gnu.pm
@${FIND} ${WRKSRC} -name "*.pl" | ${XARGS} \
- ${REINPLACE_CMD} -e '1s|${perl_OLD_CMD}|${perl_CMD}|'
+ ${REINPLACE_CMD} -e '1s|/usr/bin/perl|${perl_CMD}|'
post-patch-XINE-off:
@${RM} -f ${WRKSRC}/makers/emAv.maker.pm
diff --git a/x11/scripts/Makefile b/x11/scripts/Makefile
index 96d6dcb403a9..8a140fc3adf1 100644
--- a/x11/scripts/Makefile
+++ b/x11/scripts/Makefile
@@ -15,6 +15,6 @@ USE_XORG= x11
USES= shebangfix
post-patch:
- @${REINPLACE_CMD} -e 's|XCOMM!${ksh_OLD_CMD}|XCOMM!${ksh_CMD}|' ${WRKSRC}/xauth_switch_to_sun-des-1.cpp
+ @${REINPLACE_CMD} -e 's|XCOMM!/bin/ksh|XCOMM!${ksh_CMD}|' ${WRKSRC}/xauth_switch_to_sun-des-1.cpp
.include <bsd.port.mk>
diff --git a/x11/wbarconf/Makefile b/x11/wbarconf/Makefile
index f5651a0162af..bc6d52870749 100644
--- a/x11/wbarconf/Makefile
+++ b/x11/wbarconf/Makefile
@@ -16,9 +16,8 @@ RUN_DEPENDS= wbar:${PORTSDIR}/x11/wbar
USE_GNOME= pygobject pygtk2 gtk20
USES= gettext desktop-file-utils python shebangfix
-SHEBANG_LANG= python
SHEBANG_FILES= ${WRKSRC}/wbarconf
-python_OLD_CMD= /usr/bin/env python2
+python_OLD_CMD= "/usr/bin/env python2"
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
PORTDOCS= README COPYING