aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-29 21:03:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-29 21:03:12 +0000
commit794a09d3901735203939f2ff3fb2afa7f9c17a4c (patch)
tree83e8539549ba8414686210dc862d95ac4d951949 /x11
parentc5cf5fc4902fb8a6e7bb86a9e58bf3393106c6b5 (diff)
downloadports-794a09d3901735203939f2ff3fb2afa7f9c17a4c.tar.gz
ports-794a09d3901735203939f2ff3fb2afa7f9c17a4c.zip
Xmobar is a minimalistic text based status bar. Inspired by the Ion3 status
bar, it supports similar features, like dynamic color management, output templates, and extensibility through plugins. WWW: http://code.haskell.org/~arossato/xmobar PR: ports/129191 Submitted by: Samy Al Bahra <sbahra at kerneled.org>
Notes
Notes: svn path=/head/; revision=223584
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/hs-xmobar/Makefile38
-rw-r--r--x11/hs-xmobar/distinfo3
-rw-r--r--x11/hs-xmobar/pkg-descr5
-rw-r--r--x11/hs-xmobar/pkg-plist3
-rw-r--r--x11/xmobar/Makefile38
-rw-r--r--x11/xmobar/distinfo3
-rw-r--r--x11/xmobar/pkg-descr5
-rw-r--r--x11/xmobar/pkg-plist3
9 files changed, 99 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index bc99d49e15a4..4360419574eb 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -407,6 +407,7 @@
SUBDIR += xmascot
SUBDIR += xmessage
SUBDIR += xmh
+ SUBDIR += xmobar
SUBDIR += xmodmap
SUBDIR += xmold
SUBDIR += xmon
diff --git a/x11/hs-xmobar/Makefile b/x11/hs-xmobar/Makefile
new file mode 100644
index 000000000000..20c751b44229
--- /dev/null
+++ b/x11/hs-xmobar/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: xmobar
+# Date created: November 7, 2008
+# Whom: Samy Al Bahra <sbahra@kerneled.org>
+#
+# $FreeBSD$
+
+PORTNAME= xmobar
+PORTVERSION= 0.9
+CATEGORIES= x11 haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/xmobar/${PORTVERSION}/ \
+ http://carte.kerneled.org/mirror/
+
+MAINTAINER= sbahra@kerneled.org
+COMMENT= Xmobar is a minimalistic text based status bar
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
+ hs-x11-ghc>=1.4.1:${PORTSDIR}/x11/hs-x11-ghc
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+USE_XORG= x11
+
+CABAL= ${LOCALBASE}/bin/runghc Setup.lhs
+GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION="${GHC_VERSION}" \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${SUBDIR}
+
+do-configure:
+ cd ${WRKSRC} && ${CABAL} configure --prefix=${PREFIX} --ghc
+
+do-build:
+ cd ${WRKSRC} && ${CABAL} build
+
+do-install:
+ cd ${WRKSRC} && ${CABAL} install
+
+.include <bsd.port.mk>
diff --git a/x11/hs-xmobar/distinfo b/x11/hs-xmobar/distinfo
new file mode 100644
index 000000000000..5b933e1a4f21
--- /dev/null
+++ b/x11/hs-xmobar/distinfo
@@ -0,0 +1,3 @@
+MD5 (xmobar-0.9.tar.gz) = b9cd54d4a7aee0067cfb8043ba9ab5cb
+SHA256 (xmobar-0.9.tar.gz) = 1e52e9ec669504ae66ae98fbd5291a7034e28723bf93abe29345d5567aefeba9
+SIZE (xmobar-0.9.tar.gz) = 37172
diff --git a/x11/hs-xmobar/pkg-descr b/x11/hs-xmobar/pkg-descr
new file mode 100644
index 000000000000..7bbb2995df55
--- /dev/null
+++ b/x11/hs-xmobar/pkg-descr
@@ -0,0 +1,5 @@
+Xmobar is a minimalistic text based status bar. Inspired by the Ion3 status
+bar, it supports similar features, like dynamic color management, output
+templates, and extensibility through plugins.
+
+WWW: http://code.haskell.org/~arossato/xmobar
diff --git a/x11/hs-xmobar/pkg-plist b/x11/hs-xmobar/pkg-plist
new file mode 100644
index 000000000000..b304c5a56605
--- /dev/null
+++ b/x11/hs-xmobar/pkg-plist
@@ -0,0 +1,3 @@
+bin/xmobar
+share/doc/xmobar-%%PORTVERSION%%/LICENSE
+@dirrm share/doc/xmobar-%%PORTVERSION%%
diff --git a/x11/xmobar/Makefile b/x11/xmobar/Makefile
new file mode 100644
index 000000000000..20c751b44229
--- /dev/null
+++ b/x11/xmobar/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: xmobar
+# Date created: November 7, 2008
+# Whom: Samy Al Bahra <sbahra@kerneled.org>
+#
+# $FreeBSD$
+
+PORTNAME= xmobar
+PORTVERSION= 0.9
+CATEGORIES= x11 haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/xmobar/${PORTVERSION}/ \
+ http://carte.kerneled.org/mirror/
+
+MAINTAINER= sbahra@kerneled.org
+COMMENT= Xmobar is a minimalistic text based status bar
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
+ hs-x11-ghc>=1.4.1:${PORTSDIR}/x11/hs-x11-ghc
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+USE_XORG= x11
+
+CABAL= ${LOCALBASE}/bin/runghc Setup.lhs
+GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION="${GHC_VERSION}" \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${SUBDIR}
+
+do-configure:
+ cd ${WRKSRC} && ${CABAL} configure --prefix=${PREFIX} --ghc
+
+do-build:
+ cd ${WRKSRC} && ${CABAL} build
+
+do-install:
+ cd ${WRKSRC} && ${CABAL} install
+
+.include <bsd.port.mk>
diff --git a/x11/xmobar/distinfo b/x11/xmobar/distinfo
new file mode 100644
index 000000000000..5b933e1a4f21
--- /dev/null
+++ b/x11/xmobar/distinfo
@@ -0,0 +1,3 @@
+MD5 (xmobar-0.9.tar.gz) = b9cd54d4a7aee0067cfb8043ba9ab5cb
+SHA256 (xmobar-0.9.tar.gz) = 1e52e9ec669504ae66ae98fbd5291a7034e28723bf93abe29345d5567aefeba9
+SIZE (xmobar-0.9.tar.gz) = 37172
diff --git a/x11/xmobar/pkg-descr b/x11/xmobar/pkg-descr
new file mode 100644
index 000000000000..7bbb2995df55
--- /dev/null
+++ b/x11/xmobar/pkg-descr
@@ -0,0 +1,5 @@
+Xmobar is a minimalistic text based status bar. Inspired by the Ion3 status
+bar, it supports similar features, like dynamic color management, output
+templates, and extensibility through plugins.
+
+WWW: http://code.haskell.org/~arossato/xmobar
diff --git a/x11/xmobar/pkg-plist b/x11/xmobar/pkg-plist
new file mode 100644
index 000000000000..b304c5a56605
--- /dev/null
+++ b/x11/xmobar/pkg-plist
@@ -0,0 +1,3 @@
+bin/xmobar
+share/doc/xmobar-%%PORTVERSION%%/LICENSE
+@dirrm share/doc/xmobar-%%PORTVERSION%%