aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2019-06-20 19:19:25 +0000
committerChris Rees <crees@FreeBSD.org>2019-06-20 19:19:25 +0000
commit81b5f58607d98075dea356ad4c4717faea63e11c (patch)
treeeb94ea2e43194a37830609cf604c830a90d598bc /x11
parentd84019894634bc92066dd9acf8f50efd6c081c21 (diff)
downloadports-81b5f58607d98075dea356ad4c4717faea63e11c.tar.gz
ports-81b5f58607d98075dea356ad4c4717faea63e11c.zip
x11/cde: Add dtlogin rc script
Remove double ksh dependency Pet portlint Mark BROKEN on head: cc -o dthelpview -O2 -fno-strict-aliasing -Wno-write-strings -Wno-unused-result -Wno-deprecated-register -pipe -L../../../exports/lib -L/usr/local/lib -L/usr/local/lib Main.o ManPage.o Util.o version.o -lDtHelp -lDtSvc -ltt -lXm -lXt -lSM -lICE -lXext -lX11 -L/usr/local/dt/lib -L/usr/local/lib -L/usr/local/lib -liconv -lm -lstdc++ ld: error: ../../../exports/lib/libDtHelp.so: undefined reference to jpeg_CreateDecompress [...]
Notes
Notes: svn path=/head/; revision=504733
Diffstat (limited to 'x11')
-rw-r--r--x11/cde/Makefile11
-rw-r--r--x11/cde/files/dtcms.in4
-rw-r--r--x11/cde/files/dtlogin.in26
-rw-r--r--x11/cde/files/dtspc.in5
4 files changed, 38 insertions, 8 deletions
diff --git a/x11/cde/Makefile b/x11/cde/Makefile
index c237555c563f..5a72d190b0ea 100644
--- a/x11/cde/Makefile
+++ b/x11/cde/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cde
DISTVERSION= 2.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11
MASTER_SITES= SF/cdesktopenv/src/
@@ -22,7 +22,6 @@ BUILD_DEPENDS= ksh93:shells/ksh93 \
${LOCALBASE}/libdata/pkgconfig/freetype2.pc:print/freetype2
RUN_DEPENDS= ${LOCALBASE}/bin/fc-cache:x11-fonts/fontconfig \
${LOCALBASE}/libdata/pkgconfig/freetype2.pc:print/freetype2 \
- ksh93:shells/ksh93 \
xrdb:x11/xrdb \
xset:x11/xset
@@ -33,7 +32,7 @@ SHEBANG_FILES= programs/dtdocbook/sgmls/sgmls.pl \
programs/dtdocbook/doc2sdl/docbook.tcl \
programs/dtdocbook/doc2sdl/dtdocbook
USE_LDCONFIG= ${PREFIX}/dt/lib
-USE_RC_SUBR= dtcms dtspc
+USE_RC_SUBR= dtcms dtspc dtlogin
USE_XORG= ice sm x11 xau xdmcp xext xinerama xmu xp xscrnsaver xt
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
@@ -42,6 +41,12 @@ MAKE_ARGS+= PERL=${PERL}
MAKE_JOBS_UNSAFE=yes
SUB_FILES= pkg-message
+.include <bsd.port.options.mk>
+
+.if ${OSVERSION} >= 1300018
+BROKEN= Fails to build: ld: error: ../../../exports/lib/libDtHelp.so: undefined reference to jpeg_CreateDecompress
+.endif
+
post-patch:
@if [ -f /usr/include/iconv.h ]; then \
${REINPLACE_CMD} -e 's!^[[:space:]]*const char .ip = (const char .) .bp!char *ip = *bp!' \
diff --git a/x11/cde/files/dtcms.in b/x11/cde/files/dtcms.in
index 9cfd44dce07c..d855499bb461 100644
--- a/x11/cde/files/dtcms.in
+++ b/x11/cde/files/dtcms.in
@@ -15,14 +15,14 @@
name=dtcms
rcvar=dtcms_enable
desc="CDE calendar manager service daemon"
-start_precmd="force_depend rpcbind || exit 1"
load_rc_config $name
: ${dtcms_enable:=NO}
command=/usr/sbin/daemon
-pidfile=/var/run/dtcms.pid
command_args="-P $pidfile %%PREFIX%%/dt/bin/rpc.cmsd"
+start_precmd="force_depend rpcbind || exit 1"
+pidfile=/var/run/dtcms.pid
run_rc_command $1
diff --git a/x11/cde/files/dtlogin.in b/x11/cde/files/dtlogin.in
new file mode 100644
index 000000000000..fdbe293865dc
--- /dev/null
+++ b/x11/cde/files/dtlogin.in
@@ -0,0 +1,26 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: dtlogin
+# REQUIRE: LOGIN dbus hald dtspc
+# KEYWORD: shutdown
+#
+# Add the following line to /etc/rc.conf to enable slim:
+# dtlogin_enable="YES"
+#
+
+. /etc/rc.subr
+
+name=dtlogin
+rcvar=dtlogin_enable
+desc="Display manager for CDE"
+
+load_rc_config dtlogin
+
+: ${dtlogin_enable:=NO}
+
+command=%%PREFIX%%/dt/bin/dtlogin
+command_args=-daemon
+
+run_rc_command $1
diff --git a/x11/cde/files/dtspc.in b/x11/cde/files/dtspc.in
index 1aa56c34834c..a4b770342631 100644
--- a/x11/cde/files/dtspc.in
+++ b/x11/cde/files/dtspc.in
@@ -15,16 +15,15 @@
name=dtspc
rcvar=dtspc_enable
desc="CDE Subprocess Control Service"
-start_precmd="force_depend rpcbind || exit 1"
load_rc_config $name
: ${dtspc_enable:=NO}
command=/usr/sbin/daemon
-pidfile=/var/run/dtspc.pid
command_args="-P $pidfile %%PREFIX%%/dt/bin/dtspcd"
-start_precmd="ln -sf %%PREFIX%%/dt /usr/dt && ln -sf %%PREFIX%%/etc/dt /etc/dt"
+start_precmd="force_depend rpcbind || exit 1 && ln -sf %%PREFIX%%/dt /usr/dt && ln -sf %%PREFIX%%/etc/dt /etc/dt"
stop_postcmd="[ -L /usr/dt -a -L /etc/dt ] && rm /usr/dt /etc/dt"
+pidfile=/var/run/dtspc.pid
run_rc_command $1