aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2023-12-03 09:17:13 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2023-12-03 09:30:21 +0000
commit886e9bf1911974c90f2a43d5b23a07f06fa73b1a (patch)
treeb78d82a5031cc427f5f69d58ebfc2a470fb9bdfc /x11
parent34e85ff599ddb057d4d567f006d2a86da58a2bf3 (diff)
downloadports-886e9bf1911974c90f2a43d5b23a07f06fa73b1a.tar.gz
ports-886e9bf1911974c90f2a43d5b23a07f06fa73b1a.zip
KDE: complete dependency list in plasma6-ports
Reported by: poudriere
Diffstat (limited to 'x11')
-rw-r--r--x11/plasma6-kgamma/Makefile6
-rw-r--r--x11/plasma6-kglobalacceld/Makefile2
-rw-r--r--x11/plasma6-kscreen/Makefile14
-rw-r--r--x11/plasma6-libplasma/Makefile16
-rw-r--r--x11/plasma6-plasma-activities/Makefile3
-rw-r--r--x11/plasma6-plasma-desktop/Makefile7
-rw-r--r--x11/plasma6-plasma-integration/Makefile13
-rw-r--r--x11/plasma6-plasma-workspace/Makefile14
8 files changed, 49 insertions, 26 deletions
diff --git a/x11/plasma6-kgamma/Makefile b/x11/plasma6-kgamma/Makefile
index d5aa50ebd7f2..7baedbfcca35 100644
--- a/x11/plasma6-kgamma/Makefile
+++ b/x11/plasma6-kgamma/Makefile
@@ -5,8 +5,10 @@ CATEGORIES= x11 kde kde-plasma
MAINTAINER= kde@FreeBSD.org
COMMENT= Adjust gamma settings
-USES= cmake gettext kde:6 qt:6 tar:xz xorg
-USE_KDE= config configwidgets doctools i18n kcmutils \
+USES= cmake gettext gl kde:6 qt:6 tar:xz xorg
+USE_GL= gl opengl
+USE_KDE= colorscheme config configwidgets coreaddons doctools i18n \
+ kcmutils kdeclarative widgetsaddons \
ecm:build
USE_QT= base
USE_XORG= ice sm x11 xext xxf86vm
diff --git a/x11/plasma6-kglobalacceld/Makefile b/x11/plasma6-kglobalacceld/Makefile
index a6b2d8aaf8c7..3bd02d1657b3 100644
--- a/x11/plasma6-kglobalacceld/Makefile
+++ b/x11/plasma6-kglobalacceld/Makefile
@@ -11,7 +11,7 @@ LIB_DEPENDS= libxcb-keysyms.so:x11/xcb-util-keysyms \
USES= cmake gl kde:6 qt:6 tar:xz xorg
USE_GL= gl opengl
-USE_KDE= config coreaddons crash dbusaddons globalaccel kio \
+USE_KDE= config coreaddons crash dbusaddons globalaccel jobwidgets kio \
notifications service windowsystem \
ecm:build
USE_QT= base
diff --git a/x11/plasma6-kscreen/Makefile b/x11/plasma6-kscreen/Makefile
index 069af9492a40..e2c6aee31e00 100644
--- a/x11/plasma6-kscreen/Makefile
+++ b/x11/plasma6-kscreen/Makefile
@@ -5,10 +5,16 @@ CATEGORIES= x11 kde kde-plasma
COMMENT= KDE screen management software
MAINTAINER= kde@FreeBSD.org
-USES= cmake gettext kde:6 qt:6 tar:xz
-USE_KDE= config dbusaddons globalaccel i18n iconthemes kcmutils \
- layer-shell-qt libkscreen libplasma svg xmlgui \
+LIB_DEPENDS= libxcb-util.so:x11/xcb-util \
+ libxkbcommon.so:x11/libxkbcommon
+
+USES= cmake gettext kde:6 qt:6 tar:xz gl xorg
+USE_KDE= colorscheme config configwidgets coreaddons dbusaddons \
+ globalaccel i18n iconthemes kcmutils layer-shell-qt libkscreen \
+ libplasma svg widgetsaddons windowsystem xmlgui \
ecm:build
-USE_QT= base sensors
+USE_GL= gl opengl
+USE_QT= base declarative sensors
+USE_XORG= x11 xcb xext xi
.include <bsd.port.mk>
diff --git a/x11/plasma6-libplasma/Makefile b/x11/plasma6-libplasma/Makefile
index f58221e48d83..02529bff69be 100644
--- a/x11/plasma6-libplasma/Makefile
+++ b/x11/plasma6-libplasma/Makefile
@@ -6,12 +6,18 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Shared libraries for Plasma Desktop
BUILD_DEPENDS= wayland-protocols>=0:graphics/wayland-protocols
+LIB_DEPENDS= libwayland-client.so:graphics/wayland \
+ libxkbcommon.so:x11/libxkbcommon
-USES= cmake gettext kde:6 pkgconfig qt:6 tar:xz
-USE_KDE= activities archive config configwidgets coreaddons globalaccel \
- guiaddons i18n iconthemes kcmutils kio kirigami2 notifications \
- package plasma-wayland-protocols svg windowsystem \
+USES= cmake gettext gl kde:6 pkgconfig qt:6 tar:xz xorg
+USE_XORG= ice sm x11 xcb xext
+USE_GL= egl gl opengl
+USE_KDE= activities archive colorscheme completion config configwidgets \
+ coreaddons globalaccel guiaddons i18n iconthemes jobwidgets \
+ kcmutils kio kirigami2 notifications package \
+ plasma-wayland-protocols service solid svg widgetsaddons \
+ windowsystem \
ecm:build
-USE_QT= base declarative svg
+USE_QT= base declarative svg wayland
.include <bsd.port.mk>
diff --git a/x11/plasma6-plasma-activities/Makefile b/x11/plasma6-plasma-activities/Makefile
index 7b1f8b962853..160ca28ed107 100644
--- a/x11/plasma6-plasma-activities/Makefile
+++ b/x11/plasma6-plasma-activities/Makefile
@@ -7,9 +7,10 @@ MAINTAINER= kde@FreeBSD.org
BUILD_DEPENDS= boost-libs>0:devel/boost-libs
-USES= cmake compiler:c++11-lib gettext kde:6 pathfix qt:6 tar:xz
+USES= cmake compiler:c++11-lib gettext gl kde:6 pathfix qt:6 tar:xz
USE_KDE= config coreaddons \
ecm:build
USE_QT= base declarative
+USE_GL= gl opengl
.include <bsd.port.mk>
diff --git a/x11/plasma6-plasma-desktop/Makefile b/x11/plasma6-plasma-desktop/Makefile
index 583d3db8d470..f3d8e5f60c3d 100644
--- a/x11/plasma6-plasma-desktop/Makefile
+++ b/x11/plasma6-plasma-desktop/Makefile
@@ -10,6 +10,7 @@ BUILD_DEPENDS= wayland-protocols>=0:graphics/wayland-protocols \
xf86-input-libinput>0:x11-drivers/xf86-input-libinput \
xf86-input-synaptics>0:x11-drivers/xf86-input-synaptics
LIB_DEPENDS= libcanberra.so:audio/libcanberra \
+ libicuuc.so:devel/icu \
liboauth2plugin.so:sysutils/signon-plugin-oauth2 \
libwayland-client.so:graphics/wayland \
libxcb-util.so:x11/xcb-util \
@@ -27,9 +28,9 @@ USE_KDE= activities activities-stats attica5 auth baloo5 bookmarks \
codecs colorscheme completion config configwidgets coreaddons \
crash dbusaddons doctools filemetadata globalaccel guiaddons \
i18n iconthemes itemmodels itemviews jobwidgets kcmutils kio \
- libksysguard newstuff notifications notifyconfig package \
- plasma-workspace plasma5support runner service solid sonnet \
- widgetsaddons windowsystem xmlgui \
+ libksysguard libplasma newstuff notifications notifyconfig \
+ package plasma-workspace plasma5support runner service solid \
+ sonnet svg widgetsaddons windowsystem xmlgui \
ecm:build \
kirigami-addons:run kirigami2:run kpipewire:run \
qqc2-desktop-style:run
diff --git a/x11/plasma6-plasma-integration/Makefile b/x11/plasma6-plasma-integration/Makefile
index 52245ff75881..72e395633e16 100644
--- a/x11/plasma6-plasma-integration/Makefile
+++ b/x11/plasma6-plasma-integration/Makefile
@@ -5,14 +5,21 @@ CATEGORIES= x11 kde kde-plasma
COMMENT= Qt Platform Theme integration plugins for the Plasma workspaces
MAINTAINER= kde@FreeBSD.org
+LIB_DEPENDS= libwayland-client.so:graphics/wayland \
+ libxkbcommon.so:x11/libxkbcommon
RUN_DEPENDS= hack-font>0:x11-fonts/hack-font \
noto-basic>0:x11-fonts/noto-basic \
noto-emoji>0:x11-fonts/noto-emoji
-USES= cmake gettext kde:6 qt:6 shebangfix tar:xz
-USE_KDE= breeze xdg-desktop-portal-kde \
+USES= cmake gettext gl kde:6 qt:6 shebangfix tar:xz xorg
+USE_KDE= bookmarks breeze colorscheme completion config configwidgets \
+ coreaddons guiaddons i18n iconthemes itemviews jobwidgets kio \
+ notifications service solid statusnotifieritem widgetsaddons \
+ windowsystem xdg-desktop-portal-kde xmlgui \
ecm:build plasma-wayland-protocols:build
-USE_QT= base
+USE_GL= gl opengl
+USE_XORG= x11 xcb xcursor
+USE_QT= base declarative wayland
CMAKE_ON= BUILD_QT6
CMAKE_OFF= BUILD_QT5
diff --git a/x11/plasma6-plasma-workspace/Makefile b/x11/plasma6-plasma-workspace/Makefile
index d4de60458cec..b92d3f17947c 100644
--- a/x11/plasma6-plasma-workspace/Makefile
+++ b/x11/plasma6-plasma-workspace/Makefile
@@ -10,14 +10,14 @@ LIB_DEPENDS= libcanberra.so:audio/libcanberra \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libicui18n.so:devel/icu \
+ libKExiv2Qt6.so:graphics/libkexiv2-devel \
libpipewire-0.3.so:multimedia/pipewire \
libqalculate.so:math/libqalculate \
libudev.so:devel/libudev-devd \
libwayland-client.so:graphics/wayland \
libxcb-image.so:x11/xcb-util-image \
libxcb-util.so:x11/xcb-util \
- libxkbcommon.so:x11/libxkbcommon \
- libKExiv2Qt6.so:graphics/libkexiv2-devel
+ libxkbcommon.so:x11/libxkbcommon
RUN_DEPENDS= ${LOCALBASE}/bin/genv:sysutils/coreutils
@@ -30,11 +30,11 @@ USE_KDE= activities activities-stats archive attica5 auth baloo5 \
guiaddons holidays i18n iconthemes idletime itemmodels \
itemviews jobwidgets kcmutils kdeclarative kio kirigami-addons \
kirigami2 kpipewire kquickcharts kscreenlocker kwin \
- layer-shell-qt libkscreen libksysguard newstuff notifications \
- notifyconfig package parts plasma5support prison runner \
- service solid sonnet statusnotifieritem svg syntaxhighlighting \
- texteditor textwidgets unitconversion userfeedback wallet \
- widgetsaddons windowsystem xmlgui \
+ layer-shell-qt libkscreen libksysguard libplasma newstuff \
+ notifications notifyconfig package parts plasma5support prison \
+ runner service solid sonnet statusnotifieritem svg \
+ syntaxhighlighting texteditor textwidgets unitconversion \
+ userfeedback wallet wayland widgetsaddons windowsystem xmlgui \
ecm:build plasma-wayland-protocols:build
USE_QT= 5compat base declarative phonon4 svg wayland
USE_XORG= ice sm x11 xau xcb xcursor xext xfixes xft xi xrender xtst