aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-31 16:01:01 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-02-01 02:42:57 +0000
commit8a7fe231329504803c7068da657f659ce6db6680 (patch)
tree5705d28fcbe4ccd95422c6fd19669719391c021e /x11
parentbea0c0bc1625361668a9b1e5296d431ff26c9c5e (diff)
downloadports-8a7fe231329504803c7068da657f659ce6db6680.tar.gz
ports-8a7fe231329504803c7068da657f659ce6db6680.zip
x11/py-pynput: New port: Send virtual input commands
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/py-pynput/Makefile26
-rw-r--r--x11/py-pynput/distinfo3
-rw-r--r--x11/py-pynput/files/patch-setup.py13
-rw-r--r--x11/py-pynput/pkg-descr3
5 files changed, 46 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 7e81497365b7..72debe1a0ad2 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -308,6 +308,7 @@
SUBDIR += py-caffeine-ng
SUBDIR += py-i3-quickterm
SUBDIR += py-i3ipc
+ SUBDIR += py-pynput
SUBDIR += py-pyscreenshot
SUBDIR += py-python-xapp
SUBDIR += py-pyvirtualdisplay
diff --git a/x11/py-pynput/Makefile b/x11/py-pynput/Makefile
new file mode 100644
index 000000000000..ded00786224e
--- /dev/null
+++ b/x11/py-pynput/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= pynput
+DISTVERSION= 1.7.6
+CATEGORIES= x11
+MASTER_SITES= PYPI # no tests on PYPI, but GitHub tarball doesn't bui;d
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Send virtual input commands
+WWW= https://github.com/moses-palmer/pynput
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING.LGPL
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=1.3.1:textproc/py-sphinx@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-xlib>0:x11-toolkits/py-python-xlib@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+TEST_WRKSRC= ${WRKSRC}/tests
+
+.include <bsd.port.mk>
diff --git a/x11/py-pynput/distinfo b/x11/py-pynput/distinfo
new file mode 100644
index 000000000000..28f824a43120
--- /dev/null
+++ b/x11/py-pynput/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1675195033
+SHA256 (pynput-1.7.6.tar.gz) = 3a5726546da54116b687785d38b1db56997ce1d28e53e8d22fc656d8b92e533c
+SIZE (pynput-1.7.6.tar.gz) = 79501
diff --git a/x11/py-pynput/files/patch-setup.py b/x11/py-pynput/files/patch-setup.py
new file mode 100644
index 000000000000..e87d2cf77536
--- /dev/null
+++ b/x11/py-pynput/files/patch-setup.py
@@ -0,0 +1,13 @@
+- setuptools-lint isn't really needed during build
+
+--- setup.py.orig 2023-01-31 20:21:18 UTC
++++ setup.py
+@@ -23,7 +23,7 @@ RUNTIME_PACKAGES = [
+
+ #: Additional requirements used during setup
+ SETUP_PACKAGES = [
+- 'setuptools-lint >=0.5',
++ #'setuptools-lint >=0.5',
+ 'sphinx >=1.3.1']
+
+ #: Packages requires for different environments
diff --git a/x11/py-pynput/pkg-descr b/x11/py-pynput/pkg-descr
new file mode 100644
index 000000000000..c70387df548c
--- /dev/null
+++ b/x11/py-pynput/pkg-descr
@@ -0,0 +1,3 @@
+pynput is the library allows you to control and monitor input devices.
+
+Currently, mouse and keyboard input and monitoring are supported.