aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-01-13 20:13:20 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-01-13 20:13:20 +0000
commitbea55972c51c57cd08625d30061ae4c8587631f0 (patch)
treea722815a274e5cd257134cd2fcafdddfc9cac8e1 /x11
parent65db53357802bac64fc74f62a380d40a8202d65b (diff)
downloadports-bea55972c51c57cd08625d30061ae4c8587631f0.tar.gz
ports-bea55972c51c57cd08625d30061ae4c8587631f0.zip
Add tools for taking screenshots on x11-wm/sway
Notes
Notes: svn path=/head/; revision=490208
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile2
-rw-r--r--x11/grim/Makefile33
-rw-r--r--x11/grim/distinfo3
-rw-r--r--x11/grim/pkg-descr3
-rw-r--r--x11/slurp/Makefile32
-rw-r--r--x11/slurp/distinfo3
-rw-r--r--x11/slurp/pkg-descr4
7 files changed, 80 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 31b9663c775a..3dcc46cc5d16 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -85,6 +85,7 @@
SUBDIR += gnustep-app
SUBDIR += gpctool
SUBDIR += grabc
+ SUBDIR += grim
SUBDIR += gromit
SUBDIR += gskrab
SUBDIR += gstreamer1-plugins-x
@@ -303,6 +304,7 @@
SUBDIR += slim
SUBDIR += slock
SUBDIR += slop
+ SUBDIR += slurp
SUBDIR += smproxy
SUBDIR += sselp
SUBDIR += stalonetray
diff --git a/x11/grim/Makefile b/x11/grim/Makefile
new file mode 100644
index 000000000000..60a1ba7b866b
--- /dev/null
+++ b/x11/grim/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= grim
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0
+CATEGORIES= x11
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Grab images from a Wayland compositor
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= wayland-protocols>=1.14:graphics/wayland-protocols
+LIB_DEPENDS= libwayland-client.so:graphics/wayland
+
+USES= compiler:c11 gnome jpeg meson pkgconfig
+USE_GITHUB= yes
+USE_GNOME= cairo
+GH_ACCOUNT= emersion
+MESON_ARGS= -Dwerror=false # https://github.com/emersion/grim/issues/37
+PLIST_FILES= bin/${PORTNAME}
+
+OPTIONS_DEFINE= MANPAGES
+OPTIONS_DEFAULT=MANPAGES
+
+MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
+MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz
+
+post-patch-MANPAGES-off:
+ @${REINPLACE_CMD} -i '' "s/'scdoc/&-disabled/" ${WRKSRC}/meson.build
+
+.include <bsd.port.mk>
diff --git a/x11/grim/distinfo b/x11/grim/distinfo
new file mode 100644
index 000000000000..24af275e1f01
--- /dev/null
+++ b/x11/grim/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1542872698
+SHA256 (emersion-grim-v1.0_GH0.tar.gz) = 0ed45902920acd400ec5c7acd01b4f0303663f64552bf2bb06fd86ebb12d7376
+SIZE (emersion-grim-v1.0_GH0.tar.gz) = 13103
diff --git a/x11/grim/pkg-descr b/x11/grim/pkg-descr
new file mode 100644
index 000000000000..4929cf0d786a
--- /dev/null
+++ b/x11/grim/pkg-descr
@@ -0,0 +1,3 @@
+Grab images from a Wayland compositor. Works great with slurp and sway >= 1.0.
+
+WWW: https://wayland.emersion.fr/grim/
diff --git a/x11/slurp/Makefile b/x11/slurp/Makefile
new file mode 100644
index 000000000000..6f382e741db6
--- /dev/null
+++ b/x11/slurp/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= slurp
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0
+CATEGORIES= x11
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Select a region in a Wayland compositor
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= wayland-protocols>=1.14:graphics/wayland-protocols
+LIB_DEPENDS= libwayland-client.so:graphics/wayland
+
+USES= compiler:c11 gnome meson pkgconfig
+USE_GITHUB= yes
+USE_GNOME= cairo
+GH_ACCOUNT= emersion
+PLIST_FILES= bin/${PORTNAME}
+
+OPTIONS_DEFINE= MANPAGES
+OPTIONS_DEFAULT=MANPAGES
+
+MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
+MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz
+
+post-patch-MANPAGES-off:
+ @${REINPLACE_CMD} -i '' "s/'scdoc/&-disabled/" ${WRKSRC}/meson.build
+
+.include <bsd.port.mk>
diff --git a/x11/slurp/distinfo b/x11/slurp/distinfo
new file mode 100644
index 000000000000..10701e1f9ba8
--- /dev/null
+++ b/x11/slurp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1542873030
+SHA256 (emersion-slurp-v1.0_GH0.tar.gz) = 41f3e98fa2729ae91d9f45e4d5e08023777b2cf3839e0cc0a7b2a5c53ebc4fd4
+SIZE (emersion-slurp-v1.0_GH0.tar.gz) = 13416
diff --git a/x11/slurp/pkg-descr b/x11/slurp/pkg-descr
new file mode 100644
index 000000000000..92fef76eff87
--- /dev/null
+++ b/x11/slurp/pkg-descr
@@ -0,0 +1,4 @@
+Select a region in a Wayland compositor and print it to the standard
+output. Works well with grim on sway >= 1.0.
+
+WWW: https://wayland.emersion.fr/slurp/