aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2022-09-11 10:20:14 +0000
committerFelix Palmen <zirias@FreeBSD.org>2022-09-11 10:20:14 +0000
commitddae4e92d8313a1461145e3b4f0232fe463feaee (patch)
treee84ab3fcfdf00dbf560f8ef9ae031d0c2ed252f5 /x11
parent51a360b7fe98be99d21134e5fe624ba12d596dd9 (diff)
downloadports-ddae4e92d8313a1461145e3b4f0232fe463feaee.tar.gz
ports-ddae4e92d8313a1461145e3b4f0232fe463feaee.zip
Mk/Uses: always use colon for build/run suffix
Most USES use a colon for build/run(/test) suffixes. Change kde.mk, qt.mk and pyqt.mk to do the same, and update all ports using that. Document in CHANGES. PR: 266034 Exp-run by: antoine Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D36349
Diffstat (limited to 'x11')
-rw-r--r--x11/antimicro/Makefile2
-rw-r--r--x11/compton-conf/Makefile2
-rw-r--r--x11/cool-retro-term/Makefile6
-rw-r--r--x11/coreterminal/Makefile2
-rw-r--r--x11/disman/Makefile4
-rw-r--r--x11/dsbautostart/Makefile2
-rw-r--r--x11/dsbxinput/Makefile2
-rw-r--r--x11/glcapsviewer/Makefile2
-rw-r--r--x11/kdisplay/Makefile4
-rw-r--r--x11/kf5-frameworkintegration/Makefile4
-rw-r--r--x11/kf5-kactivities-stats/Makefile4
-rw-r--r--x11/kf5-kactivities/Makefile4
-rw-r--r--x11/kf5-kded/Makefile4
-rw-r--r--x11/kf5-kdelibs4support/Makefile8
-rw-r--r--x11/kf5-kglobalaccel/Makefile4
-rw-r--r--x11/kf5-kinit/Makefile4
-rw-r--r--x11/kf5-krunner/Makefile4
-rw-r--r--x11/kf5-kwayland/Makefile4
-rw-r--r--x11/kf5-kwindowsystem/Makefile4
-rw-r--r--x11/kf5-plasma-framework/Makefile4
-rw-r--r--x11/konsole/Makefile4
-rw-r--r--x11/libfm-qt/Makefile2
-rw-r--r--x11/lumina-core/Makefile4
-rw-r--r--x11/lumina-coreutils/Makefile4
-rw-r--r--x11/lxqt-about/Makefile2
-rw-r--r--x11/lxqt-globalkeys/Makefile2
-rw-r--r--x11/lxqt-runner/Makefile2
-rw-r--r--x11/pcdm/Makefile2
-rw-r--r--x11/plasma-wayland-protocols/Makefile2
-rw-r--r--x11/plasma5-kactivitymanagerd/Makefile2
-rw-r--r--x11/plasma5-kgamma5/Makefile4
-rw-r--r--x11/plasma5-kscreen/Makefile4
-rw-r--r--x11/plasma5-kwayland-integration/Makefile2
-rw-r--r--x11/plasma5-kwayland-server/Makefile2
-rw-r--r--x11/plasma5-layer-shell-qt/Makefile2
-rw-r--r--x11/plasma5-libkscreen/Makefile4
-rw-r--r--x11/plasma5-plasma-desktop/Makefile8
-rw-r--r--x11/plasma5-plasma-integration/Makefile4
-rw-r--r--x11/plasma5-plasma-workspace/Makefile10
-rw-r--r--x11/plasma5-plasma/Makefile2
-rw-r--r--x11/qimageblitz/Makefile2
-rw-r--r--x11/qt5-x11extras/Makefile2
-rw-r--r--x11/qterminal/Makefile2
-rw-r--r--x11/radare-cutter/Makefile2
-rw-r--r--x11/rsibreak/Makefile2
-rw-r--r--x11/sddm/Makefile4
-rw-r--r--x11/yakuake/Makefile4
47 files changed, 80 insertions, 80 deletions
diff --git a/x11/antimicro/Makefile b/x11/antimicro/Makefile
index 499b99bf53c2..9dbb18eec795 100644
--- a/x11/antimicro/Makefile
+++ b/x11/antimicro/Makefile
@@ -20,7 +20,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
USES= cmake compiler:c++11-lang desktop-file-utils pkgconfig \
qt:5 sdl shared-mime-info xorg
USE_XORG= x11 xi xtst
-USE_QT= core gui linguisttools_build qmake_build buildtools_build widgets network
+USE_QT= core gui linguisttools:build qmake:build buildtools:build widgets network
USE_SDL= sdl2
.include <bsd.port.mk>
diff --git a/x11/compton-conf/Makefile b/x11/compton-conf/Makefile
index 9adb7c3892ba..17ecd80b8d22 100644
--- a/x11/compton-conf/Makefile
+++ b/x11/compton-conf/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS= compton:x11-wm/compton
USES= cmake compiler:c++14-lang localbase:ldflags lxqt qt:5 \
pkgconfig tar:xz
-USE_QT= buildtools_build qmake_build core dbus gui linguisttools \
+USE_QT= buildtools:build qmake:build core dbus gui linguisttools \
widgets
USE_LXQT= buildtools
diff --git a/x11/cool-retro-term/Makefile b/x11/cool-retro-term/Makefile
index 83a0870f3daa..23fc3f8e40d3 100644
--- a/x11/cool-retro-term/Makefile
+++ b/x11/cool-retro-term/Makefile
@@ -17,9 +17,9 @@ GH_SUBDIR= ${GH_PROJECT}
USES= compiler:c++11-lang gl gmake qmake qt:5
USE_GL= gl
-USE_QT= qmake_build buildtools_build core declarative gui \
- network sql widgets graphicaleffects_run \
- quickcontrols_run sql-sqlite3_run
+USE_QT= qmake:build buildtools:build core declarative gui \
+ network sql widgets graphicaleffects:run \
+ quickcontrols:run sql-sqlite3:run
post-patch:
@${REINPLACE_CMD} -e '/DEFINES +=/s,^macx:,,' \
diff --git a/x11/coreterminal/Makefile b/x11/coreterminal/Makefile
index 056d31a66bd4..b6eaf76ca1cc 100644
--- a/x11/coreterminal/Makefile
+++ b/x11/coreterminal/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libqtermwidget5.so:x11-toolkits/qtermwidget \
RUN_DEPENDS= coregarage:deskutils/coregarage
USES= cmake localbase:ldflags qt:5
-USE_QT= buildtools_build core gui qmake_build serialport widgets
+USE_QT= buildtools:build core gui qmake:build serialport widgets
USE_GITLAB= yes
GL_ACCOUNT= CuboCore
diff --git a/x11/disman/Makefile b/x11/disman/Makefile
index f65ea823f19a..6813654ae2f4 100644
--- a/x11/disman/Makefile
+++ b/x11/disman/Makefile
@@ -14,9 +14,9 @@ TEST_DEPENDS= ${qt-testlib_PORT:T}>0:${qt-testlib_PORT}
USES= cmake:testing kde:5 qt:5
USE_GITLAB= yes
-USE_KDE= ecm_build coreaddons
+USE_KDE= ecm:build coreaddons
USE_LDCONFIG= yes
-USE_QT= qmake_build buildtools_build core dbus gui
+USE_QT= qmake:build buildtools:build core dbus gui
GL_ACCOUNT= kwinft
GL_COMMIT= a8fc81af423ab14513c7096b405cec3f58943495
PLIST_SUB= VERSION=${PORTVERSION}
diff --git a/x11/dsbautostart/Makefile b/x11/dsbautostart/Makefile
index 4345a495a0ab..4c51b50b8524 100644
--- a/x11/dsbautostart/Makefile
+++ b/x11/dsbautostart/Makefile
@@ -14,6 +14,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= compiler:c++11-lang gl qmake qt:5 tar:tgz
USE_GL= gl
-USE_QT= buildtools_build core gui linguisttools_build widgets
+USE_QT= buildtools:build core gui linguisttools:build widgets
.include <bsd.port.mk>
diff --git a/x11/dsbxinput/Makefile b/x11/dsbxinput/Makefile
index 8886d5500812..5a3267b5a436 100644
--- a/x11/dsbxinput/Makefile
+++ b/x11/dsbxinput/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= xinput:x11/xinput
USES= pyqt:5 python:3.8+ qt:5
-USE_QT= linguisttools_build
+USE_QT= linguisttools:build
USE_GITHUB= yes
GH_ACCOUNT= mrclksr
GH_PROJECT= DSBXinput
diff --git a/x11/glcapsviewer/Makefile b/x11/glcapsviewer/Makefile
index d7e73f0f210f..6c3eefa840aa 100644
--- a/x11/glcapsviewer/Makefile
+++ b/x11/glcapsviewer/Makefile
@@ -18,7 +18,7 @@ GH_TAGNAME= 26e160c
USES= cmake compiler:c++11-lang gl qt:5 xorg
USE_GL= gl glew glu
-USE_QT= buildtools_build qmake_build core gui network widgets
+USE_QT= buildtools:build qmake:build core gui network widgets
USE_XORG= ice sm x11 xext
PLIST_FILES= bin/glcapsviewer ${DATADIR_REL}/capslist.xml \
diff --git a/x11/kdisplay/Makefile b/x11/kdisplay/Makefile
index 5f391fd01e48..77d5b4fd5bef 100644
--- a/x11/kdisplay/Makefile
+++ b/x11/kdisplay/Makefile
@@ -17,10 +17,10 @@ TEST_DEPENDS= ${qt-testlib_PORT:T}>0:${qt-testlib_PORT}
USES= cmake:testing kde:5 qt:5
USE_GITLAB= yes
-USE_KDE= ecm_build config coreaddons dbusaddons globalaccel i18n \
+USE_KDE= ecm:build config coreaddons dbusaddons globalaccel i18n \
kcmutils kdeclarative plasma-framework xmlgui
USE_LDCONFIG= yes
-USE_QT= qmake_build buildtools_build core dbus declarative gui \
+USE_QT= qmake:build buildtools:build core dbus declarative gui \
sensors widgets
GL_ACCOUNT= kwinft
GL_COMMIT= a4dcebd297fded753579c7aef5a874617d274b7f
diff --git a/x11/kf5-frameworkintegration/Makefile b/x11/kf5-frameworkintegration/Makefile
index 4cb589e3ea78..2a4e730e23c7 100644
--- a/x11/kf5-frameworkintegration/Makefile
+++ b/x11/kf5-frameworkintegration/Makefile
@@ -9,9 +9,9 @@ USES= cmake compiler:c++11-lib gettext kde:5 pkgconfig \
qt:5 tar:xz xorg
USE_KDE= auth attica codecs config configwidgets coreaddons i18n \
iconthemes newstuff notifications widgetsaddons \
- ecm_build
+ ecm:build
USE_QT= core dbus gui network widgets xml \
- buildtools_build qmake_build
+ buildtools:build qmake:build
USE_XORG= xcb xcursor
.include <bsd.port.mk>
diff --git a/x11/kf5-kactivities-stats/Makefile b/x11/kf5-kactivities-stats/Makefile
index b1de65ed986a..82742788299b 100644
--- a/x11/kf5-kactivities-stats/Makefile
+++ b/x11/kf5-kactivities-stats/Makefile
@@ -10,8 +10,8 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/range/algorithm.hpp:devel/boost-libs
USES= cmake compiler:c++11-lib kde:5 pathfix qt:5 tar:xz
USE_KDE= activities config \
- ecm_build
+ ecm:build
USE_QT= core dbus sql \
- buildtools_build qmake_build
+ buildtools:build qmake:build
.include <bsd.port.mk>
diff --git a/x11/kf5-kactivities/Makefile b/x11/kf5-kactivities/Makefile
index 2991300e680e..bf04e8048b64 100644
--- a/x11/kf5-kactivities/Makefile
+++ b/x11/kf5-kactivities/Makefile
@@ -10,8 +10,8 @@ BUILD_DEPENDS= boost-libs>1.53:devel/boost-libs
USES= cmake compiler:c++11-lib gettext kde:5 pathfix qt:5 tar:xz
USE_KDE= config coreaddons service \
- ecm_build
+ ecm:build
USE_QT= core dbus declarative gui network sql \
- buildtools_build qmake_build
+ buildtools:build qmake:build
.include <bsd.port.mk>
diff --git a/x11/kf5-kded/Makefile b/x11/kf5-kded/Makefile
index 85655e2b22b2..baf707071109 100644
--- a/x11/kf5-kded/Makefile
+++ b/x11/kf5-kded/Makefile
@@ -7,8 +7,8 @@ COMMENT= KF5 extensible daemon for providing system level services
USES= cmake compiler:c++11-lib kde:5 qt:5 tar:xz
USE_KDE= config coreaddons crash dbusaddons service \
- doctools_build ecm_build
+ doctools:build ecm:build
USE_QT= core dbus gui widgets \
- buildtools_build qmake_build
+ buildtools:build qmake:build
.include <bsd.port.mk>
diff --git a/x11/kf5-kdelibs4support/Makefile b/x11/kf5-kdelibs4support/Makefile
index 7cfae8c90e6f..4fa32419053c 100644
--- a/x11/kf5-kdelibs4support/Makefile
+++ b/x11/kf5-kdelibs4support/Makefile
@@ -15,12 +15,12 @@ USE_KDE= auth bookmarks codecs completion config configwidgets \
i18n iconthemes itemviews jobwidgets kded kio notifications \
parts service solid sonnet textwidgets unitconversion \
widgetsaddons windowsystem xmlgui \
- doctools_build ecm_build \
- designerplugin_build designerplugin_run \
- itemmodels_run
+ doctools:build ecm:build \
+ designerplugin:build designerplugin:run \
+ itemmodels:run
USE_QT= concurrent core dbus designer gui network \
printsupport svg testlib widgets x11extras xml \
- buildtools_build qmake_build testlib_build
+ buildtools:build qmake:build testlib:build
USE_XORG= ice sm x11 xcb xext
SHEBANG_FILES= src/kio/fileshareset
diff --git a/x11/kf5-kglobalaccel/Makefile b/x11/kf5-kglobalaccel/Makefile
index 5cfd399d4baa..26437c98b78a 100644
--- a/x11/kf5-kglobalaccel/Makefile
+++ b/x11/kf5-kglobalaccel/Makefile
@@ -11,9 +11,9 @@ LIB_DEPENDS= libxcb-keysyms.so:x11/xcb-util-keysyms
USES= cmake compiler:c++11-lib kde:5 qt:5 tar:xz xorg
USE_KDE= config coreaddons crash dbusaddons i18n service \
windowsystem \
- ecm_build
+ ecm:build
USE_QT= core dbus gui linguisttools widgets x11extras \
- buildtools_build qmake_build testlib_build
+ buildtools:build qmake:build testlib:build
USE_XORG= x11 xcb
.include <bsd.port.mk>
diff --git a/x11/kf5-kinit/Makefile b/x11/kf5-kinit/Makefile
index 7183fca9afda..eb7d5f5efab1 100644
--- a/x11/kf5-kinit/Makefile
+++ b/x11/kf5-kinit/Makefile
@@ -9,9 +9,9 @@ COMMENT= KF5 process launcher to speed up launching KDE applications
USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz xorg
USE_KDE= completion config coreaddons crash dbusaddons i18n \
jobwidgets kio service solid widgetsaddons windowsystem \
- doctools_build ecm_build
+ doctools:build ecm:build
USE_QT= concurrent core dbus gui network widgets \
- buildtools_build qmake_build
+ buildtools:build qmake:build
USE_XORG= x11 xcb
.include <bsd.port.mk>
diff --git a/x11/kf5-krunner/Makefile b/x11/kf5-krunner/Makefile
index 1c0c413183ac..6e4f60ab74f4 100644
--- a/x11/kf5-krunner/Makefile
+++ b/x11/kf5-krunner/Makefile
@@ -9,8 +9,8 @@ COMMENT= KF5 parallelized query system
USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz
USE_KDE= activities config coreaddons i18n kio package plasma-framework \
service solid threadweaver \
- ecm_build
+ ecm:build
USE_QT= concurrent core dbus declarative gui network widgets \
- buildtools_build qmake_build
+ buildtools:build qmake:build
.include <bsd.port.mk>
diff --git a/x11/kf5-kwayland/Makefile b/x11/kf5-kwayland/Makefile
index 528e129e4aba..a48e937b38db 100644
--- a/x11/kf5-kwayland/Makefile
+++ b/x11/kf5-kwayland/Makefile
@@ -16,8 +16,8 @@ LICENSE_COMB= dual
USES= cmake compiler:c++11-lib gettext gl kde:5 pkgconfig \
qt:5 tar:xz
USE_GL= egl
-USE_KDE= ecm_build
+USE_KDE= ecm:build
USE_QT= concurrent core gui wayland \
- buildtools_build qmake_build testlib_build
+ buildtools:build qmake:build testlib:build
.include <bsd.port.mk>
diff --git a/x11/kf5-kwindowsystem/Makefile b/x11/kf5-kwindowsystem/Makefile
index 504e0d4e7cd1..7e9586291412 100644
--- a/x11/kf5-kwindowsystem/Makefile
+++ b/x11/kf5-kwindowsystem/Makefile
@@ -8,9 +8,9 @@ COMMENT= KF5 library for access to the windowing system
LIB_DEPENDS= libxcb-keysyms.so:x11/xcb-util-keysyms
USES= cmake compiler:c++11-lib kde:5 pkgconfig qt:5 tar:xz xorg
-USE_KDE= ecm_build
+USE_KDE= ecm:build
USE_QT= core gui linguisttools widgets x11extras \
- buildtools_build qmake_build testlib_build
+ buildtools:build qmake:build testlib:build
USE_XORG= ice sm x11 xcb xext xfixes xrender
.include <bsd.port.mk>
diff --git a/x11/kf5-plasma-framework/Makefile b/x11/kf5-plasma-framework/Makefile
index 557adb6bc585..f922113d48db 100644
--- a/x11/kf5-plasma-framework/Makefile
+++ b/x11/kf5-plasma-framework/Makefile
@@ -9,11 +9,11 @@ COMMENT= KF5 plugin based UI runtime used to write user interfaces
USES= cmake compiler:c++11-lib gettext gl kde:5 pkgconfig qt:5 tar:xz xorg
USE_GL= egl gl
USE_KDE= activities archive auth codecs completion config \
- configwidgets coreaddons dbusaddons doctools_build globalaccel \
+ configwidgets coreaddons dbusaddons doctools:build globalaccel \
guiaddons i18n iconthemes jobwidgets kirigami2 kio package \
notifications service solid wayland windowsystem xmlgui kdeclarative \
widgetsaddons
-USE_QT= buildtools_build concurrent core dbus declarative gui network qmake_build \
+USE_QT= buildtools:build concurrent core dbus declarative gui network qmake:build \
script sql svg widgets x11extras xml
USE_XORG= ice sm x11 xcb xext xrandr
diff --git a/x11/konsole/Makefile b/x11/konsole/Makefile
index 1b10294ae516..622d03ba09a9 100644
--- a/x11/konsole/Makefile
+++ b/x11/konsole/Makefile
@@ -20,10 +20,10 @@ USE_KDE= auth attica bookmarks codecs completion config configwidgets \
iconthemes init itemmodels jobwidgets kio \
newstuff notifications notifyconfig parts pty service solid sonnet \
textwidgets widgetsaddons windowsystem xmlgui \
- ecm_build
+ ecm:build
USE_QT= concurrent core dbus gui network printsupport script scripttools sql \
widgets xml \
- buildtools_build qmake_build
+ buildtools:build qmake:build
USE_XORG= x11
OPTIONS_DEFINE= DOCS
diff --git a/x11/libfm-qt/Makefile b/x11/libfm-qt/Makefile
index 3d2e71c96a25..82a8884156e8 100644
--- a/x11/libfm-qt/Makefile
+++ b/x11/libfm-qt/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libmenu-cache.so:x11/menu-cache \
USES= cmake compiler:c++14-lang gettext-runtime lxqt pkgconfig \
qt:5 gnome shared-mime-info tar:xz xorg
-USE_QT= buildtools_build qmake_build core gui linguisttools widgets \
+USE_QT= buildtools:build qmake:build core gui linguisttools widgets \
x11extras
USE_GNOME= glib20
USE_XORG= xcb
diff --git a/x11/lumina-core/Makefile b/x11/lumina-core/Makefile
index 5bf35b5497f1..ee6fa99d0b55 100644
--- a/x11/lumina-core/Makefile
+++ b/x11/lumina-core/Makefile
@@ -28,7 +28,7 @@ USES= compiler:c++11-lang gl qmake qt:5 xorg
USE_GL= gl
USE_XORG= x11 xdamage xcb
USE_LDCONFIG= yes
-USE_QT= buildtools_build concurrent core dbus declarative gui \
+USE_QT= buildtools:build concurrent core dbus declarative gui \
imageformats multimedia network svg widgets x11extras
USE_GITHUB= yes
GH_ACCOUNT= lumina-desktop
@@ -46,7 +46,7 @@ TRUEOS_QMAKE_ON= DEFAULT_SETTINGS=TrueOS
MULTIMEDIA_USES= gstreamer
MULTIMEDIA_USE= GSTREAMER=core
-NLS_USE= QT=linguist_build
+NLS_USE= QT=linguist:build
NLS_QMAKE_ON= CONFIG+=WITH_I18N
WRKSRC_SUBDIR= src-qt5/core
diff --git a/x11/lumina-coreutils/Makefile b/x11/lumina-coreutils/Makefile
index bf3eaa76cbf1..e0ac844f1315 100644
--- a/x11/lumina-coreutils/Makefile
+++ b/x11/lumina-coreutils/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/../../LICENSE
RUN_DEPENDS= xrandr:x11/xrandr
USES= compiler:c++11-lang qmake qt:5
-USE_QT= buildtools_build concurrent core gui \
+USE_QT= buildtools:build concurrent core gui \
imageformats multimedia network \
svg widgets x11extras
USE_GITHUB= yes
@@ -23,7 +23,7 @@ GH_PROJECT= lumina
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
-NLS_USE= QT=linguist_build
+NLS_USE= QT=linguist:build
NLS_QMAKE_ON= CONFIG+=WITH_I18N
WRKSRC_SUBDIR= src-qt5/core-utils
diff --git a/x11/lxqt-about/Makefile b/x11/lxqt-about/Makefile
index fc9301fb1b26..2a018555561a 100644
--- a/x11/lxqt-about/Makefile
+++ b/x11/lxqt-about/Makefile
@@ -12,7 +12,7 @@ LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
USES= cmake compiler:c++11-lang kde:5 lxqt pkgconfig tar:xz qt:5 gnome xorg
-USE_QT= buildtools_build qmake_build core dbus gui svg widgets \
+USE_QT= buildtools:build qmake:build core dbus gui svg widgets \
x11extras xml
USE_XORG= x11
USE_KDE= windowsystem
diff --git a/x11/lxqt-globalkeys/Makefile b/x11/lxqt-globalkeys/Makefile
index 4f14d70a197b..1f8c6c203988 100644
--- a/x11/lxqt-globalkeys/Makefile
+++ b/x11/lxqt-globalkeys/Makefile
@@ -11,7 +11,7 @@ LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake compiler:c++14-lang kde:5 xorg lxqt pkgconfig qt:5 tar:xz gnome
-USE_QT= buildtools_build qmake_build core dbus gui linguisttools \
+USE_QT= buildtools:build qmake:build core dbus gui linguisttools \
svg widgets x11extras xml
USE_KDE= windowsystem
USE_LXQT= buildtools lxqt
diff --git a/x11/lxqt-runner/Makefile b/x11/lxqt-runner/Makefile
index 11ba93a8c234..69696eb98cf5 100644
--- a/x11/lxqt-runner/Makefile
+++ b/x11/lxqt-runner/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libmuparser.so:math/muparser
USES= cmake compiler:c++14-lang gettext-runtime kde:5 qt:5 \
gnome localbase lxqt pkgconfig tar:xz xorg
-USE_QT= buildtools_build qmake_build core dbus gui linguisttools \
+USE_QT= buildtools:build qmake:build core dbus gui linguisttools \
script svg widgets x11extras xml
USE_KDE= windowsystem
USE_GNOME= glib20
diff --git a/x11/pcdm/Makefile b/x11/pcdm/Makefile
index 8e486f480ed7..dbbd507adb7d 100644
--- a/x11/pcdm/Makefile
+++ b/x11/pcdm/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= xorg-minimal>=0:x11/xorg-minimal \
USES= compiler:c++11-lang gl qmake qt:5 xorg
USE_QT= core gui network svg multimedia imageformats \
- buildtools_build x11extras widgets concurrent linguisttools_build
+ buildtools:build x11extras widgets concurrent linguisttools:build
USE_GL= gl
USE_XORG= x11
diff --git a/x11/plasma-wayland-protocols/Makefile b/x11/plasma-wayland-protocols/Makefile
index c1758600a35e..ef2c8d3bdf0c 100644
--- a/x11/plasma-wayland-protocols/Makefile
+++ b/x11/plasma-wayland-protocols/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING.LIB
USES= cmake kde:5 qt:5 tar:xz
USE_KDE= ecm
-USE_QT= buildtools_build qmake_build
+USE_QT= buildtools:build qmake:build
NO_ARCH= yes
diff --git a/x11/plasma5-kactivitymanagerd/Makefile b/x11/plasma5-kactivitymanagerd/Makefile
index b00894d4f3b6..2e5a398f15b8 100644
--- a/x11/plasma5-kactivitymanagerd/Makefile
+++ b/x11/plasma5-kactivitymanagerd/Makefile
@@ -14,7 +14,7 @@ USE_KDE= auth codecs config configwidgets coreaddons crash dbusaddons \
ecm globalaccel i18n kio service widgetsaddons windowsystem \
xmlgui
USE_QT= concurrent core dbus gui network sql widgets xml \
- buildtools_build qmake_build
+ buildtools:build qmake:build
USE_XORG= x11
.include <bsd.port.mk>
diff --git a/x11/plasma5-kgamma5/Makefile b/x11/plasma5-kgamma5/Makefile
index 7b2e76de3b87..d1d5bfcdb426 100644
--- a/x11/plasma5-kgamma5/Makefile
+++ b/x11/plasma5-kgamma5/Makefile
@@ -12,9 +12,9 @@ USE_KDE= auth bookmarks codecs completion config configwidgets \
itemmodels itemviews jobwidgets kio notifications parts \
service solid sonnet textwidgets unitconversion widgetsaddons \
windowsystem xmlgui \
- doctools_build ecm_build
+ doctools:build ecm:build
USE_QT= core dbus gui network printsupport widgets x11extras xml \
- buildtools_build qmake_build
+ buildtools:build qmake:build
USE_XORG= ice sm x11 xext xxf86vm
.include <bsd.port.mk>
diff --git a/x11/plasma5-kscreen/Makefile b/x11/plasma5-kscreen/Makefile
index fdae6f68a62d..5b8f9b747320 100644
--- a/x11/plasma5-kscreen/Makefile
+++ b/x11/plasma5-kscreen/Makefile
@@ -13,9 +13,9 @@ USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz xorg
USE_KDE= auth codecs config configwidgets coreaddons dbusaddons \
globalaccel i18n kcmutils kdeclarative libkscreen package \
plasma-framework service widgetsaddons windowsystem xmlgui \
- ecm_build
+ ecm:build
USE_QT= core dbus declarative gui network sensors widgets x11extras xml \
- buildtools_build qmake_build testlib_build
+ buildtools:build qmake:build testlib:build
USE_XORG= x11 xcb xext xi
.include <bsd.port.mk>
diff --git a/x11/plasma5-kwayland-integration/Makefile b/x11/plasma5-kwayland-integration/Makefile
index 9b482b4305f1..088243b1e657 100644
--- a/x11/plasma5-kwayland-integration/Makefile
+++ b/x11/plasma5-kwayland-integration/Makefile
@@ -17,7 +17,7 @@ USES= cmake compiler:c++11-lib gl kde:5 pkgconfig qt:5 tar:xz xorg
USE_GL= gl
USE_KDE= ecm guiaddons idletime plasma-wayland-protocols wayland windowsystem
USE_QT= core gui wayland widgets \
- buildtools_build qmake_build
+ buildtools:build qmake:build
USE_XORG= x11
.include <bsd.port.mk>
diff --git a/x11/plasma5-kwayland-server/Makefile b/x11/plasma5-kwayland-server/Makefile
index a1aea990c921..085b756fd3e3 100644
--- a/x11/plasma5-kwayland-server/Makefile
+++ b/x11/plasma5-kwayland-server/Makefile
@@ -18,6 +18,6 @@ USES= cmake compiler:c++11-lang gl kde:5 pkgconfig qt:5 tar:xz
USE_GL= egl
USE_KDE= ecm wayland
USE_QT= concurrent core gui wayland \
- buildtools_build qmake_build
+ buildtools:build qmake:build
.include <bsd.port.mk>
diff --git a/x11/plasma5-layer-shell-qt/Makefile b/x11/plasma5-layer-shell-qt/Makefile
index 16f6dffbba16..7bfe4ce5341a 100644
--- a/x11/plasma5-layer-shell-qt/Makefile
+++ b/x11/plasma5-layer-shell-qt/Makefile
@@ -15,6 +15,6 @@ USES= cmake compiler:c++11-lang gettext gl kde:5 pkgconfig qt:5 tar:xz
USE_GL= gl
USE_KDE= ecm
USE_QT= core gui wayland \
- buildtools_build qmake_build
+ buildtools:build qmake:build
.include <bsd.port.mk>
diff --git a/x11/plasma5-libkscreen/Makefile b/x11/plasma5-libkscreen/Makefile
index e0837333a4b6..e5831b838810 100644
--- a/x11/plasma5-libkscreen/Makefile
+++ b/x11/plasma5-libkscreen/Makefile
@@ -12,9 +12,9 @@ LIB_DEPENDS= libwayland-client.so:graphics/wayland
USES= cmake compiler:c++11-lib kde:5 pathfix pkgconfig qt:5 tar:xz \
xorg
USE_KDE= plasma-wayland-protocols wayland \
- ecm_build
+ ecm:build
USE_QT= core dbus gui x11extras \
- buildtools_build qmake_build testlib_build
+ buildtools:build qmake:build testlib:build
USE_XORG= x11 xcb xrandr
.include <bsd.port.mk>
diff --git a/x11/plasma5-plasma-desktop/Makefile b/x11/plasma5-plasma-desktop/Makefile
index bbba3fad5905..c876c0b9f0f9 100644
--- a/x11/plasma5-plasma-desktop/Makefile
+++ b/x11/plasma5-plasma-desktop/Makefile
@@ -39,12 +39,12 @@ USE_KDE= activities activities-stats archive attica auth baloo \
plasma-framework plasma-workspace runner service solid sonnet \
textwidgets unitconversion wallet widgetsaddons windowsystem \
xmlgui \
- doctools_build ecm_build \
- drkonqi_run infocenter_run kde-cli-tools_run kmenuedit_run \
- ksysguard_run polkit-kde-agent-1_run systemsettings_run
+ doctools:build ecm:build \
+ drkonqi:run infocenter:run kde-cli-tools:run kmenuedit:run \
+ ksysguard:run polkit-kde-agent-1:run systemsettings:run
USE_QT= concurrent core dbus declarative gui network phonon4 \
printsupport sql svg widgets x11extras xml \
- buildtools_build qmake_build
+ buildtools:build qmake:build
USE_XORG= ice sm x11 xcb xcursor xext xfixes xft xi xrender
CPE_VENDOR= kde
diff --git a/x11/plasma5-plasma-integration/Makefile b/x11/plasma5-plasma-integration/Makefile
index a77ae8cdf5e1..0055d741231a 100644
--- a/x11/plasma5-plasma-integration/Makefile
+++ b/x11/plasma5-plasma-integration/Makefile
@@ -15,10 +15,10 @@ USE_KDE= auth bookmarks breeze codecs completion config configwidgets \
coreaddons ecm i18n iconthemes itemviews jobwidgets kio \
notifications service solid wayland widgetsaddons windowsystem \
xmlgui \
- qqc2-desktop-style_run
+ qqc2-desktop-style:run
USE_QT= concurrent core dbus declarative gui network quickcontrols2 \
widgets x11extras xml \
- buildtools_build qmake_build
+ buildtools:build qmake:build
USE_XORG= x11 xcb xcursor
SHEBANG_FILES= src/platformtheme/fonts_akregator.pl \
diff --git a/x11/plasma5-plasma-workspace/Makefile b/x11/plasma5-plasma-workspace/Makefile
index 1dd12bd9caf0..b27d3ff39106 100644
--- a/x11/plasma5-plasma-workspace/Makefile
+++ b/x11/plasma5-plasma-workspace/Makefile
@@ -42,14 +42,14 @@ USE_KDE= activities activities-stats activitymanagerd archive attica \
plasma-framework plasma-integration prison pty runner service \
solid sonnet syntaxhighlighting texteditor textwidgets unitconversion \
wallet wayland widgetsaddons windowsystem xmlgui xmlrpcclient \
- doctools_build ecm_build \
- breeze-icons_run breeze_run kded_run kquickcharts_run \
- milou_run oxygen-icons5_run
+ doctools:build ecm:build \
+ breeze-icons:run breeze:run kded:run kquickcharts:run \
+ milou:run oxygen-icons5:run
USE_QT= concurrent core dbus declarative graphicaleffects gui network \
phonon4 printsupport qdbus script sql svg wayland webkit \
widgets x11extras xml \
- buildtools_build qmake_build testlib_build \
- paths_run quickcontrols_run
+ buildtools:build qmake:build testlib:build \
+ paths:run quickcontrols:run
USE_XORG= ice sm x11 xau xcb xcomposite xcursor xext xfixes xft xi xkbfile xrender xtst
CPE_VENDOR= kde
diff --git a/x11/plasma5-plasma/Makefile b/x11/plasma5-plasma/Makefile
index 375e665cb63a..7c58a26111e5 100644
--- a/x11/plasma5-plasma/Makefile
+++ b/x11/plasma5-plasma/Makefile
@@ -21,6 +21,6 @@ OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
PHONON_DESC= Include phonon-gstreamer, for sound output
PHONON_RUN_DEPENDS= ${QT_PLUGINDIR}/phonon4qt5_backend/phonon_gstreamer.so:multimedia/phonon-gstreamer
-PULSEAUDIO_USE= KDE=plasma-pa_run
+PULSEAUDIO_USE= KDE=plasma-pa:run
.include <bsd.port.mk>
diff --git a/x11/qimageblitz/Makefile b/x11/qimageblitz/Makefile
index f420e99a139b..5bfc83df5e87 100644
--- a/x11/qimageblitz/Makefile
+++ b/x11/qimageblitz/Makefile
@@ -13,7 +13,7 @@ FETCH_DEPENDS= svn:devel/subversion
USES= cmake compiler:c++11-lang qt:5
USE_LDCONFIG= yes
-USE_QT= core gui widgets qmake_build buildtools_build
+USE_QT= core gui widgets qmake:build buildtools:build
USE_CXXSTD= gnu++98
SVN_URL= svn://anonsvn.kde.org/home/kde/trunk/kdesupport/qimageblitz
diff --git a/x11/qt5-x11extras/Makefile b/x11/qt5-x11extras/Makefile
index d83132e409e5..9c2b119b21bf 100644
--- a/x11/qt5-x11extras/Makefile
+++ b/x11/qt5-x11extras/Makefile
@@ -9,6 +9,6 @@ COMMENT= Qt platform-specific features for X11-based systems
USES= compiler:c++11-lang perl5 qmake qt-dist:5,x11extras perl5
USE_PERL5= extract
USE_QT= core gui \
- buildtools_build # syncqt
+ buildtools:build # syncqt
.include <bsd.port.mk>
diff --git a/x11/qterminal/Makefile b/x11/qterminal/Makefile
index 1eaa6bb0b2a2..40796d9bcd60 100644
--- a/x11/qterminal/Makefile
+++ b/x11/qterminal/Makefile
@@ -14,7 +14,7 @@ RUN_DEPENDS= liberation-fonts-ttf>=2.00:x11-fonts/liberation-fonts-ttf
USES= cmake compiler:c++11-lang gettext-runtime \
localbase:ldflags lxqt pkgconfig qt:5 tar:xz xorg
-USE_QT= buildtools_build core gui qmake_build dbus linguisttools \
+USE_QT= buildtools:build core gui qmake:build dbus linguisttools \
widgets x11extras
USE_XORG= x11
USE_LXQT= buildtools
diff --git a/x11/radare-cutter/Makefile b/x11/radare-cutter/Makefile
index 6a5b09de8ad2..6ed3a8adb3ef 100644
--- a/x11/radare-cutter/Makefile
+++ b/x11/radare-cutter/Makefile
@@ -23,7 +23,7 @@ GH_PROJECT= r2cutter
GH_TUPLE= radareorg:cutter-translations:8e1d24b:translations/translations
USE_QT= core declarative gui linguist location network printsupport svg \
- webchannel widgets buildtools_build
+ webchannel widgets buildtools:build
USE_GL= gl
WRKSRC_SUBDIR= src
diff --git a/x11/rsibreak/Makefile b/x11/rsibreak/Makefile
index 437a5e51ec53..919b42c81627 100644
--- a/x11/rsibreak/Makefile
+++ b/x11/rsibreak/Makefile
@@ -15,7 +15,7 @@ USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz xorg
USE_KDE= auth codecs config configwidgets coreaddons crash dbusaddons doctools ecm \
iconthemes i18n idletime notifications notifyconfig \
sonnet textwidgets xmlgui widgetsaddons windowsystem
-USE_QT= core dbus gui widgets xml buildtools_build qmake_build
+USE_QT= core dbus gui widgets xml buildtools:build qmake:build
USE_XORG= x11
.include <bsd.port.mk>
diff --git a/x11/sddm/Makefile b/x11/sddm/Makefile
index 5bbc84c5aa83..2f9c9c8465b5 100644
--- a/x11/sddm/Makefile
+++ b/x11/sddm/Makefile
@@ -28,9 +28,9 @@ RUN_DEPENDS= dbus-run-session:devel/dbus \
USES= cmake compiler:c++11-lang cpe kde:5 pkgconfig python:build qt:5 xorg
CPE_VENDOR= ${PORTNAME}_project
USE_GITHUB= yes
-USE_KDE= ecm_build
+USE_KDE= ecm:build
USE_QT= core declarative dbus gui network \
- buildtools_build linguisttools_build qmake_build testlib_build
+ buildtools:build linguisttools:build qmake:build testlib:build
USE_XORG= xcb
CONFLICTS_INSTALL= lightdm
diff --git a/x11/yakuake/Makefile b/x11/yakuake/Makefile
index 6852cdb80930..1d603e2e2005 100644
--- a/x11/yakuake/Makefile
+++ b/x11/yakuake/Makefile
@@ -16,9 +16,9 @@ USE_KDE= attica auth archive codecs completion config configwidgets \
jobwidgets kio newstuff notifications notifyconfig parts \
service solid sonnet textwidgets wayland widgetsaddons windowsystem \
xmlgui \
- ecm_build
+ ecm:build
USE_QT= concurrent core dbus gui network widgets x11extras xml \
- buildtools_build qmake_build
+ buildtools:build qmake:build
USE_XORG= x11
OPTIONS_DEFINE= DOCS