aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-01 22:06:50 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-01 22:06:50 +0000
commite83fce0aab3d324ce7e35a57a452470666a85504 (patch)
tree99ccda203e4ce062d16b64388c841aee685e8a35 /x11
parentf47967987e7ba3006f788efd469fdaf8f047b9a8 (diff)
downloadports-e83fce0aab3d324ce7e35a57a452470666a85504.tar.gz
ports-e83fce0aab3d324ce7e35a57a452470666a85504.zip
x11/slim: make consolekit support optional
PR: 197585 Submitted by: Stefan (ott.net) Approved by: maintainer (Henry Hu)
Notes
Notes: svn path=/head/; revision=380229
Diffstat (limited to 'x11')
-rw-r--r--x11/slim/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/x11/slim/Makefile b/x11/slim/Makefile
index d8c1b70bd43e..a339975e788c 100644
--- a/x11/slim/Makefile
+++ b/x11/slim/Makefile
@@ -3,7 +3,7 @@
PORTNAME= slim
PORTVERSION= 1.3.6
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= x11
MASTER_SITES= ftp://ftp.berlios.de/pub/slim/ \
SF/slim.berlios
@@ -18,7 +18,6 @@ LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2 \
- libck-connector.so:${PORTSDIR}/sysutils/consolekit \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
USES= cmake pkgconfig
@@ -32,10 +31,11 @@ CMAKE_ARGS= -DUSE_CONSOLEKIT=yes \
-DBUILD_SLIMLOCK=no \
-DBUILD_SHARED_LIBS=yes
-OPTIONS_DEFINE= PAM UTF8
-OPTIONS_DEFAULT= PAM
+OPTIONS_DEFINE= PAM UTF8 CONSOLEKIT
+OPTIONS_DEFAULT= PAM CONSOLEKIT
UTF8_DESC= Support UTF-8 characters
+CONSOLEKIT_DESC=Enable support for consolekit
PLIST_SUB+= VERSION="${PORTVERSION}"
@@ -54,6 +54,13 @@ PLIST_SUB+= PAM="@comment "
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-utf8
.endif
+.if ${PORT_OPTIONS:MCONSOLEKIT}
+CMAKE_ARGS+= -DUSE_CONSOLEKIT=yes
+LIB_DEPENDS+= libck-connector.so:${PORTSDIR}/sysutils/consolekit
+.else
+CMAKE_ARGS+= -DUSE_CONSOLEKIT=no
+.endif
+
post-patch:
@${CP} ${WRKSRC}/slim.conf ${WRKSRC}/slim.conf.sample
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \