aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-08-22 22:56:25 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-08-22 22:56:25 +0000
commitf5622b4a4b5bce4de668116b337d8ce68a2752f6 (patch)
treedff479ea3581931354f9e83f604d9ad67a9cd50b /x11
parent1e3df1adfa72bf7e1bff3e33317aa2605c6596c9 (diff)
downloadports-f5622b4a4b5bce4de668116b337d8ce68a2752f6.tar.gz
ports-f5622b4a4b5bce4de668116b337d8ce68a2752f6.zip
- update to 2.5
- change LIB_DEPENDS to new format - remove upstreamed patch - add a dependency on the new libxkbcommon Approved by: dhn (implicit)
Notes
Notes: svn path=/head/; revision=325241
Diffstat (limited to 'x11')
-rw-r--r--x11/i3lock/Makefile18
-rw-r--r--x11/i3lock/distinfo4
-rw-r--r--x11/i3lock/files/patch-i3lock.c40
3 files changed, 10 insertions, 52 deletions
diff --git a/x11/i3lock/Makefile b/x11/i3lock/Makefile
index 4450e822765c..348b5db5e499 100644
--- a/x11/i3lock/Makefile
+++ b/x11/i3lock/Makefile
@@ -2,23 +2,21 @@
# $FreeBSD$
PORTNAME= i3lock
-PORTVERSION= 2.4.1
-PORTREVISION= 2
+PORTVERSION= 2.5
CATEGORIES= x11
-MASTER_SITES= http://i3wm.org/${PORTNAME}/ \
- http://mirror.4bit.ws/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= dhn
+MASTER_SITES= http://i3wm.org/${PORTNAME}/
MAINTAINER= dhn@FreeBSD.org
COMMENT= Slightly improved screen locker based on slock
LICENSE= BSD
-LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
- xcb-keysyms:${PORTSDIR}/x11/xcb-util-keysyms \
- xcb-image:${PORTSDIR}/x11/xcb-util-image \
- ev.4:${PORTSDIR}/devel/libev
+LIB_DEPENDS= libcairo.so.2:${PORTSDIR}/graphics/cairo \
+ libxcb-keysyms.so:${PORTSDIR}/x11/xcb-util-keysyms \
+ libxcb-image.so:${PORTSDIR}/x11/xcb-util-image \
+ libev.so.4:${PORTSDIR}/devel/libev \
+ libxkbfile.so:${PORTSDIR}/x11/libxkbfile \
+ libxkbcommon.so:${PORTSDIR}/x11/libxkbcommon
MAKE_ARGS= PREFIX="${PREFIX}" X11LIB="${LOCALBASE}/lib" \
X11INC="${LOCALBASE}/include" CC="${CC}" \
diff --git a/x11/i3lock/distinfo b/x11/i3lock/distinfo
index e21cc0dfa864..10f7107ce4e6 100644
--- a/x11/i3lock/distinfo
+++ b/x11/i3lock/distinfo
@@ -1,2 +1,2 @@
-SHA256 (i3lock-2.4.1.tar.bz2) = 4d29e66841138de562e71903d31ecaaefd8ecffe5e68da0d6c8d560ed543047c
-SIZE (i3lock-2.4.1.tar.bz2) = 30592
+SHA256 (i3lock-2.5.tar.bz2) = ac2772c9e4fc13adb882cacaae13ccc381d6d4f154ffd538634a58e6369d0d77
+SIZE (i3lock-2.5.tar.bz2) = 16135
diff --git a/x11/i3lock/files/patch-i3lock.c b/x11/i3lock/files/patch-i3lock.c
deleted file mode 100644
index 6cf6bda57750..000000000000
--- a/x11/i3lock/files/patch-i3lock.c
+++ /dev/null
@@ -1,40 +0,0 @@
---- ./i3lock.c.orig 2013-03-19 21:44:37.876383724 +0100
-+++ ./i3lock.c 2013-03-20 19:23:55.060606716 +0100
-@@ -525,6 +525,8 @@
- /* In the parent process, we exit */
- if (fork() != 0)
- exit(0);
-+
-+ ev_loop_fork(EV_DEFAULT);
- }
- break;
-
-@@ -645,11 +647,16 @@
- if (ret != PAM_SUCCESS)
- errx(EXIT_FAILURE, "PAM: %s", pam_strerror(pam_handle, ret));
-
-+/* Using mlock() as non-super-user seems only possible in Linux. Users of other
-+ * operating systems should use encrypted swap/no swap (or remove the ifdef and
-+ * run i3lock as super-user). */
-+#if defined(__linux__)
- /* Lock the area where we store the password in memory, we don’t want it to
- * be swapped to disk. Since Linux 2.6.9, this does not require any
- * privileges, just enough bytes in the RLIMIT_MEMLOCK limit. */
- if (mlock(password, sizeof(password)) != 0)
- err(EXIT_FAILURE, "Could not lock page in memory, check RLIMIT_MEMLOCK");
-+#endif
-
- /* Initialize connection to X11 */
- if ((conn = xcb_connect(NULL, &nscreen)) == NULL ||
-@@ -731,9 +738,11 @@
- ev_check_init(xcb_check, xcb_check_cb);
- ev_check_start(main_loop, xcb_check);
-
-+ ev_check_init(xcb_check, xcb_check_cb);
- ev_prepare_init(xcb_prepare, xcb_prepare_cb);
- ev_prepare_start(main_loop, xcb_prepare);
-
-+ ev_check_init(xcb_check, xcb_check_cb);
- /* Invoke the event callback once to catch all the events which were
- * received up until now. ev will only pick up new events (when the X11
- * file descriptor becomes readable). */