aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/py-cbeams/Makefile31
-rw-r--r--games/py-cbeams/distinfo5
-rw-r--r--games/py-cbeams/pkg-descr12
4 files changed, 49 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 7415af9e1fa8..6f20f74a8f5c 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -717,6 +717,7 @@
SUBDIR += puckman
SUBDIR += pushover
SUBDIR += pvpgn
+ SUBDIR += py-cbeams
SUBDIR += py-fife
SUBDIR += py-mnemosyne
SUBDIR += py-sgflib
diff --git a/games/py-cbeams/Makefile b/games/py-cbeams/Makefile
new file mode 100644
index 000000000000..9f3d143eabd7
--- /dev/null
+++ b/games/py-cbeams/Makefile
@@ -0,0 +1,31 @@
+# Created by: Mateusz Piotrowski <0mp@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cbeams
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.0rc3-52
+DISTVERSIONSUFFIX= -gda823c2
+CATEGORIES= games python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${PORTNAME}/commit/
+# Loosen for the dependencies.
+PATCHFILES= 422477bc4c21a0e8ea95549e699edd0c94faa78d.patch:-p1
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Draw pretty animated colored circles in the terminal
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blessings>=1.6:devel/py-blessings@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}docopt>=0.6.1:devel/py-docopt@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= tartley
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/games/py-cbeams/distinfo b/games/py-cbeams/distinfo
new file mode 100644
index 000000000000..cbb6f22a53f3
--- /dev/null
+++ b/games/py-cbeams/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1586353340
+SHA256 (tartley-cbeams-v1.0.0rc3-52-gda823c2_GH0.tar.gz) = 3595c99564eb6fb7ddf98b7bb2f36e699055fb3e00c160bb12aeeb3da6601bb6
+SIZE (tartley-cbeams-v1.0.0rc3-52-gda823c2_GH0.tar.gz) = 25396
+SHA256 (422477bc4c21a0e8ea95549e699edd0c94faa78d.patch) = bbb5363561ff9417e020016ad84cd5287895f7d8e5071c89872b2d9d90b7bbb7
+SIZE (422477bc4c21a0e8ea95549e699edd0c94faa78d.patch) = 714
diff --git a/games/py-cbeams/pkg-descr b/games/py-cbeams/pkg-descr
new file mode 100644
index 000000000000..c69f7db77892
--- /dev/null
+++ b/games/py-cbeams/pkg-descr
@@ -0,0 +1,12 @@
+cbeams is a command-line program which draws pretty animated colored circles in
+the terminal.
+
+The feeling of the generated visuals could be described
+with the following quote:
+
+> I've seen things you people wouldn't believe. Attack ships on fire off the
+> shoulder of Orion. I watched c-beams glitter in the dark, near the
+> Tannhauser Gate. All those moments will be lost, in time, like tears in
+> rain. Time to die.
+
+WWW: https://github.com/tartley/cbeams