aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--print/fontforge/Makefile2
-rw-r--r--print/fontforge/files/patch-fontforgeexe_startui.c25
2 files changed, 26 insertions, 1 deletions
diff --git a/print/fontforge/Makefile b/print/fontforge/Makefile
index c1f804098253..71da30af8307 100644
--- a/print/fontforge/Makefile
+++ b/print/fontforge/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fontforge
PORTVERSION= 20190801
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
MAINTAINER= cyberbotx@cyberbotx.com
diff --git a/print/fontforge/files/patch-fontforgeexe_startui.c b/print/fontforge/files/patch-fontforgeexe_startui.c
new file mode 100644
index 000000000000..a7e23b7834a6
--- /dev/null
+++ b/print/fontforge/files/patch-fontforgeexe_startui.c
@@ -0,0 +1,25 @@
+--- fontforgeexe/startui.c.orig 2019-08-01 08:28:36 UTC
++++ fontforgeexe/startui.c
+@@ -1099,10 +1099,6 @@ int fontforge_main( int argc, char **argv ) {
+ CheckIsScript(argc,argv); /* Will run the script and exit if it is a script */
+ /* If there is no UI, there is always a script */
+ /* and we will never return from the above */
+-#ifdef FONTFORGE_CAN_USE_GDK
+- gdk_init(&argc, &argv);
+- gdk_set_allowed_backends("win32,quartz,x11");
+-#endif
+ if ( load_prefs==NULL ||
+ (strcasecmp(load_prefs,"Always")!=0 && /* Already loaded */
+ strcasecmp(load_prefs,"Never")!=0 ))
+@@ -1185,7 +1181,10 @@ int fontforge_main( int argc, char **argv ) {
+ }
+ #endif
+ }
+-
++#ifdef FONTFORGE_CAN_USE_GDK
++ gdk_init(&argc, &argv);
++ gdk_set_allowed_backends("win32,quartz,x11");
++#endif
+ ensureDotFontForgeIsSetup();
+ #if defined(__MINGW32__) && !defined(_NO_LIBCAIRO)
+ //Load any custom fonts for the user interface