aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/typo3-12/Makefile79
-rw-r--r--www/typo3-12/distinfo3
-rw-r--r--www/typo3-12/files/pkg-message.in24
-rw-r--r--www/typo3-12/pkg-descr14
5 files changed, 121 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a1b54dab879e..4cc1b620be30 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -2309,6 +2309,7 @@
SUBDIR += twiki-WysiwygPlugin
SUBDIR += twms
SUBDIR += typo3-11
+ SUBDIR += typo3-12
SUBDIR += uchiwa
SUBDIR += ufdbguard
SUBDIR += ulfius
diff --git a/www/typo3-12/Makefile b/www/typo3-12/Makefile
new file mode 100644
index 000000000000..ca8a933df898
--- /dev/null
+++ b/www/typo3-12/Makefile
@@ -0,0 +1,79 @@
+PORTNAME= typo3
+PORTVERSION= ${PORT_V_MAJOR}.${PORT_V_MINOR}.${PORT_V_PATCH}
+CATEGORIES= www
+MASTER_SITES= https://typo3.azureedge.net/typo3/${PORTVERSION}/
+PKGNAMESUFFIX= -${PORT_V_MAJOR}${PHP_PKGNAMESUFFIX}
+DISTNAME= ${PORTNAME}_src-${PORTVERSION}
+
+MAINTAINER= freebsd-ports@charlieroot.de
+COMMENT= Typo3 content management system
+WWW= https://typo3.org/
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+IGNORE_WITH_MYSQL= 55 56 57 101m 102m
+IGNORE_WITH_PHP= 80 82
+
+USES= cpe php:web,flavors shebangfix
+USE_PHP= ctype dom fileinfo filter gd hash intl json \
+ mbstring openssl pcre pdo session simplexml \
+ spl tokenizer xml zip zlib
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_src-${PORTVERSION}
+SHEBANG_GLOB= *.sh *.php
+NO_ARCH= yes
+NO_BUILD= yes
+PORTSCOUT= limit:^${PORT_V_MAJOR}\.${PORT_V_MINOR}\.
+SUB_FILES= pkg-message
+SUB_LIST+= PREFIX=${PREFIX} \
+ TYPO3WWW=${TYPO3WWW} \
+ TYPO3DIR=${TYPO3DIR}
+
+PORT_V_MAJOR= 12
+PORT_V_MINOR= 0
+PORT_V_PATCH= 0
+
+TYPO3DIR= www/${PORTNAME}-${PORT_V_MAJOR}
+
+OPTIONS_DEFINE= CURL GMP IMAGICK MYSQL POSTGRES SQLSRV SQLITE
+OPTIONS_DEFAULT=MYSQL
+
+IMAGICK_DESC= ${IMAGEMAGICK_DESC}
+MBSTRING_DESC= ${MULTIBYTE_DESC}
+MYSQL_DESC= Use MySQL as DBMS
+POSTGRES_DESC= Use PostgreSQL as DBMS
+SQLITE_DESC= Use SQLite as DBMS
+SQLSRV_DESC= Use MSSQL as DBMS
+
+CURL_USE= PHP=curl
+GMP_USE= PHP=gmp
+MYSQL_USE= PHP=mysqli
+POSTGRES_USE= PHP=postgresql
+SQLSRV_USE= PHP=sqlsrv
+SQLITE_USE= PHP=sqlite3
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MIMAGICK}
+.if ${PORT_OPTIONS:MX11}
+USES+= magick:7,run
+.else
+USES+= magick:7,run,nox11
+.endif
+.endif
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/${TYPO3DIR}
+
+post-install:
+ @${ECHO_CMD} "@owner ${WWWOWN}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@group ${WWWGRP}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@mode 755" >> ${TMPPLIST}
+ @${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${TYPO3DIR}?g" >>${TMPPLIST}
+ @${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dir ${TYPO3DIR}?g" >> ${TMPPLIST}
+ @${ECHO_CMD} "@mode" >> ${TMPPLIST}
+ @${ECHO_CMD} "@group" >> ${TMPPLIST}
+ @${ECHO_CMD} "@owner" >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/www/typo3-12/distinfo b/www/typo3-12/distinfo
new file mode 100644
index 000000000000..11ed02ee4290
--- /dev/null
+++ b/www/typo3-12/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1669803175
+SHA256 (typo3_src-12.0.0.tar.gz) = eeb5bac265b2211ea377d6cb3f50f030894ff87312055b1692e651dd2ad1b5dc
+SIZE (typo3_src-12.0.0.tar.gz) = 24215372
diff --git a/www/typo3-12/files/pkg-message.in b/www/typo3-12/files/pkg-message.in
new file mode 100644
index 000000000000..2ab734bd1bbb
--- /dev/null
+++ b/www/typo3-12/files/pkg-message.in
@@ -0,0 +1,24 @@
+[
+{ type: install
+ message: <<EOM
+1) Add the following to your Apache configuration file
+ httpd.conf and restart the web server:
+
+ Alias /typo3 %%PREFIX%%/%%TYPO3WWW%%/%%TYPO3DIR%%/
+ AcceptPathInfo On
+ <Directory %%PREFIX%%/%%TYPO3WWW%%/%%TYPO3DIR%%/>
+ Options Indexes FollowSymLinks
+ AllowOverride all
+ Require all granted
+ </Directory>
+
+2) Visit your TYPO3 site with a browser (i.e.
+ http://your.server.com/typo3/) to continue the
+ installation / upgrade process.
+
+For more information, see the INSTALL DOCUMENTATION:
+
+ https://docs.typo3.org/typo3cms/GettingStartedTutorial/latest/Installation/Index.html
+EOM
+}
+]
diff --git a/www/typo3-12/pkg-descr b/www/typo3-12/pkg-descr
new file mode 100644
index 000000000000..1a9fb02d8ec6
--- /dev/null
+++ b/www/typo3-12/pkg-descr
@@ -0,0 +1,14 @@
+The latest version with Long Term Support (LTS). It will have full support until
+31 October 2024 and security bugfixes until 30 April 2026.
+
+* Unified editor experience
+* Advanced filelist module
+* Sharable Deep Links in the TYPO3 Backend
+* Improved collaboration and Workflow features
+* Flexible and Secure Multi-factor Authentication
+* And a lot of Improvements for Developers
+
+System requirements
+* PHP 8.1
+* MySQL 8.0+ / MariaDB / Postgres / SQLite support
+* Modern Browsers