aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-bsltl/Makefile29
-rw-r--r--math/octave-forge-bsltl/distinfo3
-rw-r--r--math/octave-forge-bsltl/pkg-descr11
4 files changed, 44 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 9014e9fa8848..2ad23a16285f 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -317,6 +317,7 @@
SUBDIR += octave-forge-base
SUBDIR += octave-forge-bim
SUBDIR += octave-forge-bioinfo
+ SUBDIR += octave-forge-bsltl
SUBDIR += octave-forge-cgi
SUBDIR += octave-forge-civil-engineering
SUBDIR += octave-forge-communications
diff --git a/math/octave-forge-bsltl/Makefile b/math/octave-forge-bsltl/Makefile
new file mode 100644
index 000000000000..e32e78ab5152
--- /dev/null
+++ b/math/octave-forge-bsltl/Makefile
@@ -0,0 +1,29 @@
+# Created by: Stephen Montgomery-Smith <stephen@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= octave-forge-bsltl
+PORTVERSION= 1.1.1
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+do-build:
+ ${DO_NADA}
+
+post-build:
+ ${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>
diff --git a/math/octave-forge-bsltl/distinfo b/math/octave-forge-bsltl/distinfo
new file mode 100644
index 000000000000..03fc02ea1502
--- /dev/null
+++ b/math/octave-forge-bsltl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1498167823
+SHA256 (octave-forge/bsltl-1.1.1.tar.gz) = 8eedcfa9bcc299b185476b61886fa691bbe3fd72c3a3000a972806ce9cd5a912
+SIZE (octave-forge/bsltl-1.1.1.tar.gz) = 58460
diff --git a/math/octave-forge-bsltl/pkg-descr b/math/octave-forge-bsltl/pkg-descr
new file mode 100644
index 000000000000..3223afa6a831
--- /dev/null
+++ b/math/octave-forge-bsltl/pkg-descr
@@ -0,0 +1,11 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is bsltl.
+
+ The BSLTL package is a free collection of OCTAVE/MATLAB routines for working
+ with the biospeckle laser technique.
+
+WWW: http://octave.sourceforge.net/