aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/xplr/Makefile7
-rw-r--r--misc/xplr/files/extra-patch-Cargo.toml11
2 files changed, 18 insertions, 0 deletions
diff --git a/misc/xplr/Makefile b/misc/xplr/Makefile
index ef098e3f0f02..ef3b819b919f 100644
--- a/misc/xplr/Makefile
+++ b/misc/xplr/Makefile
@@ -145,6 +145,13 @@ OPTIONS_DEFINE= DOCS EXAMPLES
_ASSETS= ${WRKSRC}/assets
_ICONS= ${STAGEDIR}${PREFIX}/share/icons/hicolor
+.include <bsd.port.options.mk>
+
+.if ${ARCH:Mpowerpc64*}
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-Cargo.toml
+LIB_DEPENDS= libluajit-5.1.so:lang/luajit-openresty
+.endif
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
diff --git a/misc/xplr/files/extra-patch-Cargo.toml b/misc/xplr/files/extra-patch-Cargo.toml
new file mode 100644
index 000000000000..f69fe3c97295
--- /dev/null
+++ b/misc/xplr/files/extra-patch-Cargo.toml
@@ -0,0 +1,11 @@
+--- Cargo.toml.orig 2021-10-11 23:08:59 UTC
++++ Cargo.toml
+@@ -30,7 +30,7 @@ lazy_static = "1.4.0"
+ indexmap = { version = "1.7.0", features = ["serde"] }
+ natord = "1.0.9"
+ humansize = "1.1.1"
+-mlua = { version = "0.6.4", features = ["luajit", "vendored", "serialize", "send"] }
++mlua = { version = "0.6.4", features = ["luajit", "serialize", "send"] }
+ ansi-to-tui = "0.4.1"
+ libc = "0.2.103"
+