aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--chinese/scim-chinese/Makefile12
-rw-r--r--chinese/scim-chinese/distinfo4
-rw-r--r--chinese/scim-chinese/pkg-message4
-rw-r--r--chinese/scim-chinese/pkg-plist2
-rw-r--r--chinese/scim-pinyin/Makefile12
-rw-r--r--chinese/scim-pinyin/distinfo4
-rw-r--r--chinese/scim-pinyin/pkg-message4
-rw-r--r--chinese/scim-pinyin/pkg-plist2
-rw-r--r--chinese/scim-tables/Makefile4
-rw-r--r--chinese/scim-tables/distinfo4
-rw-r--r--chinese/scim-tables/pkg-message4
-rw-r--r--japanese/scim-tables/Makefile4
-rw-r--r--japanese/scim-tables/distinfo4
-rw-r--r--japanese/scim-tables/pkg-message4
-rw-r--r--korean/scim-tables/Makefile4
-rw-r--r--korean/scim-tables/distinfo4
-rw-r--r--korean/scim-tables/pkg-message4
-rw-r--r--textproc/scim/Makefile13
-rw-r--r--textproc/scim/distinfo4
-rw-r--r--textproc/scim/pkg-plist46
-rw-r--r--textproc/skim/Makefile20
-rw-r--r--textproc/skim/distinfo4
-rw-r--r--textproc/skim/pkg-message6
-rw-r--r--textproc/skim/pkg-plist87
24 files changed, 156 insertions, 104 deletions
diff --git a/chinese/scim-chinese/Makefile b/chinese/scim-chinese/Makefile
index 8fc745bc0915..46f90f1fe69c 100644
--- a/chinese/scim-chinese/Makefile
+++ b/chinese/scim-chinese/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= scim-chinese
-PORTVERSION= 0.4.1
+PORTVERSION= 0.4.2
CATEGORIES= chinese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://freedesktop.org/~suzhe/scim-chinese/
@@ -30,10 +30,10 @@ CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500035
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/stlport" \
- LDFLAGS="-L${LOCALBASE}/lib -lstlport_gcc -lintl ${PTHREAD_LIBS}"
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/stlport" \
+ LDFLAGS="-L${LOCALBASE}/lib -lstlport_gcc -lintl ${PTHREAD_LIBS}"
EXTRA_PATCHES= ${FILESDIR}/extra-patch-4-stable
.else
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
@@ -43,7 +43,7 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO}
- @${ECHO} To display this message again, type \`make post-install\'
+ @${ECHO} To display this message again, type \`pkg_info -D ${PKGNAME}\'
@${ECHO}
.include <bsd.port.post.mk>
diff --git a/chinese/scim-chinese/distinfo b/chinese/scim-chinese/distinfo
index 68b7803e0d66..17d28b3a43b9 100644
--- a/chinese/scim-chinese/distinfo
+++ b/chinese/scim-chinese/distinfo
@@ -1,2 +1,2 @@
-MD5 (scim-chinese-0.4.1.tar.gz) = 9df58f1a2fe4b3e2f5893de6d2b8d7a1
-SIZE (scim-chinese-0.4.1.tar.gz) = 4813372
+MD5 (scim-chinese-0.4.2.tar.gz) = 6949d2dd3b408231ebd98a8f0a2dc7c8
+SIZE (scim-chinese-0.4.2.tar.gz) = 4826385
diff --git a/chinese/scim-chinese/pkg-message b/chinese/scim-chinese/pkg-message
index 40e04afc9969..9e61f11cd1b4 100644
--- a/chinese/scim-chinese/pkg-message
+++ b/chinese/scim-chinese/pkg-message
@@ -1,5 +1,5 @@
--------------------------------------------------------------------
-Remember to set environment varible XMODIFIERS:
+Remember to set environment variable XMODIFIERS:
csh/tcsh: setenv XMODIFIERS @im=SCIM
sh/bash: export XMODIFIERS='@im=SCIM'
@@ -11,7 +11,7 @@ and set LANG, LC_CTYPE to one of the following values:
Traditional Chinese:
zh_TW.UTF-8, zh_TW.Big5
- zh_HK.UTF-8, zh_HK.Big5-HKSCS
+ zh_HK.UTF-8, zh_HK.Big5-HKSCS
To start the SCIM input method daemon, use command:
diff --git a/chinese/scim-chinese/pkg-plist b/chinese/scim-chinese/pkg-plist
index 34061e70cfd9..cee98268c862 100644
--- a/chinese/scim-chinese/pkg-plist
+++ b/chinese/scim-chinese/pkg-plist
@@ -2,6 +2,8 @@
etc/gconf/schemas/scim-chinese.schemas
lib/scim-1.0/IMEngine/pinyin.so
lib/scim-1.0/SetupUI/pinyin-imengine-setup.so
+share/locale/ko/LC_MESSAGES/scim-chinese.mo
+share/locale/ja/LC_MESSAGES/scim-chinese.mo
share/locale/zh_CN/LC_MESSAGES/scim-chinese.mo
share/locale/zh_TW/LC_MESSAGES/scim-chinese.mo
share/scim/chinese/phrase_lib
diff --git a/chinese/scim-pinyin/Makefile b/chinese/scim-pinyin/Makefile
index 8fc745bc0915..46f90f1fe69c 100644
--- a/chinese/scim-pinyin/Makefile
+++ b/chinese/scim-pinyin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= scim-chinese
-PORTVERSION= 0.4.1
+PORTVERSION= 0.4.2
CATEGORIES= chinese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://freedesktop.org/~suzhe/scim-chinese/
@@ -30,10 +30,10 @@ CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500035
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/stlport" \
- LDFLAGS="-L${LOCALBASE}/lib -lstlport_gcc -lintl ${PTHREAD_LIBS}"
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/stlport" \
+ LDFLAGS="-L${LOCALBASE}/lib -lstlport_gcc -lintl ${PTHREAD_LIBS}"
EXTRA_PATCHES= ${FILESDIR}/extra-patch-4-stable
.else
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
@@ -43,7 +43,7 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO}
- @${ECHO} To display this message again, type \`make post-install\'
+ @${ECHO} To display this message again, type \`pkg_info -D ${PKGNAME}\'
@${ECHO}
.include <bsd.port.post.mk>
diff --git a/chinese/scim-pinyin/distinfo b/chinese/scim-pinyin/distinfo
index 68b7803e0d66..17d28b3a43b9 100644
--- a/chinese/scim-pinyin/distinfo
+++ b/chinese/scim-pinyin/distinfo
@@ -1,2 +1,2 @@
-MD5 (scim-chinese-0.4.1.tar.gz) = 9df58f1a2fe4b3e2f5893de6d2b8d7a1
-SIZE (scim-chinese-0.4.1.tar.gz) = 4813372
+MD5 (scim-chinese-0.4.2.tar.gz) = 6949d2dd3b408231ebd98a8f0a2dc7c8
+SIZE (scim-chinese-0.4.2.tar.gz) = 4826385
diff --git a/chinese/scim-pinyin/pkg-message b/chinese/scim-pinyin/pkg-message
index 40e04afc9969..9e61f11cd1b4 100644
--- a/chinese/scim-pinyin/pkg-message
+++ b/chinese/scim-pinyin/pkg-message
@@ -1,5 +1,5 @@
--------------------------------------------------------------------
-Remember to set environment varible XMODIFIERS:
+Remember to set environment variable XMODIFIERS:
csh/tcsh: setenv XMODIFIERS @im=SCIM
sh/bash: export XMODIFIERS='@im=SCIM'
@@ -11,7 +11,7 @@ and set LANG, LC_CTYPE to one of the following values:
Traditional Chinese:
zh_TW.UTF-8, zh_TW.Big5
- zh_HK.UTF-8, zh_HK.Big5-HKSCS
+ zh_HK.UTF-8, zh_HK.Big5-HKSCS
To start the SCIM input method daemon, use command:
diff --git a/chinese/scim-pinyin/pkg-plist b/chinese/scim-pinyin/pkg-plist
index 34061e70cfd9..cee98268c862 100644
--- a/chinese/scim-pinyin/pkg-plist
+++ b/chinese/scim-pinyin/pkg-plist
@@ -2,6 +2,8 @@
etc/gconf/schemas/scim-chinese.schemas
lib/scim-1.0/IMEngine/pinyin.so
lib/scim-1.0/SetupUI/pinyin-imengine-setup.so
+share/locale/ko/LC_MESSAGES/scim-chinese.mo
+share/locale/ja/LC_MESSAGES/scim-chinese.mo
share/locale/zh_CN/LC_MESSAGES/scim-chinese.mo
share/locale/zh_TW/LC_MESSAGES/scim-chinese.mo
share/scim/chinese/phrase_lib
diff --git a/chinese/scim-tables/Makefile b/chinese/scim-tables/Makefile
index 9379d6933c96..3a7383721c78 100644
--- a/chinese/scim-tables/Makefile
+++ b/chinese/scim-tables/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= scim-tables
-PORTVERSION= 0.4.1
+PORTVERSION= 0.4.3
CATEGORIES= chinese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://freedesktop.org/~suzhe/sources/
@@ -31,7 +31,7 @@ BROKEN= scim-make-table is not available for 4.x
post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO}
- @${ECHO} To display this message again, type \`make post-install\'
+ @${ECHO} To display this message again, type \`pkg_info -D ${PKGNAME}\'
@${ECHO}
.include <bsd.port.post.mk>
diff --git a/chinese/scim-tables/distinfo b/chinese/scim-tables/distinfo
index e0c32ff6bc4d..b294f62852f6 100644
--- a/chinese/scim-tables/distinfo
+++ b/chinese/scim-tables/distinfo
@@ -1,2 +1,2 @@
-MD5 (scim-tables-0.4.1.tar.gz) = 2d7f35f357b9ff903586b21da59563bd
-SIZE (scim-tables-0.4.1.tar.gz) = 3789238
+MD5 (scim-tables-0.4.3.tar.gz) = c9983d6fdb459dc9d755f1e06fa0849c
+SIZE (scim-tables-0.4.3.tar.gz) = 3789831
diff --git a/chinese/scim-tables/pkg-message b/chinese/scim-tables/pkg-message
index 40e04afc9969..9e61f11cd1b4 100644
--- a/chinese/scim-tables/pkg-message
+++ b/chinese/scim-tables/pkg-message
@@ -1,5 +1,5 @@
--------------------------------------------------------------------
-Remember to set environment varible XMODIFIERS:
+Remember to set environment variable XMODIFIERS:
csh/tcsh: setenv XMODIFIERS @im=SCIM
sh/bash: export XMODIFIERS='@im=SCIM'
@@ -11,7 +11,7 @@ and set LANG, LC_CTYPE to one of the following values:
Traditional Chinese:
zh_TW.UTF-8, zh_TW.Big5
- zh_HK.UTF-8, zh_HK.Big5-HKSCS
+ zh_HK.UTF-8, zh_HK.Big5-HKSCS
To start the SCIM input method daemon, use command:
diff --git a/japanese/scim-tables/Makefile b/japanese/scim-tables/Makefile
index 174c4c390e42..68ce2b1f458b 100644
--- a/japanese/scim-tables/Makefile
+++ b/japanese/scim-tables/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= scim-tables
-PORTVERSION= 0.4.1
+PORTVERSION= 0.4.3
CATEGORIES= japanese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://freedesktop.org/~suzhe/sources/
@@ -31,7 +31,7 @@ BROKEN= scim-make-table is not available for 4.x
post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO}
- @${ECHO} To display this message again, type \`make post-install\'
+ @${ECHO} To display this message again, type \`pkg_info -D ${PKGNAME}\'
@${ECHO}
.include <bsd.port.post.mk>
diff --git a/japanese/scim-tables/distinfo b/japanese/scim-tables/distinfo
index e0c32ff6bc4d..b294f62852f6 100644
--- a/japanese/scim-tables/distinfo
+++ b/japanese/scim-tables/distinfo
@@ -1,2 +1,2 @@
-MD5 (scim-tables-0.4.1.tar.gz) = 2d7f35f357b9ff903586b21da59563bd
-SIZE (scim-tables-0.4.1.tar.gz) = 3789238
+MD5 (scim-tables-0.4.3.tar.gz) = c9983d6fdb459dc9d755f1e06fa0849c
+SIZE (scim-tables-0.4.3.tar.gz) = 3789831
diff --git a/japanese/scim-tables/pkg-message b/japanese/scim-tables/pkg-message
index 40178db272c2..8f85821923d6 100644
--- a/japanese/scim-tables/pkg-message
+++ b/japanese/scim-tables/pkg-message
@@ -1,10 +1,10 @@
--------------------------------------------------------------------
-Remember to set environment varible XMODIFIERS:
+Remember to set environment variable XMODIFIERS:
csh/tcsh: setenv XMODIFIERS @im=SCIM
sh/bash: export XMODIFIERS='@im=SCIM'
-and set LANG, LC_CTYPE to a proper Japanese locale or use scim-setup
+and set LANG, LC_CTYPE to a proper Japanese locale or use scim-setup
utility to configure the supported locale.
To start the SCIM input method daemon, use command:
diff --git a/korean/scim-tables/Makefile b/korean/scim-tables/Makefile
index 078bb2287d2f..46dbf50530c8 100644
--- a/korean/scim-tables/Makefile
+++ b/korean/scim-tables/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= scim-tables
-PORTVERSION= 0.4.1
+PORTVERSION= 0.4.3
CATEGORIES= korean
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://freedesktop.org/~suzhe/sources/
@@ -31,7 +31,7 @@ BROKEN= scim-make-table is not available for 4.x
post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO}
- @${ECHO} To display this message again, type \`make post-install\'
+ @${ECHO} To display this message again, type \`pkg_info -D ${PKGNAME}\'
@${ECHO}
.include <bsd.port.post.mk>
diff --git a/korean/scim-tables/distinfo b/korean/scim-tables/distinfo
index e0c32ff6bc4d..b294f62852f6 100644
--- a/korean/scim-tables/distinfo
+++ b/korean/scim-tables/distinfo
@@ -1,2 +1,2 @@
-MD5 (scim-tables-0.4.1.tar.gz) = 2d7f35f357b9ff903586b21da59563bd
-SIZE (scim-tables-0.4.1.tar.gz) = 3789238
+MD5 (scim-tables-0.4.3.tar.gz) = c9983d6fdb459dc9d755f1e06fa0849c
+SIZE (scim-tables-0.4.3.tar.gz) = 3789831
diff --git a/korean/scim-tables/pkg-message b/korean/scim-tables/pkg-message
index dae9ab9ba19c..633c2e665440 100644
--- a/korean/scim-tables/pkg-message
+++ b/korean/scim-tables/pkg-message
@@ -1,10 +1,10 @@
--------------------------------------------------------------------
-Remember to set environment varible XMODIFIERS:
+Remember to set environment variable XMODIFIERS:
csh/tcsh: setenv XMODIFIERS @im=SCIM
sh/bash: export XMODIFIERS='@im=SCIM'
-and set LANG, LC_CTYPE to a proper Korean locale or use scim-setup
+and set LANG, LC_CTYPE to a proper Korean locale or use scim-setup
utility to configure the supported locale.
To start the SCIM input method daemon, use command:
diff --git a/textproc/scim/Makefile b/textproc/scim/Makefile
index 80316b79c437..fad7bea54f2b 100644
--- a/textproc/scim/Makefile
+++ b/textproc/scim/Makefile
@@ -6,11 +6,12 @@
#
PORTNAME= scim
-PORTVERSION= 0.99.6
+PORTVERSION= 1.0.0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://freedesktop.org/~suzhe/sources/
MASTER_SITE_SUBDIR=scim
+
MAINTAINER= gaoj@cpsc.ucalgary.ca
COMMENT= Smart Common Input Method platform
@@ -28,10 +29,10 @@ CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500035
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/stlport" \
- LDFLAGS="-L${LOCALBASE}/lib -lstlport_gcc -lintl ${PTHREAD_LIBS}"
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/stlport" \
+ LDFLAGS="-L${LOCALBASE}/lib -lstlport_gcc -lintl ${PTHREAD_LIBS}"
EXTRA_PATCHES= ${FILESDIR}/extra-patch-4-stable
PLIST_SUB= NOSTABLE="@comment "
.else
@@ -48,6 +49,6 @@ post-configure:
post-install:
@${CAT} ${PKGMESSAGE}
- @${ECHO} To display this message again, type make post-install
+ @${ECHO} To display this message again, type pkg_info -D ${PKGNAME}
.include <bsd.port.post.mk>
diff --git a/textproc/scim/distinfo b/textproc/scim/distinfo
index 1eb0382c7e86..067851884f0e 100644
--- a/textproc/scim/distinfo
+++ b/textproc/scim/distinfo
@@ -1,2 +1,2 @@
-MD5 (scim-0.99.6.tar.gz) = df8c165c4340427ac57687c141fc36b2
-SIZE (scim-0.99.6.tar.gz) = 2254643
+MD5 (scim-1.0.0.tar.gz) = 810741700b2ea73467eb3de6b61f3330
+SIZE (scim-1.0.0.tar.gz) = 2309045
diff --git a/textproc/scim/pkg-plist b/textproc/scim/pkg-plist
index e71388829854..5afe14c87deb 100644
--- a/textproc/scim/pkg-plist
+++ b/textproc/scim/pkg-plist
@@ -2,7 +2,7 @@ bin/scim
bin/scim-config-agent
%%NOSTABLE%%bin/scim-make-table
bin/scim-setup
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/scim.schemas >/dev/null || /usr/bin/true
+@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/scim.schemas >/dev/null 2>&1 || /usr/bin/true
etc/gconf/schemas/scim.schemas
etc/scim/config
etc/scim/global
@@ -63,26 +63,28 @@ libdata/pkgconfig/scim-gtkutils.pc
libdata/pkgconfig/scim.pc
share/applications/scim-setup.desktop
share/control-center-2.0/capplets/scim-setup.desktop
+share/locale/de/LC_MESSAGES/scim.mo
+share/locale/ja/LC_MESSAGES/scim.mo
+share/locale/ko/LC_MESSAGES/scim.mo
share/locale/zh_CN/LC_MESSAGES/scim.mo
share/locale/zh_TW/LC_MESSAGES/scim.mo
-share/locale/ja/LC_MESSAGES/scim.mo
share/pixmaps/scim-setup.png
-share/scim/icons/down.png
-share/scim/icons/full-letter.png
-share/scim/icons/full-punct.png
-share/scim/icons/half-letter.png
-share/scim/icons/half-punct.png
-share/scim/icons/help.png
-share/scim/icons/keyboard.png
-share/scim/icons/left.png
-share/scim/icons/pin-down.png
-share/scim/icons/pin-up.png
-share/scim/icons/rawcode.png
-share/scim/icons/right.png
-share/scim/icons/setup.png
-share/scim/icons/table.png
-share/scim/icons/trademark.png
-share/scim/icons/up.png
+%%DATADIR%%/icons/down.png
+%%DATADIR%%/icons/full-letter.png
+%%DATADIR%%/icons/full-punct.png
+%%DATADIR%%/icons/half-letter.png
+%%DATADIR%%/icons/half-punct.png
+%%DATADIR%%/icons/help.png
+%%DATADIR%%/icons/keyboard.png
+%%DATADIR%%/icons/left.png
+%%DATADIR%%/icons/pin-down.png
+%%DATADIR%%/icons/pin-up.png
+%%DATADIR%%/icons/rawcode.png
+%%DATADIR%%/icons/right.png
+%%DATADIR%%/icons/setup.png
+%%DATADIR%%/icons/table.png
+%%DATADIR%%/icons/trademark.png
+%%DATADIR%%/icons/up.png
@dirrm etc/scim
@dirrm include/scim-1.0/gtk
@dirrm include/scim-1.0
@@ -95,7 +97,7 @@ share/scim/icons/up.png
@dirrm lib/scim-1.0
@dirrm share/control-center-2.0/capplets
@dirrm share/control-center-2.0
-@dirrm share/pixmaps
-@dirrm share/scim/icons
-@dirrm share/scim
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/scim.schemas >/dev/null || /usr/bin/true
+@unexec rmdir %D/share/pixmaps 2>/dev/null || true
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%
+@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/scim.schemas >/dev/null 2>&1 || /usr/bin/true
diff --git a/textproc/skim/Makefile b/textproc/skim/Makefile
index ce5ef872de6d..585f80e9d633 100644
--- a/textproc/skim/Makefile
+++ b/textproc/skim/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= skim
-PORTVERSION= 0.9.5
+PORTVERSION= 1.0.0
CATEGORIES= textproc kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://freedesktop.org/~cougar/skim/downloads/
-MASTER_SITE_SUBDIR= scim
+MASTER_SITE_SUBDIR= scim
MAINTAINER= gaoj@cpsc.ucalgary.ca
COMMENT= An input method platform based on SCIM library and KDE/QT
@@ -18,10 +18,11 @@ COMMENT= An input method platform based on SCIM library and KDE/QT
LIB_DEPENDS= scim-1.0.5:${PORTSDIR}/textproc/scim
USE_KDELIBS_VER=3
+USE_BZIP2= yes
USE_ICONV= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-GNU_CONFIGURE= yes
+USE_INC_LIBTOOL_VER= 15
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
@@ -29,14 +30,15 @@ CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500035
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-CONFIGURE_ENV+= CXXFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/stlport" \
- LDFLAGS="-L${LOCALBASE}/lib -lstlport_gcc -lintl ${PTHREAD_LIBS}"
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+CONFIGURE_ENV+= CXXFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/stlport ${CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib -lstlport_gcc -lintl ${PTHREAD_LIBS}"
.else
-CONFIGURE_ENV+= CXXFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
+CONFIGURE_ENV+= CXXFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__ ${CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
.endif
+
pre-configure:
${REINPLACE_CMD} "s,-pedantic,,g; \
s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
@@ -44,6 +46,6 @@ pre-configure:
post-install:
@${CAT} ${PKGMESSAGE}
- @${ECHO} To display this message again, type make post-install
+ @${ECHO} To display this message again, type pkg_info -D ${PKGNAME}
.include <bsd.port.post.mk>
diff --git a/textproc/skim/distinfo b/textproc/skim/distinfo
index 7750f39a50f0..5ae9045c13d3 100644
--- a/textproc/skim/distinfo
+++ b/textproc/skim/distinfo
@@ -1,2 +1,2 @@
-MD5 (skim-0.9.5.tar.gz) = 7cf8e5c56f915f6a8c804d182a541ec9
-SIZE (skim-0.9.5.tar.gz) = 879867
+MD5 (skim-1.0.0.tar.bz2) = 82941ec52b29c850b01f870a8d070da4
+SIZE (skim-1.0.0.tar.bz2) = 1413327
diff --git a/textproc/skim/pkg-message b/textproc/skim/pkg-message
index 64eacb808427..a1b31e586427 100644
--- a/textproc/skim/pkg-message
+++ b/textproc/skim/pkg-message
@@ -3,20 +3,20 @@ The installation of skim has finished. You can find correponding menu items in
KDE's menu and Control Center.
Please note this port contains only KDE/QT frontends and utilities to the SCIM
-platform. If you want to use any actual input method, please install the
+platform. If you want to use any actual input method, please install the
following ports as needed:
Chinese:
chinese/scim-tables Table based input methods: Array30, CangJie, Cantonese,
Dayi, Erbi, EZ, Jyutping, Simplex, Wubi, Ziranma, ZhuYin
chinese/scim-chinese Smart pinyin
-
+
Korean:
korean/scim-tables Table based input methods: Hangul, Hanja
Japanese:
japanese/scim-tables Table based input methods: HIRAGANA, KATAKANA, Nippon
-You can use the command `skim' to start after properly setting SCIM (please
+You can use the command `skim' to start after properly setting SCIM (please
refer to the message displayed by scim installation).
------------------------------------------------------------------------------
diff --git a/textproc/skim/pkg-plist b/textproc/skim/pkg-plist
index a10c3f812f33..c62dac67dc4e 100644
--- a/textproc/skim/pkg-plist
+++ b/textproc/skim/pkg-plist
@@ -2,12 +2,14 @@ bin/skim
bin/scim-panel-kde
lib/kde3/kcm_skimplugin_configplugin.la
lib/kde3/kcm_skimplugin_configplugin.so
-lib/kde3/kcm_skimplugin_scim_global.la
-lib/kde3/kcm_skimplugin_scim_global.so
lib/kde3/kcm_skimplugin_inputwindow.la
lib/kde3/kcm_skimplugin_inputwindow.so
lib/kde3/kcm_skimplugin_mainwindow.la
lib/kde3/kcm_skimplugin_mainwindow.so
+lib/kde3/kcm_skimplugin_scim_global.la
+lib/kde3/kcm_skimplugin_scim_global.so
+lib/kde3/kcm_skimplugin_scim_hangul.la
+lib/kde3/kcm_skimplugin_scim_hangul.so
lib/kde3/kcm_skimplugin_scim_imengines.la
lib/kde3/kcm_skimplugin_scim_imengines.so
lib/kde3/kcm_skimplugin_scim_qtimm.la
@@ -30,39 +32,78 @@ lib/kde3/skimplugin_setupwindow.la
lib/kde3/skimplugin_setupwindow.so
lib/kde3/skimplugin_systemtray.la
lib/kde3/skimplugin_systemtray.so
-lib/skim/libscim-kdeutils.la
-lib/skim/libscim-kdeutils.so
-lib/skim/libscim-kdeutils.so.0
-lib/skim/libskim.la
-lib/skim/libskim.so
-lib/skim/libskim.so.0
+lib/libscim-kdeutils.la
+lib/libscim-kdeutils.so
+lib/libscim-kdeutils.so.0
+lib/libskim.la
+lib/libskim.so
+lib/libskim.so.0
share/applnk/Utilities/skim.desktop
share/apps/skim/mainwindowui.rc
-share/apps/skim/pics/full_width_letter.png
-share/apps/skim/pics/full_width_punct.png
-share/apps/skim/pics/half_width_letter.png
-share/apps/skim/pics/half_width_punct.png
-share/apps/skim/pics/keyboard.png
share/apps/skim/pics/pin_down.png
share/apps/skim/pics/pin_up.png
-share/apps/skim/pics/skim.png
+share/apps/skim/pics/scim_help.png
share/config.kcfg/generictable.kcfg
share/config.kcfg/qtimm.kcfg
+share/config.kcfg/scim_hangul.kcfg
share/config.kcfg/scimkdeconfig.kcfg
share/config.kcfg/smartpinyin.kcfg
-share/doc/HTML/en/skim/common
-share/doc/HTML/en/skim/index.cache.bz2
-share/doc/HTML/en/skim/index.docbook
-share/doc/HTML/en/skim/inputwindow.png
+share/doc/HTML/de/skim/skim_configuration110.png
+share/doc/HTML/de/skim/skim_configuration111.png
+share/doc/HTML/de/skim/skim_configuration112.png
+share/doc/HTML/de/skim/skim_contextmenu.png
+share/doc/HTML/de/skim/skim_configuration10.png
+share/doc/HTML/de/skim/skim_configuration11.png
+share/doc/HTML/de/skim/skim_configuration12.png
+share/doc/HTML/de/skim/skim_configuration13.png
+share/doc/HTML/de/skim/skim_configuration14.png
+share/doc/HTML/de/skim/skim_configuration15.png
+share/doc/HTML/de/skim/skim_configuration16.png
+share/doc/HTML/de/skim/skim_configuration17.png
+share/doc/HTML/de/skim/skim_configuration18.png
+share/doc/HTML/de/skim/skim01a.png
+share/doc/HTML/de/skim/skim_configuration19.png
+share/doc/HTML/de/skim/skim_choose_ime.png
+share/doc/HTML/de/skim/skim_toolbar1.png
+share/doc/HTML/de/skim/skim_toolbar3.png
+share/doc/HTML/de/skim/skim_toolbar4.png
+share/doc/HTML/de/skim/skim_toolbar6.png
+share/doc/HTML/de/skim/skim_toolbar8.png
+share/doc/HTML/de/skim/skim02a.png
+share/doc/HTML/de/skim/skim04a.png
+share/doc/HTML/de/skim/skim_configuration1.png
+share/doc/HTML/de/skim/skim_configuration2.png
+share/doc/HTML/de/skim/skim_configuration3.png
+share/doc/HTML/de/skim/skim_configuration4.png
+share/doc/HTML/de/skim/skim_configuration5.png
+share/doc/HTML/de/skim/skim_configuration6.png
+share/doc/HTML/de/skim/skim_configuration7.png
+share/doc/HTML/de/skim/skim_configuration8.png
+share/doc/HTML/de/skim/skim_configuration9.png
+share/doc/HTML/de/skim/index.docbook
+share/doc/HTML/de/skim/skim24c.png
+share/doc/HTML/de/skim/index.cache.bz2
+share/doc/HTML/de/skim/common
share/doc/HTML/en/skim/kdesystray.png
-share/doc/HTML/en/skim/kdex.dtd
-share/doc/HTML/en/skim/mainwindow.png
share/doc/HTML/en/skim/setupwindow.png
+share/doc/HTML/en/skim/inputwindow.png
+share/doc/HTML/en/skim/index.docbook
+share/doc/HTML/en/skim/mainwindow.png
+share/doc/HTML/en/skim/index.cache.bz2
+share/doc/HTML/en/skim/common
+share/doc/HTML/skim/kdex.dtd
+share/icons/crystalsvg/32x32/apps/skim.png
+share/icons/crystalsvg/scalable/apps/skim.svgz
+share/locale/de/LC_MESSAGES/skim.mo
+share/locale/ja/LC_MESSAGES/skim.mo
+share/locale/ko/LC_MESSAGES/skim.mo
share/locale/zh_CN/LC_MESSAGES/skim.mo
+share/locale/zh_TW/LC_MESSAGES/skim.mo
share/services/skimconfiguredialog/kcm_skimplugin_configplugin_config.desktop
-share/services/skimconfiguredialog/skimplugin_scim_global_config.desktop
share/services/skimconfiguredialog/skimplugin_inputwindow_config.desktop
share/services/skimconfiguredialog/skimplugin_mainwindow_config.desktop
+share/services/skimconfiguredialog/skimplugin_scim_global_config.desktop
+share/services/skimconfiguredialog/skimplugin_scim_hangul_config.desktop
share/services/skimconfiguredialog/skimplugin_scim_imengines_config.desktop
share/services/skimconfiguredialog/skimplugin_scim_qtimm_config.desktop
share/services/skimconfiguredialog/skimplugin_scim_smartpinyin_config.desktop
@@ -74,6 +115,7 @@ share/services/skimplugin_mainwindow.desktop
share/services/skimplugin_scim.desktop
share/services/skimplugin_setupwindow.desktop
share/services/skimplugin_systemtray.desktop
+share/servicetypes/skimkcmplugin.desktop
share/servicetypes/skimplugin.desktop
share/servicetypes/skimui.desktop
@cwd %%X11BASE%%
@@ -83,6 +125,7 @@ lib/scim-1.0/1.0.0/Config/kconfig.so.0
@cwd %%LOCALBASE%%
@dirrm share/services/skimconfiguredialog
@dirrm share/doc/HTML/en/skim
+@dirrm share/doc/HTML/de/skim
+@dirrm share/doc/HTML/skim
@dirrm share/apps/skim/pics
@dirrm share/apps/skim
-@dirrm lib/skim