aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/libcerf/Makefile23
-rw-r--r--math/libcerf/distinfo3
-rw-r--r--math/libcerf/pkg-descr3
-rw-r--r--math/libcerf/pkg-plist21
5 files changed, 51 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 45f67ab3a56b..519125e2796d 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -437,6 +437,7 @@
SUBDIR += libRmath
SUBDIR += libbraiding
SUBDIR += libccd
+ SUBDIR += libcerf
SUBDIR += libdivide
SUBDIR += libfixmath
SUBDIR += libflame
diff --git a/math/libcerf/Makefile b/math/libcerf/Makefile
new file mode 100644
index 000000000000..27c493d89b60
--- /dev/null
+++ b/math/libcerf/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= libcerf
+DISTVERSION= 2.3
+CATEGORIES= math
+MASTER_SITES= https://jugit.fz-juelich.de/mlz/libcerf/-/archive/v${DISTVERSION}/
+DISTNAME= ${PORTNAME}-v${DISTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library that provides an implementation of complex error functions
+WWW= https://jugit.fz-juelich.de/mlz/libcerf/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake:testing perl5
+USE_PERL5= build
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= DOCS
+
+DOCSDIR= ${PREFIX}/share/doc/cerf # docs are installed with the same option and man pages
+PORTDOCS= *
+
+.include <bsd.port.mk>
diff --git a/math/libcerf/distinfo b/math/libcerf/distinfo
new file mode 100644
index 000000000000..438554e5337c
--- /dev/null
+++ b/math/libcerf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1674542525
+SHA256 (libcerf-v2.3.tar.gz) = cceefee46e84ce88d075103390b4f9d04c34e4bc3b96d733292c36836d4f7065
+SIZE (libcerf-v2.3.tar.gz) = 91314
diff --git a/math/libcerf/pkg-descr b/math/libcerf/pkg-descr
new file mode 100644
index 000000000000..dc20dcafaac0
--- /dev/null
+++ b/math/libcerf/pkg-descr
@@ -0,0 +1,3 @@
+libcerf is a self-contained numeric library that provides an efficient and
+accurate implementation of complex error functions, along with Dawson,
+Faddeeva, and Voigt functions.
diff --git a/math/libcerf/pkg-plist b/math/libcerf/pkg-plist
new file mode 100644
index 000000000000..62c4ab5c831c
--- /dev/null
+++ b/math/libcerf/pkg-plist
@@ -0,0 +1,21 @@
+include/cerf.h
+lib/cmake/cerf/cerfConfig.cmake
+lib/cmake/cerf/cerfConfigVersion.cmake
+lib/cmake/cerf/cerfTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/cerf/cerfTargets.cmake
+lib/libcerf.so
+lib/libcerf.so.2
+lib/libcerf.so.2.3
+libdata/pkgconfig/libcerf.pc
+share/man/man3/cdawson.3.gz
+share/man/man3/cerf.3.gz
+share/man/man3/cerfc.3.gz
+share/man/man3/cerfcx.3.gz
+share/man/man3/cerfi.3.gz
+share/man/man3/dawson.3.gz
+share/man/man3/erfcx.3.gz
+share/man/man3/erfi.3.gz
+share/man/man3/im_w_of_z.3.gz
+share/man/man3/voigt.3.gz
+share/man/man3/voigt_hwhm.3.gz
+share/man/man3/w_of_z.3.gz