aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/cpprestsdk/Makefile4
-rw-r--r--devel/cpprestsdk/files/patch-src_CMakeLists.txt11
2 files changed, 1 insertions, 14 deletions
diff --git a/devel/cpprestsdk/Makefile b/devel/cpprestsdk/Makefile
index a28cdac6f76d..e93798effc69 100644
--- a/devel/cpprestsdk/Makefile
+++ b/devel/cpprestsdk/Makefile
@@ -18,9 +18,7 @@ USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= Microsoft
WRKSRC_SUBDIR= Release
-CMAKE_OFF= BUILD_SAMPLES BUILD_TESTS
-
-CXXFLAGS+= -Wno-c11-extensions
+CMAKE_OFF= BUILD_SAMPLES BUILD_TESTS WERROR
OPTIONS_DEFINE= BROTLI
diff --git a/devel/cpprestsdk/files/patch-src_CMakeLists.txt b/devel/cpprestsdk/files/patch-src_CMakeLists.txt
deleted file mode 100644
index b99d076519df..000000000000
--- a/devel/cpprestsdk/files/patch-src_CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/CMakeLists.txt.orig 2022-10-06 15:08:19 UTC
-+++ src/CMakeLists.txt
-@@ -187,7 +187,7 @@ configure_pch(cpprest stdafx.h pch/stdafx.cpp /Zm120)
-
- if(CMAKE_CXX_COMPILER_ID MATCHES "Clang" OR CMAKE_CXX_COMPILER_ID MATCHES "GNU")
- if(WERROR)
-- target_compile_options(cpprest PRIVATE -Werror)
-+ target_compile_options(cpprest PRIVATE -Wno-error)
- endif()
- target_compile_options(cpprest PRIVATE -pedantic ${WARNINGS})
- elseif(CMAKE_CXX_COMPILER_ID MATCHES "MSVC")