aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2022-10-08 18:51:40 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2022-10-08 18:51:40 +0000
commit0c34c5fd80f37c4d802092c9768cf272754dd9ab (patch)
treec828a750cdf2f20dc4297944eef3ac8f76c1390f
parent2331f637a405403428e1d8a954d9cbf620cbfc51 (diff)
downloadports-0c34c5fd80f37c4d802092c9768cf272754dd9ab.tar.gz
ports-0c34c5fd80f37c4d802092c9768cf272754dd9ab.zip
devel/cpprestsdk: purge bogus patch file and unset WERROR instead
While here, remove needless -Wno-c11-extensions from the CXXFLAGS.
-rw-r--r--devel/cpprestsdk/Makefile4
-rw-r--r--devel/cpprestsdk/files/patch-src_CMakeLists.txt11
2 files changed, 1 insertions, 14 deletions
diff --git a/devel/cpprestsdk/Makefile b/devel/cpprestsdk/Makefile
index a28cdac6f76d..e93798effc69 100644
--- a/devel/cpprestsdk/Makefile
+++ b/devel/cpprestsdk/Makefile
@@ -18,9 +18,7 @@ USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= Microsoft
WRKSRC_SUBDIR= Release
-CMAKE_OFF= BUILD_SAMPLES BUILD_TESTS
-
-CXXFLAGS+= -Wno-c11-extensions
+CMAKE_OFF= BUILD_SAMPLES BUILD_TESTS WERROR
OPTIONS_DEFINE= BROTLI
diff --git a/devel/cpprestsdk/files/patch-src_CMakeLists.txt b/devel/cpprestsdk/files/patch-src_CMakeLists.txt
deleted file mode 100644
index b99d076519df..000000000000
--- a/devel/cpprestsdk/files/patch-src_CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/CMakeLists.txt.orig 2022-10-06 15:08:19 UTC
-+++ src/CMakeLists.txt
-@@ -187,7 +187,7 @@ configure_pch(cpprest stdafx.h pch/stdafx.cpp /Zm120)
-
- if(CMAKE_CXX_COMPILER_ID MATCHES "Clang" OR CMAKE_CXX_COMPILER_ID MATCHES "GNU")
- if(WERROR)
-- target_compile_options(cpprest PRIVATE -Werror)
-+ target_compile_options(cpprest PRIVATE -Wno-error)
- endif()
- target_compile_options(cpprest PRIVATE -pedantic ${WARNINGS})
- elseif(CMAKE_CXX_COMPILER_ID MATCHES "MSVC")