aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pytest-regtest/Makefile23
-rw-r--r--devel/py-pytest-regtest/distinfo3
-rw-r--r--devel/py-pytest-regtest/pkg-descr10
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d21fd12b32e0..0692fe98d31e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5034,6 +5034,7 @@
SUBDIR += py-pytest-pycodestyle
SUBDIR += py-pytest-randomly
SUBDIR += py-pytest-regressions
+ SUBDIR += py-pytest-regtest
SUBDIR += py-pytest-relaxed
SUBDIR += py-pytest-rerunfailures
SUBDIR += py-pytest-runner
diff --git a/devel/py-pytest-regtest/Makefile b/devel/py-pytest-regtest/Makefile
new file mode 100644
index 000000000000..52393f644879
--- /dev/null
+++ b/devel/py-pytest-regtest/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= pytest-regtest
+PORTVERSION= 1.4.6
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Pytest plugin for regression tests
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+do-test:
+ @cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest -v -rs
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytest-regtest/distinfo b/devel/py-pytest-regtest/distinfo
new file mode 100644
index 000000000000..1c7af2eea298
--- /dev/null
+++ b/devel/py-pytest-regtest/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1633617306
+SHA256 (pytest-regtest-1.4.6.tar.gz) = 4c85a1d1f99f4ebe4932b33bff950de364dcac543ce88c7bef295a5d1f10a40f
+SIZE (pytest-regtest-1.4.6.tar.gz) = 10182
diff --git a/devel/py-pytest-regtest/pkg-descr b/devel/py-pytest-regtest/pkg-descr
new file mode 100644
index 000000000000..2af1a5a1f90f
--- /dev/null
+++ b/devel/py-pytest-regtest/pkg-descr
@@ -0,0 +1,10 @@
+pytest-regtest is a pytest-plugin for implementing regression tests.
+Compared to functional testing a regression test does not test if
+software produces correct results, instead a regression test checks
+if software behaves the same way as it did before introduced changes.
+
+pytest-regtest allows capturing selected output which then can be
+compared to the captured output from former runs.
+
+WWW: https://pypi.org/project/pytest-regtest/
+WWW: https://gitlab.com/uweschmitt/pytest-regtest