aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/viruskiller/Makefile39
-rw-r--r--games/viruskiller/distinfo3
-rw-r--r--games/viruskiller/pkg-descr9
-rw-r--r--games/viruskiller/pkg-plist28
5 files changed, 80 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index e6fdb44422f9..7f2b06928198 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -919,6 +919,7 @@
SUBDIR += vegastrike
SUBDIR += vegastrike-data
SUBDIR += violetland
+ SUBDIR += viruskiller
SUBDIR += vitetris
SUBDIR += volleyball
SUBDIR += vor
diff --git a/games/viruskiller/Makefile b/games/viruskiller/Makefile
new file mode 100644
index 000000000000..835a7616447c
--- /dev/null
+++ b/games/viruskiller/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: viruskiller
+# Date created: 2010-08-16
+# Whom: markand
+#
+# $FreeBSD$
+#
+
+PORTNAME= viruskiller
+PORTVERSION= 1.03
+CATEGORIES= games
+MASTER_SITES= http://www.parallelrealities.co.uk/download/viruskiller/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-1
+
+MAINTAINER= markand@malikania.fr
+COMMENT= An arcade game that relies on quick reflexes
+
+LICENSE= GPLv2
+
+USE_SDL= mixer image ttf net
+USE_GMAKE= yes
+
+INSTALLS_ICONS= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAKEFILE= makefile
+
+post-patch:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e "s|^.*install.*DOCS.*||g" \
+ -e "s|^.*mkdir.*DOCDIR.*||g" \
+ ${WRKSRC}/makefile
+.endif
+ @${REINPLACE_CMD} -e "s|^PREFIX.*|PREFIX=${PREFIX}|g" \
+ -e "s|^BINDIR.*|BINDIR=${PREFIX}/bin/|g" \
+ -e "s|^DATADIR.*|DATADIR=${DATADIR}/|g" \
+ -e "s|^DOCDIR.*|DOCDIR=${DOCSDIR}|g" ${WRKSRC}/makefile
+
+.include <bsd.port.mk>
diff --git a/games/viruskiller/distinfo b/games/viruskiller/distinfo
new file mode 100644
index 000000000000..9315bd79db25
--- /dev/null
+++ b/games/viruskiller/distinfo
@@ -0,0 +1,3 @@
+MD5 (viruskiller-1.03-1.tar.gz) = ac74f8a49d249a87e3e77cadd9aa6fa9
+SHA256 (viruskiller-1.03-1.tar.gz) = c6421df23a5c1f677fa6effc72a4723f913dc08addd48de76ca031bbd6d5bd76
+SIZE (viruskiller-1.03-1.tar.gz) = 4446649
diff --git a/games/viruskiller/pkg-descr b/games/viruskiller/pkg-descr
new file mode 100644
index 000000000000..5efeee5ac3bc
--- /dev/null
+++ b/games/viruskiller/pkg-descr
@@ -0,0 +1,9 @@
+Your computer has been invaded! Dozens of little viruses are pouring in via
+security holes in Microsoft Internet Explorer, Microsoft Outlook, Microsoft MSN
+Messenger and Microsoft Recycle Bin!! Using your trusty mouse you must shoot the
+buggers before they can destroy your files! Some will steal them from their home
+directories and take them back to their security hole. Others will just eat them
+right there on the spot! See how long you and your computer can survive the
+onslaught!
+
+WWW: http://www.parallelrealities.co.uk/projects/virusKiller.php
diff --git a/games/viruskiller/pkg-plist b/games/viruskiller/pkg-plist
new file mode 100644
index 000000000000..f3fbf49e873e
--- /dev/null
+++ b/games/viruskiller/pkg-plist
@@ -0,0 +1,28 @@
+bin/viruskiller
+%%DATADIR%%/viruskiller.pak
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/battery.png
+%%PORTDOCS%%%%DOCSDIR%%/bomb.png
+%%PORTDOCS%%%%DOCSDIR%%/clock.png
+%%PORTDOCS%%%%DOCSDIR%%/manual.html
+%%PORTDOCS%%%%DOCSDIR%%/title.png
+%%PORTDOCS%%%%DOCSDIR%%/virus1.gif
+%%PORTDOCS%%%%DOCSDIR%%/virus2.gif
+%%PORTDOCS%%%%DOCSDIR%%/virus3.gif
+share/icons/hicolor/16x16/apps/viruskiller.png
+share/icons/hicolor/32x32/apps/viruskiller.png
+share/icons/hicolor/64x64/apps/viruskiller.png
+share/applications/viruskiller.desktop
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry %%DATADIR%%
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications
+