aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/py-johnnydep/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/devel/py-johnnydep/Makefile b/devel/py-johnnydep/Makefile
index 199ba8f1ebb3..6736802b5394 100644
--- a/devel/py-johnnydep/Makefile
+++ b/devel/py-johnnydep/Makefile
@@ -1,5 +1,6 @@
PORTNAME= johnnydep
PORTVERSION= 1.20.4
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,6 +12,8 @@ WWW= https://github.com/wimglenn/johnnydep
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}anytree>=0:devel/py-anytree@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cachetools>=0:devel/py-cachetools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}oyaml>=0:devel/py-oyaml@${PY_FLAVOR} \
@@ -23,7 +26,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}anytree>=0:devel/py-anytree@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wimpy>=0:devel/py-wimpy@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes