aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/p5-BBS-UserInfo-Ptt/Makefile3
-rw-r--r--net/p5-BBS-UserInfo/Makefile3
-rw-r--r--net/p5-IO-Socket-Multicast6/Makefile3
-rw-r--r--net/p5-Net-Amazon-EC2/Makefile3
-rw-r--r--net/p5-Net-Google-AuthSub/Makefile3
-rw-r--r--net/p5-Net-Google-Spreadsheets/Makefile3
-rw-r--r--net/p5-Net-IPTrie/Makefile3
-rw-r--r--net/p5-Net-LDAP-AutoDNs/Makefile3
-rw-r--r--net/p5-Net-LDAP-Express/Makefile3
-rw-r--r--net/p5-Net-Rendezvous-Publish/Makefile3
-rw-r--r--net/p5-Net-Rsh/Makefile3
-rw-r--r--net/p5-Net-SSH-Mechanize/Makefile3
-rw-r--r--net/p5-POEx-Role-TCPServer/Makefile3
-rw-r--r--net/p5-RPC-Simple/Makefile3
-rw-r--r--net/p5-Sort-Key-IPv4/Makefile3
-rw-r--r--net/p5-What/Makefile3
-rw-r--r--net/p5-XML-RPC/Makefile3
-rw-r--r--ports-mgmt/p5-FreeBSD-Pkgs/Makefile3
-rw-r--r--ports-mgmt/pkg_tree/Makefile2
19 files changed, 37 insertions, 19 deletions
diff --git a/net/p5-BBS-UserInfo-Ptt/Makefile b/net/p5-BBS-UserInfo-Ptt/Makefile
index 0701b4c7a4fc..89d91a4a48ca 100644
--- a/net/p5-BBS-UserInfo-Ptt/Makefile
+++ b/net/p5-BBS-UserInfo-Ptt/Makefile
@@ -17,7 +17,8 @@ COMMENT= Get user information of PTT-style BBS
RUN_DEPENDS= p5-Expect>=0:${PORTSDIR}/lang/p5-Expect
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= BBS::UserInfo::Ptt.3
diff --git a/net/p5-BBS-UserInfo/Makefile b/net/p5-BBS-UserInfo/Makefile
index 9658af5971ca..7676b0cb454b 100644
--- a/net/p5-BBS-UserInfo/Makefile
+++ b/net/p5-BBS-UserInfo/Makefile
@@ -15,7 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Base class of BBS::UserInfo::XXX
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= BBS::UserInfo.3
diff --git a/net/p5-IO-Socket-Multicast6/Makefile b/net/p5-IO-Socket-Multicast6/Makefile
index e71cd14b6784..f33df021dbbc 100644
--- a/net/p5-IO-Socket-Multicast6/Makefile
+++ b/net/p5-IO-Socket-Multicast6/Makefile
@@ -21,7 +21,8 @@ BUILD_DEPENDS= p5-IO-Interface>=1.01:${PORTSDIR}/net/p5-IO-Interface \
p5-Socket6>=0.19:${PORTSDIR}/net/p5-Socket6
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= IO::Socket::Multicast6.3
diff --git a/net/p5-Net-Amazon-EC2/Makefile b/net/p5-Net-Amazon-EC2/Makefile
index 038c242e557f..4d92ac2d2b67 100644
--- a/net/p5-Net-Amazon-EC2/Makefile
+++ b/net/p5-Net-Amazon-EC2/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
BUILD_DEPENDS:= ${RUN_DEPENDS} \
p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Amazon::EC2.3 \
Net::Amazon::EC2::Attachment.3 \
diff --git a/net/p5-Net-Google-AuthSub/Makefile b/net/p5-Net-Google-AuthSub/Makefile
index e5f4af658d00..e448cf0132d4 100644
--- a/net/p5-Net-Google-AuthSub/Makefile
+++ b/net/p5-Net-Google-AuthSub/Makefile
@@ -18,7 +18,8 @@ COMMENT= Interact with sites that implement Google style AuthSub
RUN_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Google::AuthSub::Response.3 \
Net::Google::AuthSub.3
diff --git a/net/p5-Net-Google-Spreadsheets/Makefile b/net/p5-Net-Google-Spreadsheets/Makefile
index 1422ace12dd8..50cc6e1feeb1 100644
--- a/net/p5-Net-Google-Spreadsheets/Makefile
+++ b/net/p5-Net-Google-Spreadsheets/Makefile
@@ -27,7 +27,8 @@ TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-MockModule>=0:${PORTSDIR}/devel/p5-Test-MockModule \
p5-Test-MockObject>=0:${PORTSDIR}/devel/p5-Test-MockObject
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Google::Spreadsheets.3 \
Net::Google::Spreadsheets::Cell.3 \
diff --git a/net/p5-Net-IPTrie/Makefile b/net/p5-Net-IPTrie/Makefile
index 0bb1d81a7b79..54c7586d8b3c 100644
--- a/net/p5-Net-IPTrie/Makefile
+++ b/net/p5-Net-IPTrie/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-NetAddr-IP>=4.00.7:${PORTSDIR}/net-mgmt/p5-NetAddr-IP \
p5-version>=0:${PORTSDIR}/devel/p5-version
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Net::IPTrie.3 Net::IPTrie::Node.3
diff --git a/net/p5-Net-LDAP-AutoDNs/Makefile b/net/p5-Net-LDAP-AutoDNs/Makefile
index 4309deaa95cb..8aeea5bb2771 100644
--- a/net/p5-Net-LDAP-AutoDNs/Makefile
+++ b/net/p5-Net-LDAP-AutoDNs/Makefile
@@ -15,7 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= vvelox@vvelox.net
COMMENT= Automatically make some default decisions some LDAP DNs and scopes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::LDAP::AutoDNs.3
diff --git a/net/p5-Net-LDAP-Express/Makefile b/net/p5-Net-LDAP-Express/Makefile
index 012499bc3e82..09856afcffc7 100644
--- a/net/p5-Net-LDAP-Express/Makefile
+++ b/net/p5-Net-LDAP-Express/Makefile
@@ -18,7 +18,8 @@ COMMENT= A module to simplify connecting up to a LDAP server
BUILD_DEPENDS= p5-perl-ldap>=0.23:${PORTSDIR}/net/p5-perl-ldap
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::LDAP::Express.3
diff --git a/net/p5-Net-Rendezvous-Publish/Makefile b/net/p5-Net-Rendezvous-Publish/Makefile
index 2f81544f0f77..7c676317ee87 100644
--- a/net/p5-Net-Rendezvous-Publish/Makefile
+++ b/net/p5-Net-Rendezvous-Publish/Makefile
@@ -18,7 +18,8 @@ COMMENT= Publish Rendezvous services
BUILD_DEPENDS= p5-Class-Accessor-Lvalue>=0:${PORTSDIR}/devel/p5-Class-Accessor-Lvalue
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Rendezvous::Publish.3 \
Net::Rendezvous::Publish::Service.3
diff --git a/net/p5-Net-Rsh/Makefile b/net/p5-Net-Rsh/Makefile
index 49b78e92cb61..5b1b31d6c716 100644
--- a/net/p5-Net-Rsh/Makefile
+++ b/net/p5-Net-Rsh/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= nistor@snickers.org
COMMENT= Perl5 module to access and use rsh protocol
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Rsh.3
diff --git a/net/p5-Net-SSH-Mechanize/Makefile b/net/p5-Net-SSH-Mechanize/Makefile
index 25bc2c0409fc..7e29af23eb9b 100644
--- a/net/p5-Net-SSH-Mechanize/Makefile
+++ b/net/p5-Net-SSH-Mechanize/Makefile
@@ -17,7 +17,8 @@ RUN_DEPENDS= \
p5-MooseX-Params-Validate>0:${PORTSDIR}/devel/p5-MooseX-Params-Validate
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Net::SSH::Mechanize.3 \
Net::SSH::Mechanize::ConnectParams.3 \
diff --git a/net/p5-POEx-Role-TCPServer/Makefile b/net/p5-POEx-Role-TCPServer/Makefile
index bee145e242c2..e512cdacb212 100644
--- a/net/p5-POEx-Role-TCPServer/Makefile
+++ b/net/p5-POEx-Role-TCPServer/Makefile
@@ -25,7 +25,8 @@ RUN_DEPENDS= \
p5-aliased>0:${PORTSDIR}/devel/p5-aliased
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POEx::Role::TCPServer.3
diff --git a/net/p5-RPC-Simple/Makefile b/net/p5-RPC-Simple/Makefile
index c223ad928c44..9ee8e069a28b 100644
--- a/net/p5-RPC-Simple/Makefile
+++ b/net/p5-RPC-Simple/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Perl classes to handle simple asynchronous RPC calls with call-back
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= RPC::Simple.3 RPC::Simple::Agent.3 RPC::Simple::AnyLocal.3 \
RPC::Simple::AnyRemote.3 RPC::Simple::AnyWhere.3 \
diff --git a/net/p5-Sort-Key-IPv4/Makefile b/net/p5-Sort-Key-IPv4/Makefile
index cdf092a527bb..8dac7842692d 100644
--- a/net/p5-Sort-Key-IPv4/Makefile
+++ b/net/p5-Sort-Key-IPv4/Makefile
@@ -17,7 +17,8 @@ COMMENT= Perl extension for sorting IPv4 addresses
BUILD_DEPENDS= p5-Sort-Key>=0:${PORTSDIR}/devel/p5-Sort-Key
RUN_DEPENDS= p5-Sort-Key>=0:${PORTSDIR}/devel/p5-Sort-Key
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Sort::Key::IPv4.3
diff --git a/net/p5-What/Makefile b/net/p5-What/Makefile
index 7a046cb213df..4891c73cb31e 100644
--- a/net/p5-What/Makefile
+++ b/net/p5-What/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-Error>=0:${PORTSDIR}/lang/p5-Error \
p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= What.3 What::MTA.3
diff --git a/net/p5-XML-RPC/Makefile b/net/p5-XML-RPC/Makefile
index 9dd909352817..c24705ee01a9 100644
--- a/net/p5-XML-RPC/Makefile
+++ b/net/p5-XML-RPC/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-XML-TreePP>=0:${PORTSDIR}/textproc/p5-XML-TreePP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= XML::RPC.3
diff --git a/ports-mgmt/p5-FreeBSD-Pkgs/Makefile b/ports-mgmt/p5-FreeBSD-Pkgs/Makefile
index 2a2ed86b03c0..1691ac8e48fe 100644
--- a/ports-mgmt/p5-FreeBSD-Pkgs/Makefile
+++ b/ports-mgmt/p5-FreeBSD-Pkgs/Makefile
@@ -17,7 +17,8 @@ COMMENT= Parses the contents of FreeBSD package DB under /var/db/pkg
BUILD_DEPENDS= p5-Error-Helper>=0:${PORTSDIR}/devel/p5-Error-Helper
RUN_DEPENDS= p5-Error-Helper>=0:${PORTSDIR}/devel/p5-Error-Helper
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= FreeBSD::Pkgs.3
diff --git a/ports-mgmt/pkg_tree/Makefile b/ports-mgmt/pkg_tree/Makefile
index 84d4c386e1e4..69f224b06939 100644
--- a/ports-mgmt/pkg_tree/Makefile
+++ b/ports-mgmt/pkg_tree/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.mavetju.org/download/
MAINTAINER= edwin@mavetju.org
COMMENT= Get a 'graphical' tree-overview of installed packages
-USE_PERL5= yes
+USES= perl5
MAN7= pkg_tree.7
PLIST_FILES= bin/pkg_tree