aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/bfe/Makefile7
-rw-r--r--emulators/fuse/Makefile1
-rw-r--r--games/battletanks/Makefile1
-rw-r--r--games/csmash/Makefile9
-rw-r--r--games/freedoko/Makefile8
-rw-r--r--games/frozenbubble/Makefile4
-rw-r--r--graphics/apvlv/Makefile8
-rw-r--r--graphics/darktable/Makefile2
-rw-r--r--irc/cwirc/Makefile8
-rw-r--r--multimedia/ffmpeg2theora/Makefile7
-rw-r--r--ports-mgmt/bxpkg/Makefile7
-rw-r--r--science/dcl/Makefile1
-rw-r--r--science/gdis/Makefile2
-rw-r--r--sysutils/downtime/Makefile12
-rw-r--r--sysutils/downtime/pkg-plist4
-rw-r--r--textproc/fcitx-m17n/Makefile2
-rw-r--r--x11-clocks/alltraxclock/Makefile7
-rw-r--r--x11-fm/catseye-fm/Makefile7
-rw-r--r--x11-fm/emelfm2/Makefile2
-rw-r--r--x11-wm/afterstep-stable/Makefile2
-rw-r--r--x11-wm/afterstep-stable/pkg-plist1
-rw-r--r--x11/bbrun/Makefile8
-rw-r--r--x11/bmpanel2/Makefile2
-rw-r--r--x11/docker/Makefile8
-rw-r--r--x11/eaglemode/Makefile3
-rw-r--r--x11/gdkxft/Makefile2
26 files changed, 41 insertions, 84 deletions
diff --git a/emulators/bfe/Makefile b/emulators/bfe/Makefile
index 6b8a33c3793e..c3725a1c6f32 100644
--- a/emulators/bfe/Makefile
+++ b/emulators/bfe/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bfe
-# Date created: 02 February 2000
-# Whom: jhb
-#
+# Created by: jhb
# $FreeBSD$
-#
PORTNAME= bfe2
PORTVERSION= 20030723
@@ -19,6 +15,7 @@ RUN_DEPENDS= bochs:${PORTSDIR}/emulators/bochs
WRKSRC= ${WRKDIR}/${PORTNAME}
+USES= pkgconfig
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.sh
diff --git a/emulators/fuse/Makefile b/emulators/fuse/Makefile
index f8550f235277..7460e48b2cf6 100644
--- a/emulators/fuse/Makefile
+++ b/emulators/fuse/Makefile
@@ -16,6 +16,7 @@ LIB_DEPENDS= spectrum:${PORTSDIR}/emulators/libspectrum \
gcrypt:${PORTSDIR}/security/libgcrypt
GNU_CONFIGURE= yes
+USES= pkgconfig
USE_GNOME= libxml2 glib20 gtk20
CONFIGURE_ARGS+=--without-alsa --without-joystick
diff --git a/games/battletanks/Makefile b/games/battletanks/Makefile
index 46ef70900237..f22ddd3a80b2 100644
--- a/games/battletanks/Makefile
+++ b/games/battletanks/Makefile
@@ -16,6 +16,7 @@ LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
vorbisfile.6:${PORTSDIR}/audio/libvorbis \
smpeg.1:${PORTSDIR}/multimedia/smpeg
+USES= pkgconfig
USE_BZIP2= yes
USE_GCC= yes
USE_LDCONFIG= yes
diff --git a/games/csmash/Makefile b/games/csmash/Makefile
index c48370090dbf..c018d2b91668 100644
--- a/games/csmash/Makefile
+++ b/games/csmash/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: csmash
-# Date created: Nov 11, 2003
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= csmash
PORTVERSION= 0.6.6
@@ -15,7 +10,7 @@ MASTER_SITES= SF/cannonsmash/CannonSmash/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A 3D tabletennis game
-USES= gettext
+USES= gettext pkgconfig
USE_SDL= image mixer sdl
USE_GL= yes
USE_GNOME= gtk20
diff --git a/games/freedoko/Makefile b/games/freedoko/Makefile
index 1df6fd63e163..57a4a46e2ba0 100644
--- a/games/freedoko/Makefile
+++ b/games/freedoko/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: FreeDoko
-# Date created: 02 Jun 2004
-# Whom: Thomas Gellekum <tg@FreeBSD.org>
-#
+# Created by: Thomas Gellekum <tg@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= freedoko
PORTVERSION= 0.7.11
@@ -24,7 +20,7 @@ LIB_DEPENDS= gnet-2.0.0:${PORTSDIR}/net/gnet2 \
WRKSRC= ${WRKDIR}/${DISTNAME:C/\.src$//}/src
USE_ZIP= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
MAKE_ENV= OS="${OPSYS}" DATADIR="${DATADIR}" DOCSDIR="${DOCSDIR}"
post-patch:
diff --git a/games/frozenbubble/Makefile b/games/frozenbubble/Makefile
index 374d5887c6a4..23993606f9da 100644
--- a/games/frozenbubble/Makefile
+++ b/games/frozenbubble/Makefile
@@ -15,9 +15,9 @@ BUILD_DEPENDS= p5-SDL>=0:${PORTSDIR}/devel/p5-SDL
RUN_DEPENDS= p5-SDL>=0:${PORTSDIR}/devel/p5-SDL
USE_SDL= mixer sdl pango
-USE_GMAKE= yes
+USES= gmake perl5 pkgconfig
USE_BZIP2= yes
-PERL_CONFIGURE= yes
+USE_PERL5= configure
CONFIGURE_WRKSRC= ${WRKSRC}/c_stuff
REINPLACE_ARGS= -i ""
diff --git a/graphics/apvlv/Makefile b/graphics/apvlv/Makefile
index 73f5ac760b0d..4e32d6aee5cf 100644
--- a/graphics/apvlv/Makefile
+++ b/graphics/apvlv/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: apvlv
-# Date created: 03 May 2010
-# Whom: Ju Pengfei <jupengfei@gmail.com>
-#
+# Created by: Ju Pengfei <jupengfei@gmail.com>
# $FreeBSD$
-#
PORTNAME= apvlv
PORTVERSION= 0.1.4
@@ -19,7 +15,7 @@ LICENSE= GPLv2
LIB_DEPENDS= poppler-glib.8:${PORTSDIR}/graphics/poppler-glib
USE_GNOME= gtk20
-USES= cmake
+USES= cmake pkgconfig
CMAKE_ARGS+= -DSYSCONFDIR=${PREFIX}/etc \
-DMANDIR=${MANPREFIX}/man \
-DDOCDIR=${DOCSDIR} \
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index 71df575fdab4..de8105d347c0 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libexiv2.so:${PORTSDIR}/graphics/exiv2 \
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= uses SSE extensions
-USES= cmake:outsource
+USES= cmake:outsource pkgconfig
USE_XZ= yes
USE_GNOME= librsvg2
USE_SQLITE= yes
diff --git a/irc/cwirc/Makefile b/irc/cwirc/Makefile
index bec841bd8a0a..f70969508c5e 100644
--- a/irc/cwirc/Makefile
+++ b/irc/cwirc/Makefile
@@ -1,9 +1,5 @@
-# ports collection makefile for: cwirc
-# Date created: 9 April 2008
-# Whom: db
-#
+# Created by: db
# $FreeBSD$
-#
PORTNAME= cwirc
PORTVERSION= 2.0.0
@@ -19,6 +15,8 @@ COMMENT= X-Chat Morse plugin
BUILD_DEPENDS= xchat:${PORTSDIR}/irc/xchat
+USES= pkgconfig
+
post-patch:
${CP} ${FILESDIR}/Makefile ${WRKSRC}
${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
diff --git a/multimedia/ffmpeg2theora/Makefile b/multimedia/ffmpeg2theora/Makefile
index 6b95261ec8a8..c2f1c8c02e18 100644
--- a/multimedia/ffmpeg2theora/Makefile
+++ b/multimedia/ffmpeg2theora/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: ffmpeg2theora
-# Date created: Sat 19 Oct 2008
-# Whom: Anders Nordby <anders@FreeBSD.org>
-#
+# Created by: Anders Nordby <anders@FreeBSD.org>
# $FreeBSD$
PORTNAME= ffmpeg2theora
@@ -19,7 +16,7 @@ LIB_DEPENDS= avcodec:${PORTSDIR}/multimedia/ffmpeg \
theora:${PORTSDIR}/multimedia/libtheora
USE_BZIP2= yes
-USES= iconv
+USES= iconv pkgconfig
USE_SCONS= yes
SCONS_BUILDENV= CC="${CC}" CCFLAGS="${CFLAGS}" \
APPEND_CCFLAGS="${CPPFLAGS}" APPEND_LINKFLAGS="${LDFLAGS}"
diff --git a/ports-mgmt/bxpkg/Makefile b/ports-mgmt/bxpkg/Makefile
index 50a13be3eb28..0cfdc011c7c1 100644
--- a/ports-mgmt/bxpkg/Makefile
+++ b/ports-mgmt/bxpkg/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bxpkg
-# Date Created: 7 February 2011
-# Whom: Kostas Petrikas <kpetrikas@gmail.com>
-#
+# Created by: Kostas Petrikas <kpetrikas@gmail.com>
# $FreeBSD$
-#
PORTNAME= bxpkg
DISTVERSION= 0.0.4_0
@@ -15,6 +11,7 @@ DISTNAME= ${PORTNAME}-${DISTVERSION}
MAINTAINER= kpetrikas@gmail.com
COMMENT= bxPKG is a GTK+ based tool to manage binary packages on BSD systems.
+USES= pkgconfig
USE_XORG= x11
USE_GNOME= gtk20
diff --git a/science/dcl/Makefile b/science/dcl/Makefile
index 120af6d9493e..ed810861c0a7 100644
--- a/science/dcl/Makefile
+++ b/science/dcl/Makefile
@@ -12,6 +12,7 @@ MAINTAINER= murashin@gfd-dennou.org
COMMENT= Scientific graphic library for geoscience
MAKE_JOBS_UNSAFE= yes
+USES= pkgconfig
USE_XORG= x11 xext
USE_FORTRAN= yes
USE_GNOME= gtk20 gdkpixbuf2
diff --git a/science/gdis/Makefile b/science/gdis/Makefile
index b6148d110b16..7c1715bba3d1 100644
--- a/science/gdis/Makefile
+++ b/science/gdis/Makefile
@@ -18,7 +18,7 @@ OPTIONS_DEFINE= DOCS
USE_GL= glu
USE_GNOME= gtk20
-USE_GMAKE= yes
+USES= gmake pkgconfig
MAKEFILE= GNUmakefile
PORTDOCS= CHANGELOG README TODO
diff --git a/sysutils/downtime/Makefile b/sysutils/downtime/Makefile
index 7822cf3c0b39..f66623407eb3 100644
--- a/sysutils/downtime/Makefile
+++ b/sysutils/downtime/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: downtime
-# Date created: 17 July 2006
-# Whom: Nick Withers (nick@nickwithers.com)
-#
+# Created by: Nick Withers (nick@nickwithers.com)
# $FreeBSD$
-#
PORTNAME= downtime
PORTVERSION= 0.4.0
@@ -14,12 +10,10 @@ MASTER_SITES= http://www.nickwithers.com/downtime/
MAINTAINER= nick@nickwithers.com
COMMENT= A GTK-based shutdown manager using shutdown(8)
-USE_GNOME= gtk20 desktopfileutils
+USES= desktop-file-utils pkgconfig shared-mime-info
+USE_GNOME= gtk20
MAN1= downtime.1
MANCOMPRESSED= yes
-post-install:
- -@update-desktop-database
-
.include <bsd.port.mk>
diff --git a/sysutils/downtime/pkg-plist b/sysutils/downtime/pkg-plist
index 289c1d483512..f390e9b7f6d5 100644
--- a/sysutils/downtime/pkg-plist
+++ b/sysutils/downtime/pkg-plist
@@ -4,7 +4,3 @@ share/mime/packages/downtime.xml
@dirrmtry share/applications
@dirrmtry share/mime/packages
@dirrmtry share/mime
-@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
-@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
diff --git a/textproc/fcitx-m17n/Makefile b/textproc/fcitx-m17n/Makefile
index e2f1b13e4e68..c547e1b040e7 100644
--- a/textproc/fcitx-m17n/Makefile
+++ b/textproc/fcitx-m17n/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= fcitx-config:${PORTSDIR}/chinese/fcitx \
m17n:${PORTSDIR}/devel/m17n-lib
USE_XZ= yes
-USES= cmake gettext
+USES= cmake gettext pkgconfig
USE_GNOME= intltool
.include <bsd.port.mk>
diff --git a/x11-clocks/alltraxclock/Makefile b/x11-clocks/alltraxclock/Makefile
index a20cee3b7a8f..49a799ae010e 100644
--- a/x11-clocks/alltraxclock/Makefile
+++ b/x11-clocks/alltraxclock/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: alltraxclock
-# Date created: 11 Feb 2004
-# Whom: Roman Bogorodskiy <bogorodskiy@inbox.ru>
-#
+# Created by: Roman Bogorodskiy <bogorodskiy@inbox.ru>
# $FreeBSD$
-#
PORTNAME= alltraxclock
PORTVERSION= 2.0.2
@@ -20,6 +16,7 @@ COMMENT= An analog clock plugin for gkrellm2
BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+USES= pkgconfig
ALL_TARGET= alltraxclock.so
PLIST_FILES= libexec/gkrellm2/plugins/alltraxclock.so
WRKSRC= ${WRKDIR}/${PORTNAME}2_0.2/
diff --git a/x11-fm/catseye-fm/Makefile b/x11-fm/catseye-fm/Makefile
index 85407c199964..d8416d9e05fd 100644
--- a/x11-fm/catseye-fm/Makefile
+++ b/x11-fm/catseye-fm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: oneko
-# Date created: 9 May 2009
-# Whom: Geyer Klaus
-#
+# Created by: Geyer Klaus
# $FreeBSD$
-#
PORTNAME= catseye-fm
PORTVERSION= 4.2.0.0
@@ -15,6 +11,7 @@ MASTER_SITES= http://catseye-fm.sourceforge.net/downloads/ \
MAINTAINER= klausgeyer@gmx.de
COMMENT= Clear, fast, powerful file browser using gtk+2.0
+USES= pkgconfig
USE_GNOME= gtk20
PLIST_FILES= bin/catseye-fm \
diff --git a/x11-fm/emelfm2/Makefile b/x11-fm/emelfm2/Makefile
index b9f54a74898a..fa49d0793a65 100644
--- a/x11-fm/emelfm2/Makefile
+++ b/x11-fm/emelfm2/Makefile
@@ -10,7 +10,7 @@ COMMENT= The gtk2 port of emelfm, a fast graphical filemanager
USE_BZIP2= yes
USE_GNOME= gtk20
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_LDCONFIG= yes
INSTALL_TARGET= install
diff --git a/x11-wm/afterstep-stable/Makefile b/x11-wm/afterstep-stable/Makefile
index 625a4e55ddf8..3f31553d047e 100644
--- a/x11-wm/afterstep-stable/Makefile
+++ b/x11-wm/afterstep-stable/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus \
RUN_DEPENDS= xli:${PORTSDIR}/graphics/xli
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk20 librsvg2 pango
USE_XORG+= ice sm x11 xcomposite xcursor xdamage xext xfixes xi xinerama \
xrandr xrender
diff --git a/x11-wm/afterstep-stable/pkg-plist b/x11-wm/afterstep-stable/pkg-plist
index a9e32cd74aa8..1c15bcc7736e 100644
--- a/x11-wm/afterstep-stable/pkg-plist
+++ b/x11-wm/afterstep-stable/pkg-plist
@@ -1377,6 +1377,7 @@ lib/libAfterStep.a
%%DATADIR%%/wharf
%%DATADIR%%/winlist
%%DATADIR%%/wintabs
+share/gnome/wm-properties/AfterStep.desktop
@dirrm %%DATADIR%%/themes
@dirrm %%DATADIR%%/start/7_About_AfterStep
@dirrm %%DATADIR%%/start/5_Quit
diff --git a/x11/bbrun/Makefile b/x11/bbrun/Makefile
index 09cf7dfa11e7..d3554a8acc9b 100644
--- a/x11/bbrun/Makefile
+++ b/x11/bbrun/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bbrun
-# Date created: 3 August 2001
-# Whom: Adam Weinberger <adam@vectors.cx>
-#
+# Created by: Adam Weinberger <adam@vectors.cx>
# $FreeBSD$
-#
PORTNAME= bbrun
PORTVERSION= 1.6
@@ -18,7 +14,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/bbrun
USE_XORG= xpm
USE_GNOME= gtk20
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_CSTD= gnu89
PORTDOCS= README
diff --git a/x11/bmpanel2/Makefile b/x11/bmpanel2/Makefile
index d9b346ebd319..efd3e6c9aca5 100644
--- a/x11/bmpanel2/Makefile
+++ b/x11/bmpanel2/Makefile
@@ -11,7 +11,7 @@ COMMENT= Nice, lightweight NETWM compliant panel for X11
LICENSE= MIT
-USES= cmake
+USES= cmake pkgconfig
USE_GNOME= pango
USE_XORG= x11 xext
diff --git a/x11/docker/Makefile b/x11/docker/Makefile
index 12fd8b9fc373..093125b1a3a7 100644
--- a/x11/docker/Makefile
+++ b/x11/docker/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: docker
-# Date created: March 15, 2003
-# Whom: Samy Al Bahra <samy@kerneled.org>
-#
+# Created by: Samy Al Bahra <samy@kerneled.org>
# $FreeBSD$
-#
PORTNAME= docker
PORTVERSION= 1.5
@@ -20,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_XORG= x11
USE_GNOME= glib20
-USE_GMAKE= yes
+USES= gmake pkgconfig
PLIST_FILES= bin/docker
diff --git a/x11/eaglemode/Makefile b/x11/eaglemode/Makefile
index 198e476f9e60..0df7f6e6fac3 100644
--- a/x11/eaglemode/Makefile
+++ b/x11/eaglemode/Makefile
@@ -14,8 +14,9 @@ LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
tiff:${PORTSDIR}/graphics/tiff \
freetype:${PORTSDIR}/print/freetype2
+USES= perl5 pkgconfig
USE_BZIP2= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
USE_XORG= x11 xext xxf86vm
SUB_FILES= eaglemode.sh
diff --git a/x11/gdkxft/Makefile b/x11/gdkxft/Makefile
index 11cb467178a6..8586e41a2c87 100644
--- a/x11/gdkxft/Makefile
+++ b/x11/gdkxft/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft
USE_AUTOTOOLS= libtool
USE_GNOME= gtk12
-USES= iconv
+USES= iconv pkgconfig
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib -lgnuregex ${ICONV_LIB}
CFLAGS+= `pkg-config xft --cflags`