aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/streamripper/Makefile50
-rw-r--r--audio/streamripper/distinfo6
-rw-r--r--audio/streamripper/files/patch-Makefile.in68
-rw-r--r--audio/streamripper/files/patch-lib_parse.c20
-rw-r--r--audio/streamripper/files/patch-lib_util.c33
5 files changed, 56 insertions, 121 deletions
diff --git a/audio/streamripper/Makefile b/audio/streamripper/Makefile
index dfc298f28f6e..e46891ba4a31 100644
--- a/audio/streamripper/Makefile
+++ b/audio/streamripper/Makefile
@@ -6,36 +6,54 @@
#
PORTNAME= streamripper
-PORTVERSION= 1.61.27
-PORTREVISION= 1
+PORTVERSION= 1.62.1
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= streamripper
+MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Splits SHOUTcast stream into tracks
-LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad
+LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad \
+ tre.6:${PORTSDIR}/textproc/libtre
+OPTIONS= FAAD "Include FAAD mpeg4 codec support" on \
+ VORBIS "Include Ogg Vorbis codec support" on
+
+USE_GNOME= gnometarget
USE_ICONV= yes
-OPTIONS= VORBIS "Include Ogg Vorbis codec support" on
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --without-included-libmad \
+ --without-included-tre \
+ --with-included-argv
+CFLAGS+= -DANSI_PROTOTYPES -DHAVE_LANGINFO_CODESET
+
+MAN1= streamripper.1
+PLIST_FILES= bin/cstreamripper bin/streamripper
.include <bsd.port.pre.mk>
-.ifdef(WITH_VORBIS)
-LIB_DEPENDS+= ogg.5:${PORTSDIR}/audio/libogg \
- vorbis.4:${PORTSDIR}/audio/libvorbis
+.if defined(WITHOUT_FAAD)
+CONFIGURE_ARGS+= ac_cv_lib_faad_NeAACDecDecode2=no
+.else
+LIB_DEPENDS+= faad.0:${PORTSDIR}/audio/faad
.endif
-GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+.if defined(WITHOUT_VORBIS)
+CONFIGURE_ARGS+= --without-ogg
+.else
+LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+.endif
-PLIST_FILES= bin/streamripper
-MAN1= streamripper.1
+post-patch:
+ @${REINPLACE_CMD} -e '/if test/s|==|=|g ; \
+ s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
-pre-install:
- @${CHMOD} +x ${WRKSRC}/install-sh
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cstreamripper ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/streamripper ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/streamripper.1 ${MANPREFIX}/man/man1
.include <bsd.port.post.mk>
diff --git a/audio/streamripper/distinfo b/audio/streamripper/distinfo
index 85a95c7b44fc..fd6f7de75168 100644
--- a/audio/streamripper/distinfo
+++ b/audio/streamripper/distinfo
@@ -1,3 +1,3 @@
-MD5 (streamripper-1.61.27.tar.gz) = d92a37bf23ee3f1bd5a9498d72c0562a
-SHA256 (streamripper-1.61.27.tar.gz) = d53fc5d3fb49bbb2332a4d26c5a63a0679009d6bf6b4b0e4e5078a9cdc183111
-SIZE (streamripper-1.61.27.tar.gz) = 1227559
+MD5 (streamripper-1.62.1.tar.gz) = c8c84b8acf84f3d431bf7b6303acc63b
+SHA256 (streamripper-1.62.1.tar.gz) = 03890195689f72d93426d674c84d3baf2ddee39cb3e09d09811ca5b08c2b21a3
+SIZE (streamripper-1.62.1.tar.gz) = 1244851
diff --git a/audio/streamripper/files/patch-Makefile.in b/audio/streamripper/files/patch-Makefile.in
index 070c9aadb3a0..0cd8b181281c 100644
--- a/audio/streamripper/files/patch-Makefile.in
+++ b/audio/streamripper/files/patch-Makefile.in
@@ -1,50 +1,20 @@
---- Makefile.in.orig Sun Nov 6 22:33:28 2005
-+++ Makefile.in Sun Nov 6 22:33:28 2005
-@@ -25,10 +25,10 @@
- top_builddir = .
- am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
- INSTALL = @INSTALL@
--install_sh_DATA = $(install_sh) -c -m 644
--install_sh_PROGRAM = $(install_sh) -c
--install_sh_SCRIPT = $(install_sh) -c
--INSTALL_HEADER = $(INSTALL_DATA)
-+install_sh_DATA = $(BSD_INSTALL_DATA)
-+install_sh_PROGRAM = $(BSD_INSTALL_PROGRAM)
-+install_sh_SCRIPT = $(BSD_INSTALL_SCRIPT)
-+INSTALL_HEADER = $(BSD_INSTALL_DATA)
- transform = $(program_transform_name)
- NORMAL_INSTALL = :
- PRE_INSTALL = :
-@@ -57,7 +57,7 @@
- $(ACLOCAL_M4)
- am__CONFIG_DISTCLEAN_FILES = config.status config.cache config.log \
- configure.lineno configure.status.lineno
--mkinstalldirs = $(install_sh) -d
-+mkinstalldirs = $(INSTALL) -d
- CONFIG_HEADER = $(top_builddir)/lib/config.h
- CONFIG_CLEAN_FILES =
+--- Makefile.in.orig Sun May 27 04:26:06 2007
++++ Makefile.in Thu Jul 19 23:40:43 2007
+@@ -64,7 +64,7 @@
am__installdirs = "$(DESTDIR)$(bindir)" "$(DESTDIR)$(man1dir)"
-@@ -140,7 +140,7 @@
- INSTALL_DATA = @INSTALL_DATA@
- INSTALL_PROGRAM = @INSTALL_PROGRAM@
- INSTALL_SCRIPT = @INSTALL_SCRIPT@
--INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
-+INSTALL_STRIP_PROGRAM = @INSTALL_PROGRAM@
- LDFLAGS = @LDFLAGS@
- LIBCHARSET = @LIBCHARSET@
- LIBIBERTY_LIBS = @LIBIBERTY_LIBS@
-@@ -201,12 +201,12 @@
- host_vendor = @host_vendor@
- includedir = @includedir@
- infodir = @infodir@
--install_sh = @install_sh@
-+install_sh = @INSTALL@
- libdir = @libdir@
- libexecdir = @libexecdir@
- localstatedir = @localstatedir@
- mandir = @mandir@
--mkdir_p = @mkdir_p@
-+mkdir_p = @INSTALL@ -d
- oldincludedir = @oldincludedir@
- prefix = @prefix@
- program_transform_name = @program_transform_name@
+ binPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
+ PROGRAMS = $(bin_PROGRAMS)
+-am_cstreamripper_OBJECTS = cstreamripper.$(OBJEXT)
++am_cstreamripper_OBJECTS = cstreamripper.$(OBJEXT) $(am__objects_1)
+ cstreamripper_OBJECTS = $(am_cstreamripper_OBJECTS)
+ cstreamripper_DEPENDENCIES = lib/libstreamripper.a
+ am_ictest_OBJECTS = ictest.$(OBJEXT)
+@@ -227,7 +227,7 @@
+
+ streamripper_SOURCES = console/streamripper.c $(am__append_2)
+ cstreamripper_SOURCES = \
+- console/cstreamripper.c
++ console/cstreamripper.c $(am__append_2)
+
+ libmad_manifest = \
+ libmad-0.15.1b/README \
diff --git a/audio/streamripper/files/patch-lib_parse.c b/audio/streamripper/files/patch-lib_parse.c
deleted file mode 100644
index 05bb1a8f0cc7..000000000000
--- a/audio/streamripper/files/patch-lib_parse.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- lib/parse.c.orig Sun Sep 11 12:45:28 2005
-+++ lib/parse.c Sun Sep 11 12:45:28 2005
-@@ -70,14 +70,14 @@
- PARSERULE_ICASE,
- 0, 0, 0, 0,
- 0,
-- "[[:space:]]*-?[[:space:]]*mp3pro$",
-+ " *-? *mp3pro$",
- ""
- },
- { PARSERULE_CMD_MATCH,
- PARSERULE_ICASE,
- 1, 2, 0, 0,
-- 0,
-- "^[[:space:]]*([^-]*[^-[:space:]])[[:space:]]*-[[:space:]]*(.*)[[:space:]]*$",
-+ 0,
-+ "^ *([^-]*[^- ]) *- *(.*) *$",
- ""
- },
- { 0x00,
diff --git a/audio/streamripper/files/patch-lib_util.c b/audio/streamripper/files/patch-lib_util.c
deleted file mode 100644
index 8f2291298655..000000000000
--- a/audio/streamripper/files/patch-lib_util.c
+++ /dev/null
@@ -1,33 +0,0 @@
-Argh, FreeBSD 4.X has a wctype.h header that does nothing.
-
---- lib/util.c.orig Sun Sep 11 12:46:20 2005
-+++ lib/util.c Sun Sep 11 12:46:20 2005
-@@ -28,9 +28,7 @@
- #if defined HAVE_WCHAR_H
- #include <wchar.h>
- #endif
--#if defined HAVE_WCTYPE_H
--#include <wctype.h>
--#endif
-+#include <ctype.h>
- #endif
- #include <locale.h>
- #include <time.h>
-@@ -450,7 +448,7 @@
-
- /* Replace illegals to legal */
- for (wstrp = w_in; *wstrp; wstrp++) {
-- if ((wcschr(w_invalid, *wstrp) == NULL) && (!iswcntrl(*wstrp)))
-+ if ((wcschr(w_invalid, *wstrp) == NULL) && (!iscntrl(*wstrp)))
- continue;
- *wstrp = replacement;
- }
-@@ -525,7 +523,7 @@
-
- /* Replace illegals to legal */
- for (wstrp = w_in; *wstrp; wstrp++) {
-- if ((wcschr(w_invalid, *wstrp) == NULL) && (!iswcntrl(*wstrp)))
-+ if ((wcschr(w_invalid, *wstrp) == NULL) && (!iscntrl(*wstrp)))
- continue;
- *wstrp = replacement;
- }