aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/rpy/Makefile26
-rw-r--r--math/rpy/distinfo1
-rw-r--r--math/rpy/files/patch-src:setenv.c11
-rw-r--r--math/rpy/pkg-descr8
-rw-r--r--math/rpy/pkg-plist9
-rw-r--r--math/rpy2/Makefile26
-rw-r--r--math/rpy2/distinfo1
-rw-r--r--math/rpy2/files/patch-src:setenv.c11
-rw-r--r--math/rpy2/pkg-descr8
-rw-r--r--math/rpy2/pkg-plist9
11 files changed, 111 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 51c72fd3dd68..ec390fa5ae2d 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -154,6 +154,7 @@
SUBDIR += rascal
SUBDIR += rcalc
SUBDIR += rpc
+ SUBDIR += rpy
SUBDIR += ruby-algebra
SUBDIR += ruby-bitset
SUBDIR += ruby-bitvector
diff --git a/math/rpy/Makefile b/math/rpy/Makefile
new file mode 100644
index 000000000000..269723e0d864
--- /dev/null
+++ b/math/rpy/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: rpy
+# Date created: Jan 14, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= rpy
+PORTVERSION= 0.3.1
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Python interface to the R Programming Language
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/Numeric.pth:${PORTSDIR}/math/py-numeric \
+ R:${PORTSDIR}/math/R-letter
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib/R/modules"
+
+.include <bsd.port.mk>
diff --git a/math/rpy/distinfo b/math/rpy/distinfo
new file mode 100644
index 000000000000..7b8070ca160a
--- /dev/null
+++ b/math/rpy/distinfo
@@ -0,0 +1 @@
+MD5 (rpy-0.3.1.tar.gz) = 3fd3e825523521bd5084748a60ba4a37
diff --git a/math/rpy/files/patch-src:setenv.c b/math/rpy/files/patch-src:setenv.c
new file mode 100644
index 000000000000..adce3e597b9f
--- /dev/null
+++ b/math/rpy/files/patch-src:setenv.c
@@ -0,0 +1,11 @@
+--- src/setenv.c.orig Wed Oct 29 14:47:12 2003
++++ src/setenv.c Wed Oct 29 14:47:19 2003
+@@ -26,8 +26,6 @@
+
+ int setenv(const char *name, const char *value, int clobber)
+ {
+- char *malloc();
+- char *getenv();
+ char *cp;
+
+ if (clobber == 0 && getenv(name) != 0)
diff --git a/math/rpy/pkg-descr b/math/rpy/pkg-descr
new file mode 100644
index 000000000000..d0dfbb55b2bf
--- /dev/null
+++ b/math/rpy/pkg-descr
@@ -0,0 +1,8 @@
+RPy is a very simple, yet robust, Python interface to the R Programming
+Language. It can manage all kinds of R objects and can execute arbitrary
+R functions (including the graphic functions). All the errors from the
+R language are converted to Python exceptions. Any module that later were
+installed on the R system, can easily be used from within Python, without
+introducing any changes.
+
+WWW: http://rpy.sourceforge.net/
diff --git a/math/rpy/pkg-plist b/math/rpy/pkg-plist
new file mode 100644
index 000000000000..a2013ba86a99
--- /dev/null
+++ b/math/rpy/pkg-plist
@@ -0,0 +1,9 @@
+%%PYTHON_SITELIBDIR%%/io.py
+%%PYTHON_SITELIBDIR%%/io.pyc
+%%PYTHON_SITELIBDIR%%/io.pyo
+%%PYTHON_SITELIBDIR%%/rpy.py
+%%PYTHON_SITELIBDIR%%/rpy.pyc
+%%PYTHON_SITELIBDIR%%/rpy.pyo
+%%PYTHON_SITELIBDIR%%/rpy_version.py
+%%PYTHON_SITELIBDIR%%/rpy_version.pyc
+%%PYTHON_SITELIBDIR%%/rpy_version.pyo
diff --git a/math/rpy2/Makefile b/math/rpy2/Makefile
new file mode 100644
index 000000000000..269723e0d864
--- /dev/null
+++ b/math/rpy2/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: rpy
+# Date created: Jan 14, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= rpy
+PORTVERSION= 0.3.1
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Python interface to the R Programming Language
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/Numeric.pth:${PORTSDIR}/math/py-numeric \
+ R:${PORTSDIR}/math/R-letter
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib/R/modules"
+
+.include <bsd.port.mk>
diff --git a/math/rpy2/distinfo b/math/rpy2/distinfo
new file mode 100644
index 000000000000..7b8070ca160a
--- /dev/null
+++ b/math/rpy2/distinfo
@@ -0,0 +1 @@
+MD5 (rpy-0.3.1.tar.gz) = 3fd3e825523521bd5084748a60ba4a37
diff --git a/math/rpy2/files/patch-src:setenv.c b/math/rpy2/files/patch-src:setenv.c
new file mode 100644
index 000000000000..adce3e597b9f
--- /dev/null
+++ b/math/rpy2/files/patch-src:setenv.c
@@ -0,0 +1,11 @@
+--- src/setenv.c.orig Wed Oct 29 14:47:12 2003
++++ src/setenv.c Wed Oct 29 14:47:19 2003
+@@ -26,8 +26,6 @@
+
+ int setenv(const char *name, const char *value, int clobber)
+ {
+- char *malloc();
+- char *getenv();
+ char *cp;
+
+ if (clobber == 0 && getenv(name) != 0)
diff --git a/math/rpy2/pkg-descr b/math/rpy2/pkg-descr
new file mode 100644
index 000000000000..d0dfbb55b2bf
--- /dev/null
+++ b/math/rpy2/pkg-descr
@@ -0,0 +1,8 @@
+RPy is a very simple, yet robust, Python interface to the R Programming
+Language. It can manage all kinds of R objects and can execute arbitrary
+R functions (including the graphic functions). All the errors from the
+R language are converted to Python exceptions. Any module that later were
+installed on the R system, can easily be used from within Python, without
+introducing any changes.
+
+WWW: http://rpy.sourceforge.net/
diff --git a/math/rpy2/pkg-plist b/math/rpy2/pkg-plist
new file mode 100644
index 000000000000..a2013ba86a99
--- /dev/null
+++ b/math/rpy2/pkg-plist
@@ -0,0 +1,9 @@
+%%PYTHON_SITELIBDIR%%/io.py
+%%PYTHON_SITELIBDIR%%/io.pyc
+%%PYTHON_SITELIBDIR%%/io.pyo
+%%PYTHON_SITELIBDIR%%/rpy.py
+%%PYTHON_SITELIBDIR%%/rpy.pyc
+%%PYTHON_SITELIBDIR%%/rpy.pyo
+%%PYTHON_SITELIBDIR%%/rpy_version.py
+%%PYTHON_SITELIBDIR%%/rpy_version.pyc
+%%PYTHON_SITELIBDIR%%/rpy_version.pyo