aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/libgetline/Makefile20
-rw-r--r--devel/libgetline/distinfo1
-rw-r--r--devel/libgetline/files/patch-aa11
-rw-r--r--devel/libgetline/files/patch-ab92
-rw-r--r--devel/libgetline/pkg-comment1
-rw-r--r--devel/libgetline/pkg-descr1
-rw-r--r--devel/libgetline/pkg-plist7
7 files changed, 133 insertions, 0 deletions
diff --git a/devel/libgetline/Makefile b/devel/libgetline/Makefile
new file mode 100644
index 000000000000..85ca8eca0dcc
--- /dev/null
+++ b/devel/libgetline/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: getline library
+# Version required: 3.9
+# Date created: 3 June 1995
+# Whom: roberto
+#
+# $Id: Makefile,v 1.9 1998/10/20 01:34:15 steve Exp $
+#
+
+DISTNAME= getline-39-src
+PKGNAME= getline-3.9
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.sco.com/skunkware/src/lib/
+
+MAINTAINER= wghicks@bellsouth.net
+
+MAN3= getline.3
+
+WRKSRC= ${WRKDIR}/getline-39
+
+.include <bsd.port.mk>
diff --git a/devel/libgetline/distinfo b/devel/libgetline/distinfo
new file mode 100644
index 000000000000..7435640d492d
--- /dev/null
+++ b/devel/libgetline/distinfo
@@ -0,0 +1 @@
+MD5 (getline-39-src.tar.gz) = 967ed4bfcfd241b10ce36749033e9f66
diff --git a/devel/libgetline/files/patch-aa b/devel/libgetline/files/patch-aa
new file mode 100644
index 000000000000..a192d6e2c31d
--- /dev/null
+++ b/devel/libgetline/files/patch-aa
@@ -0,0 +1,11 @@
+--- CHANGES Thu Jan 15 02:07:12 1998
++++ CHANGES Sun Mar 21 15:30:05 1999
+@@ -1,3 +1,8 @@
++
++WGH 20-Mar-99
++ Patches to turn getline into a port for FreeBSD
++ Adapt for FreeBSD RELENG_3 shared library support.
++
+ Hops 14-Jan-98
+ made protos in getline.c stdc style protos
+ Added includes for C std and unix things and removed extern setups
diff --git a/devel/libgetline/files/patch-ab b/devel/libgetline/files/patch-ab
new file mode 100644
index 000000000000..79abd6fab478
--- /dev/null
+++ b/devel/libgetline/files/patch-ab
@@ -0,0 +1,92 @@
+--- Makefile Thu Jan 15 02:16:07 1998
++++ Makefile Sun Mar 21 18:04:04 1999
+@@ -1,46 +1,54 @@
+-#CC = gcc
+-#CFLAGS = -Wall -DPOSIX
++PREFIX?= /usr/local
+
+-CC= cc
+-CFLAGS = -v -DPOSIX
++AR= /usr/bin/ar
++CC= /usr/bin/cc
++INSTALL= /usr/bin/install
++LN= /bin/ln
++RANLIB= /usr/bin/ranlib
++
++CFLAGS= -DPOSIX -O
++LDFLAGS=
++
++INST_INCDIR= $(PREFIX)/include
++INST_LIBDIR= $(PREFIX)/lib
++INST_MANDIR= $(PREFIX)/man
++
++SHLIB_VERSION = 1
++SHLIB_CFLAGS = -fpic -DPIC
++SHLIB_LDFLAGS = -shared
++SHLIB_TGT = $(INST_LIBDIR)/libgetline.so.$(SHLIB_VERSION)
++SHLIB_TGT_SPEC = -Wl,-h$(SHLIB_TGT)
++
++all: libgetline.a libgetline.so.$(SHLIB_VERSION)
++
++# try this after installing to check the installed static library
++testgl: libgetline.a testgl.o
++ $(CC) $(LDFLAGS) $(CFLAGS) -o testgl testgl.o -L$(INST_MANDIR) -lgetline
+
+-LDFLAGS=
+-INSTALL_PATH=/usr/local
+-INST_LIBDIR=$(INSTALL_PATH)/lib
+-INST_MANDIR=$(INSTALL_PATH)/man
+-
+-# UDK
+-SHLIB_CFLAGS= -Kpic
+-SHLIB_LDFLAGS= -G
+-SHLIB_TGT=$(INST_LIBDIR)/libgetline.so
+-SHLIB_TGT_SPEC=-Wl,-h$(SHLIB_TGT)
+-
+-testgl: libgetline.a testgl.o shared
+- $(CC) $(LDFLAGS) $(CFLAGS) -o testgl testgl.o -L. -lgetline
++testgl.o: testgl.c getline.h
+
+ libgetline.a: getline.o
+- ar cr libgetline.a getline.o
+- -ranlib libgetline.a
+-
+-shared: testgl_sh
++ $(AR) cr libgetline.a getline.o
++ -$(RANLIB) libgetline.a
+
+-testgl_sh: libgetline.so testgl.o
+- $(CC) $(LDFLAGS) $(CFLAGS) -o testgl_sh testgl.o -L. -lgetline
++getline.o: getline.c getline.h
+
+-libgetline.so: getline_sh.o
+- $(CC) $(SHLIB_LDFLAGS) $(SHLIB_TGT_SPEC) -o libgetline.so getline_sh.o
++libgetline.so.1: getline.So
++ $(CC) $(SHLIB_LDFLAGS) $(SHLIB_TGT_SPEC) -o libgetline.so.1 getline.So
+
+-getline_sh.o:
+- $(CC) -c $(LDFLAGS) $(CFLAGS) $(SHLIB_CFLAGS) -o getline_sh.o getline.c
++getline.So: getline.c getline.h
++ $(CC) -c $(LDFLAGS) $(CFLAGS) $(SHLIB_CFLAGS) -o getline.So getline.c
+
+ clean:
+- rm -f *.o *.a *.so testgl testgl_sh
++ rm -f testgl *.o *.So *.a *.so.1
+
+ install:
+- [ -d $(INST_LIBDIR) ] || mkdir $(INST_LIBDIR)
+- [ -d $(INST_MANDIR) ] || mkdir $(INST_MANDIR)
+- [ -d $(INST_MANDIR)/man3 ] || mkdir $(INST_MANDIR)/man3
+- cp libgetline.a $(INST_LIBDIR) && chmod 644 $(INST_LIBDIR)/libgetline.a
+- cp libgetline.so $(INST_LIBDIR) && chmod 444 $(INST_LIBDIR)/libgetline.so
+- cp getline.3 $(INST_MANDIR)/man3
+-
++ [ -d $(INST_LIBDIR) ] || $(INSTALL) -d $(INST_LIBDIR)
++ $(INSTALL) -c -g bin -o bin -m 644 libgetline.a libgetline.so.1 \
++ $(INST_LIBDIR)
++ $(LN) -fs $(INST_LIBDIR)/libgetline.so.$(SHLIB_VERSION) \
++ $(INST_LIBDIR)/libgetline.so
++ [ -d $(INST_MANDIR)/man3 ] || $(INSTALL) -d $(INST_MANDIR)/man3
++ $(INSTALL) -c -g bin -o bin -m 644 getline.3 $(INST_MANDIR)/man3
++ [ -d $(INST_INCDIR) ] || $(INSTALL) -d $(INST_INCDIR)
++ $(INSTALL) -c -g bin -o bin -m 644 getline.h $(INST_INCDIR)
diff --git a/devel/libgetline/pkg-comment b/devel/libgetline/pkg-comment
new file mode 100644
index 000000000000..9c1f7d50e9e2
--- /dev/null
+++ b/devel/libgetline/pkg-comment
@@ -0,0 +1 @@
+a small, portable, and easy to use command line library
diff --git a/devel/libgetline/pkg-descr b/devel/libgetline/pkg-descr
new file mode 100644
index 000000000000..9c1f7d50e9e2
--- /dev/null
+++ b/devel/libgetline/pkg-descr
@@ -0,0 +1 @@
+a small, portable, and easy to use command line library
diff --git a/devel/libgetline/pkg-plist b/devel/libgetline/pkg-plist
new file mode 100644
index 000000000000..31954e8d1c8c
--- /dev/null
+++ b/devel/libgetline/pkg-plist
@@ -0,0 +1,7 @@
+include/getline.h
+lib/libgetline.a
+@exec ranlib %D/%F
+lib/libgetline.so
+lib/libgetline.so.1
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R