aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/orthorobot/Makefile39
-rw-r--r--games/orthorobot/distinfo3
-rw-r--r--games/orthorobot/files/orthorobot.in4
-rw-r--r--games/orthorobot/files/pkg-message.in3
-rw-r--r--games/orthorobot/pkg-descr7
6 files changed, 57 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 31cb85dfa1ca..911659c6c03f 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -696,6 +696,7 @@
SUBDIR += openxcom
SUBDIR += openyahtzee
SUBDIR += orbital_eunuchs_sniper
+ SUBDIR += orthorobot
SUBDIR += osgg
SUBDIR += outerspace
SUBDIR += p5-Acme-GuessNumber
diff --git a/games/orthorobot/Makefile b/games/orthorobot/Makefile
new file mode 100644
index 000000000000..989a7defa308
--- /dev/null
+++ b/games/orthorobot/Makefile
@@ -0,0 +1,39 @@
+# $FreeBSD$
+
+PORTNAME= orthorobot
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1.1-1
+DISTVERSIONSUFFIX= -g48f0742
+CATEGORIES= games
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Perspective puzzle game
+
+LICENSE= WTFPL
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= zip:archivers/zip
+# Does not work with LÖVE 11.
+RUN_DEPENDS= love10:devel/love10
+
+USE_GITHUB= yes
+GH_ACCOUNT= Stabyourself
+
+NO_ARCH= yes
+
+SUB_FILES= ${PORTNAME} pkg-message
+SUB_LIST+= LOVE_CMD=${LOVE_CMD} PORTNAME=${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME} ${DATADIR}/${PORTNAME}.love
+
+LOVE_CMD= ${LOCALBASE}/bin/love10
+
+do-build:
+ cd ${WRKSRC} && zip -9 -r ${PORTNAME}.love .
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.love ${STAGEDIR}${DATADIR}/
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/games/orthorobot/distinfo b/games/orthorobot/distinfo
new file mode 100644
index 000000000000..db00d9862697
--- /dev/null
+++ b/games/orthorobot/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1555338330
+SHA256 (Stabyourself-orthorobot-v1.1.1-1-g48f0742_GH0.tar.gz) = 986e30fcb4898e33ffef2eaf6861545975ee8f6240fdd312b33c4bb19b68d119
+SIZE (Stabyourself-orthorobot-v1.1.1-1-g48f0742_GH0.tar.gz) = 3403536
diff --git a/games/orthorobot/files/orthorobot.in b/games/orthorobot/files/orthorobot.in
new file mode 100644
index 000000000000..818ed1cac672
--- /dev/null
+++ b/games/orthorobot/files/orthorobot.in
@@ -0,0 +1,4 @@
+#! /bin/sh -
+# $FreeBSD$
+
+exec %%LOVE_CMD%% %%DATADIR%%/%%PORTNAME%%.love "$@"
diff --git a/games/orthorobot/files/pkg-message.in b/games/orthorobot/files/pkg-message.in
new file mode 100644
index 000000000000..58582eb73733
--- /dev/null
+++ b/games/orthorobot/files/pkg-message.in
@@ -0,0 +1,3 @@
+Start Ortho Robot with the following command:
+
+%%PREFIX%%/bin/orthorobot
diff --git a/games/orthorobot/pkg-descr b/games/orthorobot/pkg-descr
new file mode 100644
index 000000000000..6e88207d4f48
--- /dev/null
+++ b/games/orthorobot/pkg-descr
@@ -0,0 +1,7 @@
+Literally bridging the gap between 2D and 3D games, Ortho Robot is a
+perspective based puzzle game, where you flatten the view to move across gaps.
+Your objective is to reach the ending green block (either by standing directly
+on it or standing on it in relative space). For some extra challenge, try to
+collect all coins and perfect your time, steps and number of warps.
+
+WWW: http://stabyourself.net/orthorobot/