aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ftp/curl/Makefile6
-rw-r--r--ftp/curl/distinfo6
-rw-r--r--ftp/curl/files/patch-Makefile.in6
-rw-r--r--ftp/curl/files/patch-include__curl__curl.h30
-rw-r--r--ftp/curl/files/patch-lib::url.c4
-rw-r--r--ftp/curl/files/patch-src::main.c4
-rw-r--r--ftp/curl/files/patch-tests::libtest::lib505.c6
-rw-r--r--ftp/curl/files/patch-tests::libtest::lib541.c6
-rw-r--r--ftp/curl/files/patch-tests::runtests.pl4
9 files changed, 21 insertions, 51 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 7ba25768c5bd..859f7bbddd92 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= curl
-PORTVERSION= 7.19.7
-PORTREVISION= 1
+PORTVERSION= 7.20.0
CATEGORIES= ftp ipv6 www
MASTER_SITES= http://curl.haxx.se/download/ \
ftp://ftp.sunet.se/pub/www/utilities/curl/ \
@@ -46,7 +45,7 @@ MAN3= curl_easy_cleanup.3 curl_easy_duphandle.3 \
libcurl-multi.3 libcurl-share.3 libcurl-tutorial.3
USE_LDCONFIG= yes
-SHLIB_VER= 5
+SHLIB_VER= 6
MAKE_ENV= SHLIB_VER="${SHLIB_VER}"
PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
@@ -54,6 +53,7 @@ PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
USE_PERL5_BUILD= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--enable-pop3 --enable-smtp --enable-imap --enable-rtsp
MAKE_JOBS_SAFE= yes
OPTIONS= CARES "Asynchronous DNS resolution via c-ares" off \
diff --git a/ftp/curl/distinfo b/ftp/curl/distinfo
index 38ff35770ba6..737823704d43 100644
--- a/ftp/curl/distinfo
+++ b/ftp/curl/distinfo
@@ -1,3 +1,3 @@
-MD5 (curl-7.19.7.tar.bz2) = 79a8fbb2eed5464b97bdf94bee109380
-SHA256 (curl-7.19.7.tar.bz2) = 1a15f94ae3401e3bd6208ce64155c2577815019824bceae7fd3221a12bc54a70
-SIZE (curl-7.19.7.tar.bz2) = 2355121
+MD5 (curl-7.20.0.tar.bz2) = 3dda78c4a808d9a779dc3a2ae81b47d8
+SHA256 (curl-7.20.0.tar.bz2) = eb516915da615d8f6b2b855004d5d4b19c468f080e3736d7a73c5599b9acab11
+SIZE (curl-7.20.0.tar.bz2) = 2088522
diff --git a/ftp/curl/files/patch-Makefile.in b/ftp/curl/files/patch-Makefile.in
index 28e490bcdf22..96f80d9ba281 100644
--- a/ftp/curl/files/patch-Makefile.in
+++ b/ftp/curl/files/patch-Makefile.in
@@ -1,11 +1,11 @@
Description: Build and install the documentation as usual, no special handling.
Forwarded: https://sourceforge.net/tracker/?func=detail&aid=2897155&group_id=976&atid=100976
Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2009-11-13
+Last-Update: 2010-03-30
--- a/Makefile.in
+++ b/Makefile.in
-@@ -297,9 +297,9 @@
+@@ -302,9 +302,9 @@
libcurl.pc.in vc6curl.dsw MacOSX-Framework Android.mk $(CMAKE_DIST)
bin_SCRIPTS = curl-config
@@ -18,7 +18,7 @@ Last-Update: 2009-11-13
pkgconfig_DATA = libcurl.pc
all: all-recursive
-@@ -859,12 +859,10 @@
+@@ -864,12 +864,10 @@
# We extend the standard install with a custom hook:
install-data-hook:
cd include && $(MAKE) install
diff --git a/ftp/curl/files/patch-include__curl__curl.h b/ftp/curl/files/patch-include__curl__curl.h
deleted file mode 100644
index 71cb68b62107..000000000000
--- a/ftp/curl/files/patch-include__curl__curl.h
+++ /dev/null
@@ -1,30 +0,0 @@
-Description: Include <sys/select.h> for fd_set on earlier versions of FreeBSD
-Bug-FreeBSD: http://www.freebsd.org/cgi/query-pr.cgi?pr=141459
-Forwarded: http://sourceforge.net/tracker/?func=detail&aid=2916915&group_id=976&atid=100976
-Author: Renato Botelho <garga@FreeBSD.org>,
- Peter Pentchev <roam@ringlet.net>
-Last-Update: 2009-12-18
-
---- a/include/curl/curl.h
-+++ b/include/curl/curl.h
-@@ -55,6 +55,11 @@
- #include <stdio.h>
- #include <limits.h>
-
-+#if defined(__FreeBSD__)
-+/* Needed to check FreeBSD version */
-+#include <osreldate.h>
-+#endif
-+
- /* The include stuff here below is mainly for time_t! */
- #include <sys/types.h>
- #include <time.h>
-@@ -74,7 +79,7 @@
- require it! */
- #if defined(_AIX) || defined(__NOVELL_LIBC__) || defined(__NetBSD__) || \
- defined(__minix) || defined(__SYMBIAN32__) || defined(__INTEGRITY) || \
-- defined(ANDROID)
-+ defined(ANDROID) || (defined(__FreeBSD__) && __FreeBSD_version < 800000)
- #include <sys/select.h>
- #endif
-
diff --git a/ftp/curl/files/patch-lib::url.c b/ftp/curl/files/patch-lib::url.c
index 163c12514c11..3c4cc2f12f22 100644
--- a/ftp/curl/files/patch-lib::url.c
+++ b/ftp/curl/files/patch-lib::url.c
@@ -1,11 +1,11 @@
Description: Different handling of signals and threads.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2009-11-13
+Last-Update: 2010-03-30
--- a/lib/url.c
+++ b/lib/url.c
-@@ -802,6 +802,10 @@
+@@ -831,6 +831,10 @@
data->progress.flags |= PGRS_HIDE;
data->state.current_speed = -1; /* init to negative == impossible */
diff --git a/ftp/curl/files/patch-src::main.c b/ftp/curl/files/patch-src::main.c
index 28f8ba38cbef..7f46da604571 100644
--- a/ftp/curl/files/patch-src::main.c
+++ b/ftp/curl/files/patch-src::main.c
@@ -1,11 +1,11 @@
Description: Use fstat() instead of stat() to avoid a race condition.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2009-11-13
+Last-Update: 2010-03-30
--- a/src/main.c
+++ b/src/main.c
-@@ -4441,33 +4441,34 @@
+@@ -4596,33 +4596,34 @@
break;
}
diff --git a/ftp/curl/files/patch-tests::libtest::lib505.c b/ftp/curl/files/patch-tests::libtest::lib505.c
index 693988536f01..275974c02952 100644
--- a/ftp/curl/files/patch-tests::libtest::lib505.c
+++ b/ftp/curl/files/patch-tests::libtest::lib505.c
@@ -1,11 +1,11 @@
Description: Use fstat() instead of stat() to avoid a race condition.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2009-11-13
+Last-Update: 2010-03-30
--- a/tests/libtest/lib505.c
+++ b/tests/libtest/lib505.c
-@@ -56,12 +56,24 @@
+@@ -55,12 +55,24 @@
return -1;
}
@@ -32,7 +32,7 @@ Last-Update: 2009-11-13
error, strerror(error));
fprintf(stderr, "WARNING: cannot open file %s\n", libtest_arg2);
return -1;
-@@ -72,18 +84,6 @@
+@@ -71,18 +83,6 @@
return -4;
}
diff --git a/ftp/curl/files/patch-tests::libtest::lib541.c b/ftp/curl/files/patch-tests::libtest::lib541.c
index 036251f1abd6..1680725a9421 100644
--- a/ftp/curl/files/patch-tests::libtest::lib541.c
+++ b/ftp/curl/files/patch-tests::libtest::lib541.c
@@ -1,11 +1,11 @@
Description: Use fstat() instead of stat() to avoid a race condition.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2009-11-13
+Last-Update: 2010-03-30
--- a/tests/libtest/lib541.c
+++ b/tests/libtest/lib541.c
-@@ -48,12 +48,24 @@
+@@ -47,12 +47,24 @@
return -1;
}
@@ -32,7 +32,7 @@ Last-Update: 2009-11-13
error, strerror(error));
fprintf(stderr, "WARNING: cannot open file %s\n", libtest_arg2);
return -1;
-@@ -64,18 +76,6 @@
+@@ -63,18 +75,6 @@
return -4;
}
diff --git a/ftp/curl/files/patch-tests::runtests.pl b/ftp/curl/files/patch-tests::runtests.pl
index 091c225ff81b..6a7727b7f007 100644
--- a/ftp/curl/files/patch-tests::runtests.pl
+++ b/ftp/curl/files/patch-tests::runtests.pl
@@ -1,11 +1,11 @@
Description: Do not use valgrind.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2009-11-13
+Last-Update: 2010-03-30
--- a/tests/runtests.pl
+++ b/tests/runtests.pl
-@@ -88,7 +88,7 @@
+@@ -105,7 +105,7 @@
);
require "getpart.pm"; # array functions