aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/py-cmaes/Makefile25
-rw-r--r--math/py-cmaes/distinfo3
-rw-r--r--math/py-cmaes/files/pkg-message.in9
-rw-r--r--math/py-cmaes/pkg-descr4
5 files changed, 42 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index e53172a81b65..fbdaead186a0 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -746,6 +746,7 @@
SUBDIR += py-chaospy
SUBDIR += py-claripy
SUBDIR += py-cma
+ SUBDIR += py-cmaes
SUBDIR += py-colormath
SUBDIR += py-cryptominisat
SUBDIR += py-cvxopt
diff --git a/math/py-cmaes/Makefile b/math/py-cmaes/Makefile
new file mode 100644
index 000000000000..30ad3f067717
--- /dev/null
+++ b/math/py-cmaes/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= cmaes
+DISTVERSION= 0.7.0
+CATEGORIES= math # machine-learning
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= neel@neelc.org
+COMMENT= Lightweight CMA Evolution Strategy implementation for Python
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR} \
+ ${PYNUMPY}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+SUB_FILES= pkg-message
+
+.include <bsd.port.mk>
diff --git a/math/py-cmaes/distinfo b/math/py-cmaes/distinfo
new file mode 100644
index 000000000000..10bda53a0ddc
--- /dev/null
+++ b/math/py-cmaes/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608950893
+SHA256 (cmaes-0.7.0.tar.gz) = 6e5cba9f758fc02fee492d4d1e37ec2165408d5d89f422f5d963741d62af78d4
+SIZE (cmaes-0.7.0.tar.gz) = 13247
diff --git a/math/py-cmaes/files/pkg-message.in b/math/py-cmaes/files/pkg-message.in
new file mode 100644
index 000000000000..cd438590cdea
--- /dev/null
+++ b/math/py-cmaes/files/pkg-message.in
@@ -0,0 +1,9 @@
+[
+{ type: install
+ message: <<EOM
+There is no Tensorflow port currently in FreeBSD ports tree that is required
+by Keras by default. To make Keras work with Theano backend, one needs to modify
+theirs $HOME/.keras/keras.json file and set "backend" option to "theano".
+EOM
+}
+]
diff --git a/math/py-cmaes/pkg-descr b/math/py-cmaes/pkg-descr
new file mode 100644
index 000000000000..af737c32ca4b
--- /dev/null
+++ b/math/py-cmaes/pkg-descr
@@ -0,0 +1,4 @@
+CMA-ES is a Lightweight Covariance Matrix Adaptation Evolution Strategy
+(CMA-ES) implementation.
+
+WWW: https://pypi.org/project/cmaes/