aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/nginx-devel/Makefile2
-rw-r--r--www/nginx-devel/Makefile.extmod6
-rw-r--r--www/nginx-devel/files/extra-patch-rds-csv-nginx-module-config15
-rw-r--r--www/nginx-devel/files/extra-patch-rds-json-nginx-module-config15
-rw-r--r--www/nginx-devel/pkg-plist2
5 files changed, 37 insertions, 3 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 6d507a29b381..dc1b989ca000 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.18.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= www
MASTER_SITES= https://nginx.org/download/ \
LOCAL/osa
diff --git a/www/nginx-devel/Makefile.extmod b/www/nginx-devel/Makefile.extmod
index dc556f74cd46..f6d467d54e93 100644
--- a/www/nginx-devel/Makefile.extmod
+++ b/www/nginx-devel/Makefile.extmod
@@ -261,10 +261,12 @@ POSTGRES_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-ngx_postgres-config
POSTGRES_VARS= DSO_EXTMODS+=postgres
RDS_CSV_GH_TUPLE= openresty:rds-csv-nginx-module:v0.09:rdscsv
-RDS_CSV_CONFIGURE_ON= --add-module=${WRKSRC_rdscsv}
+RDS_CSV_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-rds-csv-nginx-module-config
+RDS_CSV_VARS= DSO_EXTMODS+=rdscsv
RDS_JSON_GH_TUPLE= openresty:rds-json-nginx-module:v0.15:rdsjson
-RDS_JSON_CONFIGURE_ON= --add-module=${WRKSRC_rdsjson}
+RDS_JSON_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-rds-json-nginx-module-config
+RDS_JSON_VARS= DSO_EXTMODS+=rdsjson
REDIS2_GH_TUPLE= openresty:redis2-nginx-module:v0.15:redis2
REDIS2_VARS= DSO_EXTMODS+=redis2
diff --git a/www/nginx-devel/files/extra-patch-rds-csv-nginx-module-config b/www/nginx-devel/files/extra-patch-rds-csv-nginx-module-config
new file mode 100644
index 000000000000..040c78a481e0
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-rds-csv-nginx-module-config
@@ -0,0 +1,15 @@
+--- ../rds-csv-nginx-module-0.09/config.orig 2020-04-25 11:37:21.896900000 -0400
++++ ../rds-csv-nginx-module-0.09/config 2020-04-25 11:39:06.371176000 -0400
+@@ -1,5 +1,9 @@
+ ngx_addon_name=ngx_http_rds_csv_filter_module
+-HTTP_AUX_FILTER_MODULES="$HTTP_AUX_FILTER_MODULES ngx_http_rds_csv_filter_module"
+-NGX_ADDON_SRCS="$NGX_ADDON_SRCS $ngx_addon_dir/src/ngx_http_rds_csv_filter_module.c $ngx_addon_dir/src/ngx_http_rds_csv_processor.c $ngx_addon_dir/src/ngx_http_rds_csv_util.c $ngx_addon_dir/src/ngx_http_rds_csv_output.c"
+-NGX_ADDON_DEPS="$NGX_ADDON_DEPS $ngx_addon_dir/src/ddebug.h $ngx_addon_dir/src/resty_dbd_stream.h $ngx_addon_dir/src/ngx_http_rds_csv_filter_module.h $ngx_addon_dir/src/ngx_http_rds_csv_processor.h $ngx_addon_dir/src/ngx_http_rds_csv_util.h $ngx_addon_dir/src/ngx_http_rds.h $ngx_addon_dir/src/resty_dbd_stream.h $ngx_addon_dir/src/ngx_http_rds_csv_output.h $ngx_addon_dir/src/ngx_http_rds_utils.h"
+
++ngx_module_name="$ngx_addon_name"
++ngx_module_type=HTTP_FILTER
++
++ngx_module_srcs="$ngx_addon_dir/src/ngx_http_rds_csv_filter_module.c $ngx_addon_dir/src/ngx_http_rds_csv_processor.c $ngx_addon_dir/src/ngx_http_rds_csv_util.c $ngx_addon_dir/src/ngx_http_rds_csv_output.c"
++ngx_module_deps="$ngx_addon_dir/src/ddebug.h $ngx_addon_dir/src/resty_dbd_stream.h $ngx_addon_dir/src/ngx_http_rds_csv_filter_module.h $ngx_addon_dir/src/ngx_http_rds_csv_processor.h $ngx_addon_dir/src/ngx_http_rds_csv_util.h $ngx_addon_dir/src/ngx_http_rds.h $ngx_addon_dir/src/resty_dbd_stream.h $ngx_addon_dir/src/ngx_http_rds_csv_output.h $ngx_addon_dir/src/ngx_http_rds_utils.h"
++
++. auto/module
diff --git a/www/nginx-devel/files/extra-patch-rds-json-nginx-module-config b/www/nginx-devel/files/extra-patch-rds-json-nginx-module-config
new file mode 100644
index 000000000000..f3252ac0ba50
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-rds-json-nginx-module-config
@@ -0,0 +1,15 @@
+--- ../rds-json-nginx-module-0.15/config.orig 2020-04-25 11:39:29.003855000 -0400
++++ ../rds-json-nginx-module-0.15/config 2020-04-25 11:40:18.345148000 -0400
+@@ -1,5 +1,9 @@
+ ngx_addon_name=ngx_http_rds_json_filter_module
+-HTTP_AUX_FILTER_MODULES="$HTTP_AUX_FILTER_MODULES ngx_http_rds_json_filter_module"
+-NGX_ADDON_SRCS="$NGX_ADDON_SRCS $ngx_addon_dir/src/ngx_http_rds_json_filter_module.c $ngx_addon_dir/src/ngx_http_rds_json_processor.c $ngx_addon_dir/src/ngx_http_rds_json_util.c $ngx_addon_dir/src/ngx_http_rds_json_output.c $ngx_addon_dir/src/ngx_http_rds_json_handler.c"
+-NGX_ADDON_DEPS="$NGX_ADDON_DEPS $ngx_addon_dir/src/ddebug.h $ngx_addon_dir/src/resty_dbd_stream.h $ngx_addon_dir/src/ngx_http_rds_json_filter_module.h $ngx_addon_dir/src/ngx_http_rds_json_processor.h $ngx_addon_dir/src/ngx_http_rds_json_util.h $ngx_addon_dir/src/ngx_http_rds.h $ngx_addon_dir/src/resty_dbd_stream.h $ngx_addon_dir/src/ngx_http_rds_json_output.h $ngx_addon_dir/src/ngx_http_rds_utils.h $ngx_addon_dir/src/ngx_http_rds_json_handler.h"
+
++ngx_module_name="$ngx_addon_name"
++ngx_module_type=HTTP_FILTER
++
++ngx_module_srcs="$ngx_addon_dir/src/ngx_http_rds_json_filter_module.c $ngx_addon_dir/src/ngx_http_rds_json_processor.c $ngx_addon_dir/src/ngx_http_rds_json_util.c $ngx_addon_dir/src/ngx_http_rds_json_output.c $ngx_addon_dir/src/ngx_http_rds_json_handler.c"
++ngx_module_deps="$ngx_addon_dir/src/ddebug.h $ngx_addon_dir/src/resty_dbd_stream.h $ngx_addon_dir/src/ngx_http_rds_json_filter_module.h $ngx_addon_dir/src/ngx_http_rds_json_processor.h $ngx_addon_dir/src/ngx_http_rds_json_util.h $ngx_addon_dir/src/ngx_http_rds.h $ngx_addon_dir/src/resty_dbd_stream.h $ngx_addon_dir/src/ngx_http_rds_json_output.h $ngx_addon_dir/src/ngx_http_rds_utils.h $ngx_addon_dir/src/ngx_http_rds_json_handler.h"
++
++. auto/module
diff --git a/www/nginx-devel/pkg-plist b/www/nginx-devel/pkg-plist
index ab070705cbd8..6c17b154d7be 100644
--- a/www/nginx-devel/pkg-plist
+++ b/www/nginx-devel/pkg-plist
@@ -64,6 +64,8 @@
%%DSO%%%%NAXSI%%libexec/nginx/ngx_http_naxsi_module.so
%%DSO%%%%PASSENGER%%libexec/nginx/ngx_http_passenger_module.so
%%DSO%%%%POSTGRES%%libexec/nginx/ngx_postgres_module.so
+%%DSO%%%%RDS_CSV%%libexec/nginx/ngx_http_rds_csv_filter_module.so
+%%DSO%%%%RDS_JSON%%libexec/nginx/ngx_http_rds_json_filter_module.so
%%DSO%%%%REDIS2%%libexec/nginx/ngx_http_redis2_module.so
%%DSO%%%%RTMP%%libexec/nginx/ngx_rtmp_module.so
%%DSO%%%%SET_MISC%%libexec/nginx/ngx_http_set_misc_module.so