aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/mysqlwsrep56-server/Makefile4
-rw-r--r--databases/mysqlwsrep57-server/Makefile4
-rw-r--r--databases/virtuoso/Makefile2
-rw-r--r--devel/concurrencykit/Makefile3
-rw-r--r--devel/gcc-arm-embedded/Makefile2
-rw-r--r--devel/gecode/Makefile2
-rw-r--r--devel/radare2/Makefile2
-rw-r--r--devel/smake/Makefile2
-rw-r--r--emulators/x49gp/Makefile2
-rw-r--r--games/iortcw/Makefile2
-rw-r--r--games/legesmotus/Makefile2
-rw-r--r--graphics/copperspice/Makefile2
-rw-r--r--lang/pypy/Makefile3
-rw-r--r--lang/racket/Makefile2
-rw-r--r--misc/rump/Makefile4
-rw-r--r--multimedia/mpeg_play/Makefile2
-rw-r--r--science/simlib/Makefile2
-rw-r--r--security/p5-Digest-GOST/Makefile2
-rw-r--r--security/rcracki_mt/Makefile2
-rw-r--r--sysutils/passwordsafe/Makefile2
-rw-r--r--sysutils/pesign/Makefile2
-rw-r--r--sysutils/radeontop/Makefile2
22 files changed, 27 insertions, 25 deletions
diff --git a/databases/mysqlwsrep56-server/Makefile b/databases/mysqlwsrep56-server/Makefile
index d23419f19d68..54b321355854 100644
--- a/databases/mysqlwsrep56-server/Makefile
+++ b/databases/mysqlwsrep56-server/Makefile
@@ -25,7 +25,7 @@ BROKEN_powerpc64= Does not build
DATADIR= ${PREFIX}/share/mysql
ETCDIR= ${PREFIX}/etc/mysql
-NOT_FOR_ARCHS= aarch64 armv6 powerpc64
+NOT_FOR_ARCHS= aarch64 armv6 armv7 powerpc64
NOT_FOR_ARCHS_REASON= error: Unsupported platform
USES= bison \
@@ -146,7 +146,7 @@ post-install:
${MKDIR} ${STAGEDIR}${MY_SECDIR}
${MKDIR} ${STAGEDIR}${MY_TMPDIR}
-.if ${ARCH} == "armv6"
+.if ${ARCH} == armv6 || ${ARCH} == armv7
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config.h.cmake
.endif
diff --git a/databases/mysqlwsrep57-server/Makefile b/databases/mysqlwsrep57-server/Makefile
index 020fce5f5200..ffecb2fe7ead 100644
--- a/databases/mysqlwsrep57-server/Makefile
+++ b/databases/mysqlwsrep57-server/Makefile
@@ -45,7 +45,7 @@ GH_PROJECT?= mysql-wsrep
DATADIR= ${PREFIX}/share/mysql
ETCDIR= ${PREFIX}/etc/mysql
-NOT_FOR_ARCHS= aarch64 armv6 powerpc64
+NOT_FOR_ARCHS= aarch64 armv6 armv7 powerpc64
NOT_FOR_ARCHS_REASON= Not supported platform
CMAKE_ARGS+= -DINSTALL_LAYOUT=FREEBSD \
@@ -184,7 +184,7 @@ post-install:
${MKDIR} ${STAGEDIR}${MY_SECDIR}
${MKDIR} ${STAGEDIR}${MY_TMPDIR}
-.if ${ARCH} == "armv6"
+.if ${ARCH} == armv6 || ${ARCH} == armv7
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config.h.cmake
.endif
diff --git a/databases/virtuoso/Makefile b/databases/virtuoso/Makefile
index 813fb58d6ece..e92c4eea1721 100644
--- a/databases/virtuoso/Makefile
+++ b/databases/virtuoso/Makefile
@@ -24,7 +24,7 @@ BROKEN_aarch64= Fails to link: missing sbrk
BROKEN_powerpc64= Does not compile: error: DV_INT_TAG_WORD undeclared
BROKEN_sparc64= Does not compile: error: DV_INT_TAG_WORD undeclared
-NOT_FOR_ARCHS= arm armv6 i386 mips powerpc
+NOT_FOR_ARCHS= arm armv6 armv7 i386 mips powerpc
NOT_FOR_ARCHS_REASON= can only be built on 64bit platforms
USES= gmake libtool readline uidfix ssl
diff --git a/devel/concurrencykit/Makefile b/devel/concurrencykit/Makefile
index e169816551a0..697ea9223144 100644
--- a/devel/concurrencykit/Makefile
+++ b/devel/concurrencykit/Makefile
@@ -14,9 +14,10 @@ COMMENT= Lock-free data structures for high performance concurrent systems
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-ONLY_FOR_ARCHS= aarch64 amd64 armv6 i386 powerpc powerpc64 sparc64
+ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386 powerpc powerpc64 sparc64
BROKEN_aarch64= Fails to configure: Detecting machine architecture...failed [unsupported]
BROKEN_armv6= Fails to configure: Finding suitable compiler........failed [not found]
+BROKEN_armv7= Fails to configure: Finding suitable compiler........failed [not found]
OPTIONS_DEFINE= RTM VMAPACK
OPTIONS_DEFAULT= VMAPACK
diff --git a/devel/gcc-arm-embedded/Makefile b/devel/gcc-arm-embedded/Makefile
index 16955c3cc1ed..fe52ccda3530 100644
--- a/devel/gcc-arm-embedded/Makefile
+++ b/devel/gcc-arm-embedded/Makefile
@@ -27,7 +27,7 @@ PYGDB_USES= python:2
OPTIONS_SUB= yes
-NOT_FOR_ARCHS= aarch64 arm armeb armv6 \
+NOT_FOR_ARCHS= aarch64 arm armeb armv6 armv7 \
mips mips64 mips64el mipsel mipsn32
NOT_FOR_ARCHS_REASON= Very slow to build on emulator
diff --git a/devel/gecode/Makefile b/devel/gecode/Makefile
index 9ebc010fa119..5c746bb6d11b 100644
--- a/devel/gecode/Makefile
+++ b/devel/gecode/Makefile
@@ -15,7 +15,7 @@ LICENSE_COMB= multi
LIB_DEPENDS= libmpfr.so:math/mpfr \
libgmp.so:math/gmp
-NOT_FOR_ARCHS= aarch64 armv6 mips mips64
+NOT_FOR_ARCHS= aarch64 armv6 armv7 mips mips64
NOT_FOR_ARCHS_REASON= needs code written to specify rounding control mechanism in Boost.Numeric.Interval
USES= bison gmake perl5
diff --git a/devel/radare2/Makefile b/devel/radare2/Makefile
index 6123428e0562..15e0a5927ec3 100644
--- a/devel/radare2/Makefile
+++ b/devel/radare2/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS+= pkg-config:devel/pkgconf
LIB_DEPENDS+= libcapstone.so:devel/capstone4
-NOT_FOR_ARCHS= aarch64 armv6 mips mips64 powerpc powerpc64 sparc64
+NOT_FOR_ARCHS= aarch64 armv6 armv7 mips mips64 powerpc powerpc64 sparc64
NOT_FOR_ARCHS_REASON= does not build: Unsupported BSD architecture
CONFIGURE_ARGS+= --with-syscapstone
diff --git a/devel/smake/Makefile b/devel/smake/Makefile
index 894e25f3e45f..19b2be990892 100644
--- a/devel/smake/Makefile
+++ b/devel/smake/Makefile
@@ -14,7 +14,7 @@ LICENSE_COMB= multi
LICENSE_FILE_CDDL= ${WRKSRC}/CDDL.Schily.txt
BROKEN_i386= fails to compile
-NOT_FOR_ARCHS= aarch64 armv6
+NOT_FOR_ARCHS= aarch64 armv6 armv7
NOT_FOR_ARCHS_REASON= unknown rule to build: ./RULES/arm-freebsd-/nxb-bin/usr/bin/cc.rul
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/.a.*//g}
diff --git a/emulators/x49gp/Makefile b/emulators/x49gp/Makefile
index 732149c12dab..fa19784c046d 100644
--- a/emulators/x49gp/Makefile
+++ b/emulators/x49gp/Makefile
@@ -16,7 +16,7 @@ COMMENT= HP 49g+/50g graphics calculator emulator
BROKEN_i386= does not build on i386 (error: frame pointer required, but reserved)
BROKEN_powerpc64= fails to build: qemu/qemu-git/arm-softmmu/i386-dis.o: No such file or directory
-NOT_FOR_ARCHS= aarch64 armv6
+NOT_FOR_ARCHS= aarch64 armv6 armv7
NOT_FOR_ARCHS_REASON= unsupported CPU = unknown
WRKSRC= ${WRKDIR}/x49gp/x49gp-code
diff --git a/games/iortcw/Makefile b/games/iortcw/Makefile
index ea95ff8ac418..ecd3f2c4e679 100644
--- a/games/iortcw/Makefile
+++ b/games/iortcw/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libopus.so:audio/opus \
libfreetype.so:print/freetype2
-NOT_FOR_ARCHS= aarch64 armv6 powerpc64
+NOT_FOR_ARCHS= aarch64 armv6 armv7 powerpc64
NOT_FOR_ARCHS_REASON= fails to configure: Architecture not supported
USES= jpeg pkgconfig gmake
diff --git a/games/legesmotus/Makefile b/games/legesmotus/Makefile
index 1597624f165e..68f0ad9ad430 100644
--- a/games/legesmotus/Makefile
+++ b/games/legesmotus/Makefile
@@ -13,7 +13,7 @@ COMMENT= Team-based, networked, 2D shooter set in zero-gravity
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-NOT_FOR_ARCHS= aarch64 armv6
+NOT_FOR_ARCHS= aarch64 armv6 armv7
NOT_FOR_ARCHS_REASON= fails to build: Disallowed architecture for this platform
HAS_CONFIGURE= yes
diff --git a/graphics/copperspice/Makefile b/graphics/copperspice/Makefile
index 6cd3c38ba15f..5c9dd3a92207 100644
--- a/graphics/copperspice/Makefile
+++ b/graphics/copperspice/Makefile
@@ -48,7 +48,7 @@ PLIST_SUB= LONG_VER=1.3
BROKEN_i386= qx11embed_x11.cpp:470:20: non-constant-expression\
cannot be narrowed from type 'unsigned int' to 'long'\
in initializer list [-Wc++11-narrowing]
-NOT_FOR_ARCHS= aarch64 armv6 powerpc64
+NOT_FOR_ARCHS= aarch64 armv6 armv7 powerpc64
NOT_FOR_ARCHS_REASON= fails to build: Unable to detect architecture, please update
post-patch:
diff --git a/lang/pypy/Makefile b/lang/pypy/Makefile
index 9bd230a346bf..36193208d5e9 100644
--- a/lang/pypy/Makefile
+++ b/lang/pypy/Makefile
@@ -21,10 +21,11 @@ TEST_DEPENDS= ${LOCALBASE}/${PYPY_DIR}/lib_pypy/_gdbm_cffi.${PYPY_CFFI_VER}.so:d
${LOCALBASE}/${PYPY_DIR}/lib_pypy/_sqlite3_cffi.${PYPY_CFFI_VER}.so:databases/pypy-sqlite3 \
${LOCALBASE}/${PYPY_DIR}/lib_pypy/_tkinter/tklib_cffi.${PYPY_CFFI_VER}.so:x11-toolkits/pypy-tkinter
-ONLY_FOR_ARCHS?=i386 amd64 armv6 powerpc64
+ONLY_FOR_ARCHS?= amd64 armv6 armv7 i386 powerpc64
ONLY_FOR_ARCHS_REASON?= PyPy JIT only supported on these architectures
BROKEN_armv6= fails to package: pypy_objspace_std.c: Crash in JIT!
+BROKEN_armv7= fails to package: pypy_objspace_std.c: Crash in JIT!
BROKEN_powerpc64= fails to compile: platcheck_109.c: fatal error: linux/auxvec.h: No such file or directory
OPTIONS_SINGLE= TRANS
diff --git a/lang/racket/Makefile b/lang/racket/Makefile
index 8f16c21ea550..ee4946ee6666 100644
--- a/lang/racket/Makefile
+++ b/lang/racket/Makefile
@@ -26,7 +26,7 @@ BROKEN_powerpc64= fails to build: jit.c: 'JIT_LOCAL4' undeclared (first use in t
BROKEN_FreeBSD_10_i386= segfaults during build
BROKEN_FreeBSD_11_i386= segfaults during build
BROKEN_FreeBSD_12_i386= segfaults during build
-NOT_FOR_ARCHS= aarch64 armv6 sparc64
+NOT_FOR_ARCHS= aarch64 armv6 armv7 sparc64
NOT_FOR_ARCHS_REASON= not yet ported to this arch
MAKE_JOBS_UNSAFE=yes
diff --git a/misc/rump/Makefile b/misc/rump/Makefile
index 52bc21432ee0..c6cd4bcc7b39 100644
--- a/misc/rump/Makefile
+++ b/misc/rump/Makefile
@@ -11,7 +11,7 @@ COMMENT= Virtualized NetBSD kernel components in userspace
LICENSE= BSD2CLAUSE
-NOT_FOR_ARCHS= armv6 mips mips64 powerpc powerpc64 sparc64
+NOT_FOR_ARCHS= armv6 armv7 mips mips64 powerpc powerpc64 sparc64
NOT_FOR_ARCHS_REASON= not yet ported to FreeBSD on this architecture
USE_GITHUB= yes
@@ -23,7 +23,7 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386" || ${ARCH} == "amd64"
+.if ${ARCH} == amd64 || ${ARCH} == i386
PLIST_SUB+= X8664=""
.else
PLIST_SUB+= X8664="@comment "
diff --git a/multimedia/mpeg_play/Makefile b/multimedia/mpeg_play/Makefile
index 1b078ebe8a03..1bc06ec4e2e9 100644
--- a/multimedia/mpeg_play/Makefile
+++ b/multimedia/mpeg_play/Makefile
@@ -12,7 +12,7 @@ EXTRACT_SUFX= -patched-src.tar.gz
MAINTAINER= lme@FreeBSD.org
COMMENT= Program to play mpeg movies on X displays
-NOT_FOR_ARCHS= aarch64 armv6 mips mips64
+NOT_FOR_ARCHS= aarch64 armv6 armv7 mips mips64
NOT_FOR_ARCHS_REASON= fails to build: Unknown endianness of architecture
WRKSRC= ${WRKDIR}/mpeg_play
diff --git a/science/simlib/Makefile b/science/simlib/Makefile
index 4de04dd526c1..fa3b6d83614c 100644
--- a/science/simlib/Makefile
+++ b/science/simlib/Makefile
@@ -17,7 +17,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
CXXFLAGS+= -fPIC
-NOT_FOR_ARCHS= aarch64 armv6 mips mips64 powerpc powerpc64 sparc64
+NOT_FOR_ARCHS= aarch64 armv6 armv7 mips mips64 powerpc powerpc64 sparc64
NOT_FOR_ARCHS_REASON= contains not working ${ARCH}-dependent assembly code
post-patch:
diff --git a/security/p5-Digest-GOST/Makefile b/security/p5-Digest-GOST/Makefile
index 92cc0a5a83f5..d2ba55c0a99c 100644
--- a/security/p5-Digest-GOST/Makefile
+++ b/security/p5-Digest-GOST/Makefile
@@ -12,7 +12,7 @@ COMMENT= Perl interface to the GOST R 34.11-94 digest algorithm
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-NOT_FOR_ARCHS= aarch64 armv6 mips64
+NOT_FOR_ARCHS= aarch64 armv6 armv7 mips64
NOT_FOR_ARCHS_REASON= fails to build: Cannot detect CPU architechture
USES= perl5
diff --git a/security/rcracki_mt/Makefile b/security/rcracki_mt/Makefile
index 816be5504bd6..2e97d8df9fe8 100644
--- a/security/rcracki_mt/Makefile
+++ b/security/rcracki_mt/Makefile
@@ -11,7 +11,7 @@ COMMENT= Rainbow table based crack tool
LICENSE= GPLv2
-NOT_FOR_ARCHS= aarch64 armv6 mips mips64 sparc64
+NOT_FOR_ARCHS= aarch64 armv6 armv7 mips mips64 sparc64
NOT_FOR_ARCHS_REASON= cannot detect endianness
WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
diff --git a/sysutils/passwordsafe/Makefile b/sysutils/passwordsafe/Makefile
index c64d2257c15c..e2af63c37c7b 100644
--- a/sysutils/passwordsafe/Makefile
+++ b/sysutils/passwordsafe/Makefile
@@ -13,7 +13,7 @@ LIB_DEPENDS= libuuid.so:misc/e2fsprogs-libuuid \
libxerces-c.so:textproc/xerces-c3
BUILD_DEPENDS= zip:archivers/zip
-NOT_FOR_ARCHS= aarch64 armv6
+NOT_FOR_ARCHS= aarch64 armv6 armv7
NOT_FOR_ARCHS_REASON= Cannot determine whether the target CPU is big or little endian - please fix PwsPlatform.h
CONFLICTS= pwsafe-[0-9]*
diff --git a/sysutils/pesign/Makefile b/sysutils/pesign/Makefile
index 8a382cef1176..9a9ad1b6b69c 100644
--- a/sysutils/pesign/Makefile
+++ b/sysutils/pesign/Makefile
@@ -24,7 +24,7 @@ GH_ACCOUNT= rhinstaller
USES= gmake localbase pkgconfig
USE_LDCONFIG= yes
-ONLY_FOR_ARCHS= aarch64 armv6 amd64 i386
+ONLY_FOR_ARCHS= aarch64 armv6 armv7 amd64 i386
ONLY_FOR_ARCHS_REASON= UEFI specification only supports little-endian processors
BROKEN_armv6= fails to compile: error: EFI_VARIABLE_NON_VOLATILE redefined
diff --git a/sysutils/radeontop/Makefile b/sysutils/radeontop/Makefile
index 88ee6926f344..d30dfbba9fd1 100644
--- a/sysutils/radeontop/Makefile
+++ b/sysutils/radeontop/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv3
LIB_DEPENDS= libpciaccess.so:devel/libpciaccess \
libdrm.so:graphics/libdrm
-NOT_FOR_ARCHS= aarch64 armv6 mips mips64
+NOT_FOR_ARCHS= aarch64 armv6 armv7 mips mips64
NOT_FOR_ARCHS_REASON= fails to compile: fatal error: amdgpu_drm.h file not found
USE_GITHUB= yes